PowerStore: Create clone of NAS server failing with error "The maximum number of file system has been reached. (0xE080100D0029)"
Summary: Create clone of NAS server may fail with error "The maximum number of file system has been reached. (0xE080100D0029)" even though limit is not reached. This article provides a workaround to create the NAS server. ...
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Symptoms
When a user tries to create the clone of a NAS server by selecting all the file systems within the PowerStore Manager NAS server or without specifying file_systems parameter (REST), the operation fails with the error The maximum number of file system (<file system limit value>) has been reached. (0xE080100D0029), even if the number of file systems in the appliance has not reached the limits.
Cause
This issue occurs in certain situations where the source NAS server has a lot of snapshots created on the file systems and they are counted in the limit calculation.
Resolution
This issue is planned to be addressed in a future release of PowerStore.
In the meantime, use the following workarounds:
- Remove the unwanted snapshots from the NAS server reducing the overall count of snapshots within the NAS server.
- Select a subset of file systems within the NAS server while cloning the NAS server in the PowerStore UI.
- Explicitly specify the required file systems to be cloned with the NAS server in REST call.
Affected Products
PowerStoreArticle Properties
Article Number: 000210996
Article Type: Solution
Last Modified: 13 Jun 2025
Version: 5
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