IDPA ESXi-opgradering mislykkes med fejlmeddelelsen "[Afhængighedsfejl] Filstien "/opt/lsi/perccli/libstorelib.so" hævdes af flere ikke-overliggende VIB'er"
Zusammenfassung: Denne KB artikel gennemger et problem, der er påvist under IDPA-opgradering, hvor ESXi-opgraderingen ikke lykkes på grund af afhængighedsfejl.
Dieser Artikel gilt für
Dieser Artikel gilt nicht für
Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden.
In diesem Artikel werden nicht alle Produktversionen aufgeführt.
Symptome
Følgende fejl kan ses på ESXi-opgraderingsloggen på ACM på stien "/data01/tmp/patch/logs" :
6/03/20 17:23:16 main() Package name: IDPA-13G-ESXi-6.5.0-002
26/03/20 17:23:16 main() Executing install packages command: esxcli software profile update --depot=https://192.168.100.100:9443/dataprotection-upgrade/esxi_upgrade --profile=IDPA-13G-ESXi-6.5.0-002
26/03/20 17:23:19 run() Parsing returnCode, output: ['', "[DependencyError]\r\n File path of '/opt/lsi/perccli/libstorelib.so' is claimed by multiple non-overlay VIBs: set(['LSI_bootbank_vmware-perccli-007.0529.0000.0000_007.0529.0000.0000-01', 'LSI_bootbank_perccli_007.0127.0000.0000-2'])\r\n File path of '/opt/lsi/perccli/perccli' is claimed by multiple non-overlay VIBs: set(['LSI_bootbank_vmware-perccli-007.0529.0000.0000_007.0529.0000.0000-01', 'LSI_bootbank_perccli_007.0127.0000.0000-2'])\r\n Please refer to the log file for more details.", 'Status: 1']
26/03/20 17:23:19 run_cmd_esxi() Command: esxcli software profile update --depot=https://192.168.100.100:9443/dataprotection-upgrade/esxi_upgrade --profile=IDPA-13G-ESXi-6.5.0-002
26/03/20 17:23:19 run_cmd_esxi() [DependencyError]
26/03/20 17:23:19 run_cmd_esxi() File path of '/opt/lsi/perccli/libstorelib.so' is claimed by multiple non-overlay VIBs: set(['LSI_bootbank_vmware-perccli-007.0529.0000.0000_007.0529.0000.0000-01', 'LSI_bootbank_perccli_007.0127.0000.0000-2'])
26/03/20 17:23:19 run_cmd_esxi() File path of '/opt/lsi/perccli/perccli' is claimed by multiple non-overlay VIBs: set(['LSI_bootbank_vmware-perccli-007.0529.0000.0000_007.0529.0000.0000-01', 'LSI_bootbank_perccli_007.0127.0000.0000-2'])
26/03/20 17:23:19 run_cmd_esxi() Please refer to the log file for more details.
26/03/20 17:23:19 run_cmd_esxi() Status: 1
26/03/20 17:23:19 main() Install packages command result: 1
26/03/20 17:23:19 main() Failed to install packages.
Ursache
'vmware-perccli-007.0529.0000.0000_007.0529.0000.0000-01' VIB installeret på ESXi-værten er årsag til dette problem
Lösung
Trin 1. Kør SSH på den pågældende ESXi-vært.
Trin 2. Kør følgende kommando for at fjerne den uoverensstemmende VIB:
[root@esx1:~] esxcli software vib remove --vibname vmware-perccli-007.0529.0000.0000
Removal Result
Message: Operation finished successfully.
Reboot Required: false
VIBs Installed:
VIBs Removed: LSI_bootbank_vmware-perccli-007.0529.0000.0000_007.0529.0000.0000-01
VIBs Skipped:
Trin 3. Kontroller, at VIB blev fjernet:
Trin 4: Prøv at udføre ESXi-opgraderingen igen fra ACM-brugergrænsefladen.
Trin 2. Kør følgende kommando for at fjerne den uoverensstemmende VIB:
- esxcli software vib remove --vibname vmware-perccli-007.0529.0000.0000
[root@esx1:~] esxcli software vib remove --vibname vmware-perccli-007.0529.0000.0000
Removal Result
Message: Operation finished successfully.
Reboot Required: false
VIBs Installed:
VIBs Removed: LSI_bootbank_vmware-perccli-007.0529.0000.0000_007.0529.0000.0000-01
VIBs Skipped:
Trin 3. Kontroller, at VIB blev fjernet:
- esxcli software vib list| grep -i perccli
Trin 4: Prøv at udføre ESXi-opgraderingen igen fra ACM-brugergrænsefladen.
Betroffene Produkte
Integrated Data Protection Appliance FamilyProdukte
PowerProtect DP5300, PowerProtect DP5800, PowerProtect DP8300, PowerProtect DP8800, PowerProtect Data Protection Software, Integrated Data Protection Appliance Family, PowerProtect Data Protection Hardware
, Integrated Data Protection Appliance Software
...
Artikeleigenschaften
Artikelnummer: 000173292
Artikeltyp: Solution
Zuletzt geändert: 27 Mai 2025
Version: 3
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.