PowerStore-Warnmeldungen: System hat volle Kapazität erreicht

Zusammenfassung: In diesem Artikel werden Warnmeldungen in Bezug auf den Schreibschutzmodus (WPM) mit voller Kapazität und die daraus resultierenden Warnmeldungen beschrieben.

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

Wenn in einem PowerStore ein Problem auftritt, wird eine Fehlermeldung erzeugt, um das Problem zu identifizieren. In diesem Artikel werden die verschiedenen möglichen Ursachen und die relevanten Lösungen für diese Fehlermeldungen erläutert. Wenn Ihr Problem trotz der bereitgestellten Lösung nicht behoben wird, nutzen Sie die Kontaktoptionen des technischen Supports.
 

SLN317187_en_US__1icon Hinweis: Sie können die benötigten Informationen nicht finden? Lassen Sie es uns über das Feedback-Formular am Ende dieses Artikels wissen.


Ursache

Wenn eine Appliance ihre volle Kapazität erreicht, tritt sie in einen Zustand ein, der als Schreibschutzmodus (WPM) bezeichnet wird. In WPM sind alle Volumes schreibgeschützt und eine Reparatur des Systems ist erforderlich.

Eine Erläuterung zur Berechnung der physischen Kapazität finden Sie im KB-Artikel 188491: PowerStore: Wie die physische Kapazität von PowerStore berechnet wird.

Lösung

Warnmeldungs-ID
DATA_PATH_WRITE_PROTECT_MODE_ENTER DATA_PATH_APP_EXIT_WPM_WITH_ENOUGH_MD_NOTIFY
DATA_PATH_APP_WPM_SHORT_OF_MD_NOTIFY
Warnmeldungstext Die <Nutzer - oder Systemdatenkapazität > hat ihre volle Kapazität erreicht.
Die Appliance hat den Schreibschutzstatus mit 16 GB freier Kapazität beendet.
Die Appliance kann den Schreibschutzmodus aufgrund unzureichender Systemdatenkapazität nicht beenden.
Fehlercode (0x00200701)
(0x00201401)
(0x00201501)
Auflösung Was passiert, wenn man sich im Schreibschutzmodus (WPM) befindet?
Wenn eine Appliance ihre volle Kapazität erreicht, tritt sie in einen Zustand ein, der als Schreibschutzmodus (WPM) bezeichnet wird und in dem alle Volumes in den schreibgeschützten Modus versetzt werden.
  • Die Warnmeldung 0x00B00702 (Warnmeldungstext: Servicelevel heruntergestuft, Managementfunktionen sind eingeschränkt und I/O beeinträchtigt) angehoben wird.
  • I/O-Schreibvorgänge schlagen fehl
  • Vorgänge wie Snapshots und Replikation sind möglicherweise deaktiviert.
  • Alle Kennzahlen (Kapazität und Performance) sind nicht verfügbar. In PowerStore 3.0 und höher wird die Metriktabelle in WPM aktualisiert.
Empfehlung: Das System sollte den Schwellenwert von 85 % nicht überschreiten.
 

Eine Erläuterung zur Berechnung der physischen Kapazität finden Sie im KB-Artikel 188491: PowerStore: Wie die physische Kapazität von PowerStore berechnet wird.


Ursache

Die physische Gesamtkapazität von PowerStore setzt sich aus Nutzerdaten und Systemdaten zusammen.

Unter PowerStoreOS 3.0 und höher wird Folgendes in PowerStore Manager angezeigt. Dem Benutzer wird eine genauere Aufschlüsselung der Benutzerdaten und der Systemdaten angezeigt:
image.png
Auf PowerStoreOS unter 3.0 wird Folgendes in PowerStore Manager angezeigt. Dem Nutzer wird nur eine Aufschlüsselung der physisch genutzten Kapazität angezeigt:

festzulegen:
image.png

 

Wenn das System eine Kapazität von 70 % erreicht, werden Warnmeldungen ausgegeben, um vor mangelndem Speicherplatz zu warnen. Siehe Wissensdatenbank-Artikel 000123351: PowerStore-Warnmeldungen: Kapazitätsauslastung.

Wenn der Nutzer keine Aktion ausführt und das System 100 % erreicht, wechselt das System in den Schreibschutzmodus (WPM), was darauf hinweist, dass alle Volumes in den schreibgeschützten Modus wechseln, und die Warnmeldung 0x00200701 wird ausgelöst.

Warnmeldung 0x00200701 weist auf ein Speicherplatzproblem mit Nutzerdaten oder Systemdaten hin.

Hinweis: Wenn ein Node über einen längeren Zeitraum ausfällt, kann dies zu einer Erhöhung der physischen Kapazität führen.

Wie ermitteln wir die Ursache für das WPM:

Der Nutzer kann die Ursache der WPM-Bedingung basierend auf dem Warnmeldungstext bestimmen:

  • Nutzerdaten – (0x00200701) Die Nutzerdaten haben ihre volle Kapazität erreicht.
  • Systemdaten – (0x00200701) Die Systemdaten haben ihre volle Kapazität erreicht.

Je nach Art der WPM-Bedingung (Benutzerdaten oder Systemdaten) wird der Workaround bestimmt.



Lösung

Die Wiederherstellung nach einem OOS-Zustand hängt vom Grund für das OOS ab. Die Ursache für die WPM-Bedingung ist im Text der Warnmeldung enthalten:

  • Nutzerdaten – (0x00200701) Die Nutzerdaten haben ihre volle Kapazität erreicht.
  • Systemdaten – (0x00200701) Die Systemdaten haben ihre volle Kapazität erreicht.

Je nach Art der WPM-Bedingung (Nutzerdaten oder Systemdaten) wird der Workaround bestimmt.


 

1. Benutzerdaten

Verwenden Sie eine der folgenden Optionen:

  • Add Drives: (Dies ist die empfohlene Option).
    • Wenden Sie sich an Ihr Account-Team, um Ihre Kapazitätsanforderungen zu analysieren und weitere Laufwerke hinzuzufügen.
  • Löschen von Volumes und/oder Snapshots.
    • Wenn NutzerInnen Informationen darüber benötigen, welche Volumes oder Snapshots gelöscht werden sollen, wenden Sie sich an Global Services, um Unterstützung zu erhalten.

Weitere Informationen

  1. Bevor Sie Aktionen ausführen, sollten Sie Folgendes tun:
    1. Stoppen Sie alle I/O-Vorgänge zum Array (FC/iSCSI-Ports auf dem Switch deaktivieren), um zu vermeiden, dass WPM erneut auftritt.
    2. Halten Sie alle Snapshot-Zeitpläne, die Replikation und jegliche externe Automatisierung im Zusammenhang mit dem Volume-Management an.
  2. Um den WPM-Zustand zu beenden, muss die Appliance mindestens 16 GB Speicherplatz zurückgewinnen. Dazu muss der Nutzer ein Volume mit mindestens 16 GB eindeutiger Daten löschen.
    Wenn es dem Nutzer gelingt, diesen Speicherplatz zurückzugewinnen und ausreichend Speicherplatz für Systemdaten vorhanden ist, wird die Warnmeldung 0x00200701 (Warnmeldungstext: Die Nutzerdaten haben ihre volle Kapazität erreicht) und Warnmeldung 0x00201401(Warnmeldungstext: Die Appliance hat den Schreibschutzstatus mit 16 GB freier Kapazität beendet.) erscheint.
  3. Sobald sich die Volumes in diesem Status befinden, wechseln sie in den Lese-/Schreibzugriff und der Nutzer sollte weiterhin Speicherplatz zurückgewinnen, bis die Appliance 85 % der genutzten physischen Kapazität erreicht.
    1. Es wird dringend empfohlen, Volumes oder Snapshots einzeln zu löschen.
    2. Anweisungen zum Zurückgewinnen von Speicherplatz von der Hostseite finden Sie im Handbuch des jeweiligen Betriebssystems.
  4. Sobald 85 % der genutzten physischen Kapazität erreicht sind, muss der Nutzer die Warnmeldung manuell löschen 0x00201401.
  5. Hinweis: Die Rückgewinnung von Speicherplatz durch das Löschen von Snapshots oder Volumes erfordert zunächst zusätzlichen Speicherplatz für Systemdaten und kann daher zu Warnmeldungen 0x00201501 (Warnmeldungstext: Die Appliance kann den Schreibschutzmodus aufgrund unzureichender Systemdatenkapazität nicht beenden.
  6. Mit PowerStoreOS 1.0.3 wurde ein neues Serviceskript (svc_volume_space_metrics) eingeführt, mit dem der Nutzer zusätzliche Informationen zu Volume-Speicherplatzstatistiken anzeigen kann, wenn sich die Appliance im WPM befindet.
    Weitere Informationen finden Sie im Abschnitt "Verwendung von svc_volume_space_metrics" weiter unten in diesem Wissensdatenbank-Artikel.
 

2. Systemdaten

Verwenden Sie eine der folgenden Optionen:

  • Add Drives: (Dies ist die empfohlene Option).
    • Wenden Sie sich an Ihr Account-Team, um Ihre Kapazitätsanforderungen zu analysieren und weitere Laufwerke hinzuzufügen.
  • Wenn der Nutzer keine Laufwerke hinzufügen kann, wenden Sie sich an den technischen Support, um Unterstützung zu erhalten.
Diese Informationen können über das Volume Capacity Dashboard angezeigt werden.
In diesem Beispiel werden durch das Löschen des folgenden Volumes 59,8 GB Speicherplatz zurückgewonnen, der entweder für Nutzerdaten oder für Systemdaten verwendet werden kann.

Beachten Sie, dass Systemdaten mindestens ca. 100 GB eindeutigen Speicherplatz benötigen, um erweitert werden zu können. Manchmal sind für eine ordnungsgemäße Erweiterung 200 GB Speicherplatz erforderlich.
image.png


Weitere Informationen

  1. Wenn eine Appliance aufgrund von Systemdaten in WPM wechselt, haben Nutzerdaten in der Regel auch keinen Speicherplatz mehr. 
    Dies liegt daran, dass keine Kapazität mehr für die Erweiterung (Systemdaten oder Benutzerdaten) vorhanden ist.
  2. Um aus WPM herauszukommen, muss der Nutzer in der Regel zusätzliche Laufwerke hinzufügen und die Appliance skalieren.
  3. Wenn das System die Warnmeldung auslöst 0x00200701 (Warnmeldungstext: Die Systemkapazität hat die volle Kapazität erreicht.) klicken, weist dies darauf hin, dass der Speicherplatz unter "System Data" knapp geworden ist und nicht erweitert werden kann.
  4. Vermeiden Sie das Löschen von Volumes in diesem Zustand und eskalieren Sie zur Unterstützung an Global Services. 



Verwendung von svc_volume_space_metrics

  1. Mit PowerStoreOS 1.0.3 wurde ein Serviceskript eingeführt, mit dem Nutzer in WPM zusätzliche Informationen zu jeder Volume-Struktur anzeigen können.
  2. Um das Skript auszuführen, muss SSH auf der angegebenen Appliance aktiviert sein und der Nutzer muss über SSH eine Verbindung zur Cluster-IP über das Servicekonto herstellen.
  3. Wenn Sie versuchen, dieses Serviceskript auszuführen, während Sie sich nicht in WPM befinden, schlägt das Serviceskript fehl.

  4. Wenn auf der Appliance kein Speicherplatz mehr vorhanden ist, kann der Nutzer das Skript ausführen und zusätzliche Informationen anzeigen, z. B.:
    Family Unique Physical Used: Dies stellt die eindeutigen Daten (komprimiert) dieses Volume und alle seine Produktreihen (Snapshots und Clones) dar, die freigegeben werden, wenn dieses Volume gelöscht wird.
    Beispiel: 

    [SVC:service@68R1BW2-A user]$ svc_volume_space_metrics
    2020-10-29 12:28:33,997 - INFO - event_client init() address: localhost node: A
    2020-10-29 12:28:34,248 - INFO -  PyCycloneDp.init localhost
    2020-10-29 12:28:34,318 - PyCycloneDp - INFO - logging in PyCycloneDp.__init__
      
    Namespace state is ro-oos
    Retrieve family space stats from DP namespace. It will take some time...
    2020-10-29 12:28:35,972 - INFO - event_client init() address: localhost node: A
    2020-10-29 12:28:36,175 - INFO -  PyCycloneDp.init localhost
    2020-10-29 12:28:36,220 - PyCycloneDp - INFO - logging in PyCycloneDp.__init__
      
    --------------------------------------+------------------------------------------------------+-------------+----------------+----------------+-----------+----------
                  Family ID               |             Primary Volume/FS/vVol Name              |     Type    | Family Unique  | Family Shared  |   No. of  |  No. of
                                          |                                                      |             | Physical Used  |  Logical Used  |   Clones  | Snapshots
    --------------------------------------+------------------------------------------------------+-------------+----------------+----------------+-----------+----------
     d301959c-6eb9-4e23-967a-e0b3cdf06bea |                     labtea-vol-1                     |Block        |        97.91 GB|       486.36 GB|     0     |     1
     6c97fdd8-5b01-44ef-adaf-047449f83c27 |                     labtea-vol-2                     |Block        |        99.47 GB|       492.30 GB|     0     |     1

     


 
Warnmeldungs-ID DATA_PATH_WRITE_PROTECT_MODE_EXTREMELY_HIGH 
Warnmeldungstext Die Speicherplatzauslastung von %(tier_name) ist extrem hoch.
Fehlercode 0x00200703
Auswirkungen Mehrere interne Services (z. B. NAS und UI) funktionieren möglicherweise nicht optimal.
Auflösung  Ursache:
Ein Teil der Appliance-Kapazität ist für interne Services reserviert (z. B. NAS-Core-Services, Datenerfassungen, interne Datenbanken und mehr).
Wenn die Appliance den Schreibschutzmodus (0x00200701) erreicht, kann der Nutzer keine Daten mehr schreiben, interne Services können jedoch weiterhin auf kritische Informationen zugreifen (nur ab PowerStoreOS 3.0). Sobald auch die intern reservierte Kapazität erschöpft ist, wird diese Warnmeldung ausgegeben, CP und SDNAS (und andere Services) funktionieren möglicherweise nicht optimal.

Lösung:
Wenden Sie sich an den technischen Support , um sofortige Unterstützung zu erhalten.

Weitere Informationen

Bekannte Probleme:

Betroffene Produkte

PowerStore
Artikeleigenschaften
Artikelnummer: 000193645
Artikeltyp: Solution
Zuletzt geändert: 13 Juni 2025
Version:  7
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