PowerStore-Warnmeldungen: System hat volle Kapazität erreicht
Zusammenfassung: In diesem Artikel werden Warnmeldungen in Bezug auf den Schreibschutzmodus (WPM) mit voller Kapazität und die daraus resultierenden Warnmeldungen beschrieben.
Symptome
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Ursache
Eine Erläuterung zur Berechnung der physischen Kapazität finden Sie im KB-Artikel 188491: PowerStore: Wie die physische Kapazität von PowerStore berechnet wird.
Lösung
| Warnmeldungs-ID | DATA_PATH_WRITE_PROTECT_MODE_ENTER DATA_PATH_APP_EXIT_WPM_WITH_ENOUGH_MD_NOTIFY DATA_PATH_APP_WPM_SHORT_OF_MD_NOTIFY |
| Warnmeldungstext | Die <Nutzer - oder Systemdatenkapazität > hat ihre volle Kapazität erreicht. Die Appliance hat den Schreibschutzstatus mit 16 GB freier Kapazität beendet. Die Appliance kann den Schreibschutzmodus aufgrund unzureichender Systemdatenkapazität nicht beenden. |
| Fehlercode | (0x00200701) (0x00201401) (0x00201501) |
| Auflösung | Was passiert, wenn man sich im Schreibschutzmodus (WPM) befindet? Wenn eine Appliance ihre volle Kapazität erreicht, tritt sie in einen Zustand ein, der als Schreibschutzmodus (WPM) bezeichnet wird und in dem alle Volumes in den schreibgeschützten Modus versetzt werden.
Eine Erläuterung zur Berechnung der physischen Kapazität finden Sie im KB-Artikel 188491: PowerStore: Wie die physische Kapazität von PowerStore berechnet wird. Die physische Gesamtkapazität von PowerStore setzt sich aus Nutzerdaten und Systemdaten zusammen. festzulegen: Wenn das System eine Kapazität von 70 % erreicht, werden Warnmeldungen ausgegeben, um vor mangelndem Speicherplatz zu warnen. Siehe Wissensdatenbank-Artikel 000123351: PowerStore-Warnmeldungen: Kapazitätsauslastung. Wenn der Nutzer keine Aktion ausführt und das System 100 % erreicht, wechselt das System in den Schreibschutzmodus (WPM), was darauf hinweist, dass alle Volumes in den schreibgeschützten Modus wechseln, und die Warnmeldung 0x00200701 wird ausgelöst. Warnmeldung 0x00200701 weist auf ein Speicherplatzproblem mit Nutzerdaten oder Systemdaten hin. Wie ermitteln wir die Ursache für das WPM: Der Nutzer kann die Ursache der WPM-Bedingung basierend auf dem Warnmeldungstext bestimmen:
Je nach Art der WPM-Bedingung (Benutzerdaten oder Systemdaten) wird der Workaround bestimmt. Lösung Die Wiederherstellung nach einem OOS-Zustand hängt vom Grund für das OOS ab. Die Ursache für die WPM-Bedingung ist im Text der Warnmeldung enthalten:
Je nach Art der WPM-Bedingung (Nutzerdaten oder Systemdaten) wird der Workaround bestimmt. 1. BenutzerdatenVerwenden Sie eine der folgenden Optionen:
Weitere Informationen
2. SystemdatenVerwenden Sie eine der folgenden Optionen:
In diesem Beispiel werden durch das Löschen des folgenden Volumes 59,8 GB Speicherplatz zurückgewonnen, der entweder für Nutzerdaten oder für Systemdaten verwendet werden kann. Beachten Sie, dass Systemdaten mindestens ca. 100 GB eindeutigen Speicherplatz benötigen, um erweitert werden zu können. Manchmal sind für eine ordnungsgemäße Erweiterung 200 GB Speicherplatz erforderlich. |
Weitere Informationen
- Wenn eine Appliance aufgrund von Systemdaten in WPM wechselt, haben Nutzerdaten in der Regel auch keinen Speicherplatz mehr.
Dies liegt daran, dass keine Kapazität mehr für die Erweiterung (Systemdaten oder Benutzerdaten) vorhanden ist. - Um aus WPM herauszukommen, muss der Nutzer in der Regel zusätzliche Laufwerke hinzufügen und die Appliance skalieren.
- Wenn das System die Warnmeldung auslöst 0x00200701 (Warnmeldungstext: Die Systemkapazität hat die volle Kapazität erreicht.) klicken, weist dies darauf hin, dass der Speicherplatz unter "System Data" knapp geworden ist und nicht erweitert werden kann.
- Vermeiden Sie das Löschen von Volumes in diesem Zustand und eskalieren Sie zur Unterstützung an Global Services.
Verwendung von svc_volume_space_metrics
- Mit PowerStoreOS 1.0.3 wurde ein Serviceskript eingeführt, mit dem Nutzer in WPM zusätzliche Informationen zu jeder Volume-Struktur anzeigen können.
- Um das Skript auszuführen, muss SSH auf der angegebenen Appliance aktiviert sein und der Nutzer muss über SSH eine Verbindung zur Cluster-IP über das Servicekonto herstellen.
-
Wenn Sie versuchen, dieses Serviceskript auszuführen, während Sie sich nicht in WPM befinden, schlägt das Serviceskript fehl.
-
Wenn auf der Appliance kein Speicherplatz mehr vorhanden ist, kann der Nutzer das Skript ausführen und zusätzliche Informationen anzeigen, z. B.:
Family Unique Physical Used: Dies stellt die eindeutigen Daten (komprimiert) dieses Volume und alle seine Produktreihen (Snapshots und Clones) dar, die freigegeben werden, wenn dieses Volume gelöscht wird.
Beispiel:[SVC:service@68R1BW2-A user]$ svc_volume_space_metrics 2020-10-29 12:28:33,997 - INFO - event_client init() address: localhost node: A 2020-10-29 12:28:34,248 - INFO - PyCycloneDp.init localhost 2020-10-29 12:28:34,318 - PyCycloneDp - INFO - logging in PyCycloneDp.__init__ Namespace state is ro-oos Retrieve family space stats from DP namespace. It will take some time... 2020-10-29 12:28:35,972 - INFO - event_client init() address: localhost node: A 2020-10-29 12:28:36,175 - INFO - PyCycloneDp.init localhost 2020-10-29 12:28:36,220 - PyCycloneDp - INFO - logging in PyCycloneDp.__init__ --------------------------------------+------------------------------------------------------+-------------+----------------+----------------+-----------+---------- Family ID | Primary Volume/FS/vVol Name | Type | Family Unique | Family Shared | No. of | No. of | | | Physical Used | Logical Used | Clones | Snapshots --------------------------------------+------------------------------------------------------+-------------+----------------+----------------+-----------+---------- d301959c-6eb9-4e23-967a-e0b3cdf06bea | labtea-vol-1 |Block | 97.91 GB| 486.36 GB| 0 | 1 6c97fdd8-5b01-44ef-adaf-047449f83c27 | labtea-vol-2 |Block | 99.47 GB| 492.30 GB| 0 | 1
| Warnmeldungs-ID | DATA_PATH_WRITE_PROTECT_MODE_EXTREMELY_HIGH |
| Warnmeldungstext | Die Speicherplatzauslastung von %(tier_name) ist extrem hoch. |
| Fehlercode | 0x00200703 |
| Auswirkungen | Mehrere interne Services (z. B. NAS und UI) funktionieren möglicherweise nicht optimal. |
| Auflösung | Ursache: Ein Teil der Appliance-Kapazität ist für interne Services reserviert (z. B. NAS-Core-Services, Datenerfassungen, interne Datenbanken und mehr). Wenn die Appliance den Schreibschutzmodus (0x00200701) erreicht, kann der Nutzer keine Daten mehr schreiben, interne Services können jedoch weiterhin auf kritische Informationen zugreifen (nur ab PowerStoreOS 3.0). Sobald auch die intern reservierte Kapazität erschöpft ist, wird diese Warnmeldung ausgegeben, CP und SDNAS (und andere Services) funktionieren möglicherweise nicht optimal. Lösung: Wenden Sie sich an den technischen Support , um sofortige Unterstützung zu erhalten. |
Weitere Informationen
- Wenn ein PowerStore-Node länger als 30 Minuten inaktiv ist, kann die Kapazität im Laufe der Zeit schneller zunehmen. Weitere Informationen finden Sie unter PowerStore: Appliance kann in WPM (Schreibschutzmodus) versetzt werden oder keinen Speicherplatz mehr aufweisen, wenn ein einzelner Node länger als 30 Minuten ausgefallen ist.
- Beim Löschen eines Volumes wird der Speicherplatz der gelöschten Volumes schnell in der PowerStore Manager-Benutzeroberfläche angezeigt. Die Speicherplatzrückgewinnung erfolgt jedoch im Hintergrund und kann einige Zeit in Anspruch nehmen. Es wird empfohlen, mehrere Stunden zu warten, bis die Hintergrundprozesse zur Rückgewinnung des Speicherplatzes abgeschlossen sind.


