Dell CloudIQセキュリティ アセスメント レポートで、セキュア ブートが有効になっている場合にPowerEdgeデバイスのリスク レベルが高いと識別されます。

Zusammenfassung: CloudIQサイバーセキュリティ レポートは、ターゲット システムでセキュア ブートを有効にした後でも、PowerEdgeデバイスのリスク レベルを「高」として識別し続けます。

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

セキュア ブート属性を修復した後でも、PowerEdgeデバイスのセキュリティ アセスメント レポートが「高」状態のままです。
セキュア ブートが無効になっているため、CloudIQセキュリティ評価に高リスク レベルが示されています。

Ursache

セキュア ブート用にデバイス属性を変更した後、iDRACのシステム設定ハッシュがアップデートされていません。

OpenManage Enterpriseは、iDRACのシステム構成ハッシュを活用して、デバイス設定が変更されたかどうかを判断します。ハッシュ値の変更が検出されると、OpenManage Enterpriseはターゲットからの設定インベントリー収集をトリガーします。この新しい構成インベントリー情報はCloudIQに送信され、セキュリティ評価の計算に使用されます。

現在のシステム インベントリー ハッシュは、WinRMまたはRedfishを使用してデバイスから取得できます。

iDRACシステム構成ハッシュ値を引き出すWinRMコール
winrm e cimv2/root/dcim/DCIM_iDRACCardString -u:<Username> root -p <Password> -r:https://<DRAC_IP_ADDRESS>/wsman -SkipCNcheck -SkipCAcheck -encoding:utf-8 -a:basic
出力:
DCIM_iDRACCardString
    AttributeDisplayName = System Configuration Hash
    AttributeName = SystemConfigHash
    CurrentValue = a1ce859471708c9f8f34ef5093e6b354712887af93a5d9183ed0660f57da593f
    DefaultValue = null    Dependency = null    DisplayOrder = 1
    FQDD = iDRAC.Embedded.1
    GroupDisplayName = Inventory HASH
    GroupID = InventoryHash.1
    InstanceID = iDRAC.Embedded.1#InventoryHash.1#SystemConfigHash
    IsReadOnly = true    MaxLength = 256
    MinLength = 0
    PendingValue = null

Redfish GETによるiDRACシステム構成ハッシュ値の取得
https://<DRAC_IP_ADDRESS>:443/redfish/v1/Managers/iDRAC.Embedded.1/Attributes?%24select=InventoryHash.1.SystemConfigHash
出力:
{
     "@Redfish.Settings": {
         "@odata.context": "/redfish/v1/$metadata#Settings.Settings",
         "@odata.type": "#Settings.v1_3_0.Settings",
         "SettingsObject": {
             "@odata.id": "/redfish/v1/Managers/iDRAC.Embedded.1/Oem/Dell/DellAttributes/iDRAC.Embedded.1/Settings"
         },
         "SupportedApplyTimes": [
             "Immediate",
             "AtMaintenanceWindowStart"
         ]
     },
     "@odata.context": "/redfish/v1/$metadata#DellAttributes.DellAttributes",
     "@odata.id": "/redfish/v1/Managers/iDRAC.Embedded.1/Oem/Dell/DellAttributes/iDRAC.Embedded.1",
     "@odata.type": "#DellAttributes.v1_0_0.DellAttributes",
     "Attributes": {
         "InventoryHash.1.SystemConfigHash": "187ff97183d88b55619652035722ee0be745ae981680db5d8afc4dfeb1c6a199" 
     },
     "Description": "This schema provides the oem attributes",
     "Id": "iDRACAttributes",
     "Name": "OEMAttributeRegistry"
 }

Lösung

まず、デバイスでiDRACバージョン6.10.80.00以降が実行されていることを確認します。次に、WinRMまたはRedfishのいずれかの方法を使用して、ソフトウェア インベントリー ハッシュがnullでないことを確認します。ソフトウェア インベントリー ハッシュがnullの場合は、iDRACベースの設定を変更してから、元の値に戻します。これらのアクションにより、ハッシュ値が入力されます。最後に、CloudIQポータルのデバイス アクションからデバイス同期タスクをトリガーします。

Betroffene Produkte

CloudIQ, Dell EMC OpenManage Enterprise, OpenManage Enterprise APEX AIOps Observability
Artikeleigenschaften
Artikelnummer: 000205986
Artikeltyp: Solution
Zuletzt geändert: 09 Juli 2025
Version:  4
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.