Data Domain: BoostFS zpanikaří nebo Přípojný bod přestane reagovat

Zusammenfassung: BoostFS zpanikaří nebo se zhroutí nebo přípojný bod přestane reagovat, když zálohovací aplikace provádí vstupně-výstupní operace na přípojném bodu BoostFS.

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

Příznaky:

  • BoostFS náhodně padá a panikaří. K tomu dochází, když je zatížení vysoké.
  • Zálohovací aplikace provádí se zpožděním READ a WRITE operace na přípojném bodu BoostFS.
  • Dojde-li ke zpoždění READ a WRITE operací ze zálohovací aplikace, protokoly BoostFS zobrazují toto error 5057 File handle is stale from Data Domain server.

Protokoly BoostFS:

###### WRITE operation FAILED due to STALE FILE HANDLE error ######
Sep 11 00:36:29.635 7884 10740 [E] [ddp log] [1ECC:29F4] ddcl_ddcp_send_file_loop: Call to recv
refs2 failed. [ERR=5057] Sep 11 00:36:29.635 7884 10740 [E] [ddp log] [1ECC:29F4] ddcl_ddcp_pwrite: Call to send file loop2 failed. [ERR=5057]
Sep 11 00:36:29.635 7884 10740 [E] [ddp log] [1ECC:29F4] ddcl_ddcp_pwrite: Error in ddcl ddcp
pwrite. [ERR=5057] Sep 11 00:36:29.635 7884 10740 [E] [ddp log] [1ECC:29F4] ddp_write() failed Offset 11010048, BytesToWrite 1048576, BytesWritten 0 Err: 5057-File handle is stale
Sep 11 00:36:29.635 7884 10740 [E] bfs_cache_flush: failed: 5057 File handle is stale (0 bytes written)
Sep 11 00:36:29.651 7884 11292 [E] [ddp log] [1ECC:2C1C] ddcl_ddcp_send_file_loop: Call to recv
refs2 failed. [ERR=5057]
####### PANIC occurred HERE #######
Sep 11 00:36:29.667 7884 11292 [E] [ddp log] [1ECC:2C1C] PANIC: ..\ddcl\ddcl_ddcp.c:
ddcl_ddcp_commit: 4541: !(c->send_offset == c->write_offset)

Třídění:

  1. Zkontrolujte protokoly BoostFS a DDFS na straně serveru, zda neobsahují výše uvedenou chybu.
  2. Sledujte zpoždění READ a WRITE operace ze zálohovací aplikace. Zvažte vstupní a výstupní protokoly rozhraní API BoostFS.
  3. Zkontrolujte hodnotu nastavenou pro OST_ABANDON_TIMEOUT (výchozí tři hodiny).
  4. Zkontrolujte, zda je časový limit služby RPC větší než hodnota nastavená pro OST_ABANDON_TIMEOUT.

Ursache

  1. Problém je způsoben zpožděním READ a WRITE operací zálohovací aplikace. To způsobí, že DDFS zruší časový limit. To vede k uzavření příslušného popisovače souborů po třech hodinách (výchozí hodnota)
  2. Toto je výchozí časový limit zahození, který DDFS používá k identifikaci neaktivního popisovače souboru. Nakonec může u nových zápisů dojít k panice na straně klienta.

Lösung

Kontaktujte podporu společnosti Dell ohledně prodloužení časového limitu, který vyžaduje přístup k protokolu Bash.

Změňte nastavení OST_ABANDON_TIMEOUT na straně serveru pomocí níže uvedených kroků. Jeho hodnotu lze nastavit na vyšší hodnotu s maximálně 12 hodinami.

 

Poznámka: Systém souborů musí být v rámci použití řešení zakázán a povolen.

 

  1. Přihlaste se do systému Data Domain s přístupem v roli správce . Podpora přejde do režimu bash a poté vstoupí se režim s ddsh -s
  2. Podívejte se na originál OST_ABANDON_TIMEOUT Hodnotu.
SE@dd## se sysparam show OST_ABANDON_TIMEOUT
  1. Zvyšte OST_ABANDON_TIMEOUT Hodnotu. Ve výchozím nastavení je hodnota 10800 (tři hodiny).
SE@dd## se sysparam set OST_ABANDON_TIMEOUT=129600
SE@dd## se sysparam show OST_ABANDON_TIMEOUT

Name Description Current Default Override
------------------- --------------------------------- ------- ------- -----
---
OST_ABANDON_TIMEOUT DDCP abandon context timeout(sec) 129600 10800 rpc
------------------- --------------------------------- ------- ------- -----
---

SE@dd##priv set admin
  1. Po výše uvedené změně parametrů restartujte systém souborů. Ověřte si u zákazníka, zda je tento restart povolen. Pokud ne, naplánujte období údržby pro spuštění následujícího příkazu:
SE@dd## filesys disable
SE@dd## filesys enable

Betroffene Produkte

Data Domain
Artikeleigenschaften
Artikelnummer: 000215706
Artikeltyp: Solution
Zuletzt geändert: 14 Jän. 2026
Version:  4
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.