PowerFlex: Benutzeroberfläche nicht verfügbar, während Pods funktionsfähig sind
Zusammenfassung: Die PFxM-Benutzeroberfläche ist nicht mehr verfügbar und scheint abzustürzen, während alle Kubernetes-Pods funktionsfähig sind und keine Anzeichen eines Ausfalls oder Neustarts zeigen.
Symptome
Die PFxM-Benutzeroberfläche ist nicht mehr verfügbar und scheint abzustürzen, während alle Kubernetes-Pods funktionsfähig sind und keine Anzeichen eines Ausfalls oder Neustarts zeigen.
Der folgende Befehl, der von einem Management Virtual Machine (MVM)-Node ausgeführt wird, zeigt, dass alle Pods ausgeführt werden und fehlerfrei funktionieren:
kubectl get pods -A -o wide
Der Nutzer greift von einer Workstation auf die Benutzeroberfläche zu, die sich nicht im selben Netzwerk wie PFxM befindet, sodass möglicherweise Routing und/oder Firewalls zwischen der Workstation und PFxM beteiligt sein können.
Auswirkungen
Der Nutzer verliert den Zugriff auf die PFxM-Benutzeroberfläche.
Ursache
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Wenn Routing und/oder Firewalls zwischen PFxM und der Workstation des Endnutzers verwendet werden, die für den Zugriff auf die Benutzeroberfläche verwendet wird, können verschiedene Probleme auftreten, z. B. Timeouts oder blockierte Verbindungen. Dies kann die Kommunikation mit der PFxM-Benutzeroberfläche unterbrechen und dazu führen, dass sie als "Absturz" erscheint. |
Lösung
Verwenden Sie eine Workstation, die lokal in PFxM (im selben Netzwerk) ist und kein Routing oder Firewalls umfasst, um auf die Benutzeroberfläche zuzugreifen.
Betroffene Versionen
Kein PFxM-Problem