PowerFlex: Virhe INVALID_POSTGRES_INSTANCE_ROLE PFMP 4.8 -päivityksen jälkeen
Zusammenfassung: Tässä artikkelissa kerrotaan, miten kosmeettiset hälytykset poistetaan INVALID_POSTGRES_INSTANCE_ROLE 4.6-versiosta 4.8-versioon päivittämisen jälkeen
Dieser Artikel gilt für
Dieser Artikel gilt nicht für
Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden.
In diesem Artikel werden nicht alle Produktversionen aufgeführt.
Symptome
Kun päivitys versiosta 4.6 versioon 4.8 on päivitetty, seuraavat hälytykset laukeavat, eikä niitä poisteta kuittaamalla hälytystä

Ursache
Nämä ovat vanhentuneita hälytyksiä vanhoista CrunchyData PGO -tietokantaesiintymistä (postgres-ha-cmo1-*), jotka korvattiin CloudNativePG:llä (postgres-ha-cnpg-*) 4.8-päivityksen aikana.
Vanhat kapselit ja PVC: t ovat poissa, uusi CNPG-klusteri on kunnossa, mutta kunnon valvonnan configmap viittaa edelleen vanhoihin esiintymiin, minkä vuoksi hälytykset käynnistyvät uudelleen.
Lösung
- Tarkista DB: n terveydentila
delladmin@mvm1:~>kubectl get pods -n powerflex | grep post configure-postgres-prerequirements-0-hw95r 0/1 Completed 0 47d postgres-ha-cnpg-1 1/1 Running 0 47d postgres-ha-cnpg-2 1/1 Running 0 47d postgres-ha-cnpg-3 1/1 Running 0 86m postgres-ha-cnpg-pooler-556778f6fd-2tmd9 1/1 Running 0 21d postgres-ha-cnpg-pooler-556778f6fd-qnp8k 1/1 Running 0 21d postgres-monitor-7fd88546c7-h6tjn 1/1 Running 0 21d postgres-monitor-7fd88546c7-l2wk7 1/1 Running 0 21d - Jos kaikki tietokannan asennukset ovat käynnissä, poista hälytykset manuaalisesti tämän artikkelin avulla : PowerFlex 4.X: Hälytysten poistaminen manuaalisesti 4.X PowerFlex Manager -käyttöliittymästä
- Tyhjennä välimuisti käynnistämällä/poistamalla esityspalvelun pod uudelleen
kubectl delete pod -n powerflex $(kubectl get pods -n powerflex | grep presentation | awk '{print $1}')Betroffene Produkte
PowerFlex rack, ScaleIOArtikeleigenschaften
Artikelnummer: 000453497
Artikeltyp: Solution
Zuletzt geändert: 16 Apr. 2026
Version: 1
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.