PowerFlex:4.8 PFMPアップグレード後のエラー INVALID_POSTGRES_INSTANCE_ROLE

Zusammenfassung: この記事では、4.6から4.8へのアップグレード後に外観上のアラート INVALID_POSTGRES_INSTANCE_ROLEをクリアする手順について説明します。

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

4.6から4.8へのアップグレード後に、以下のアラートがトリガーされ、アラートを確認してもクリアされません 

INVALID_POSTGRES_INSTANCE_ROLE

Ursache

これらは、4.8のアップグレード中にCloudNativePG(postgres-ha-cnpg-*)に置き換えられた古いCrunchyData PGデータベースインスタンス(postgres-ha-cmo1-*)からの古いアラートです。

古いポッドとPVCはなくなり、新しいCNPGクラスターは正常ですが、正常稼働モニタリングconfigmapは引き続き古いインスタンスを参照しているため、アラートが再発生し続けます。 

Lösung

  1. DBの稼働状態を確認してください 
    delladmin@mvm1:~>kubectl get pods -n powerflex | grep post
    configure-postgres-prerequirements-0-hw95r                0/1     Completed   0             47d
    postgres-ha-cnpg-1                                        1/1     Running     0             47d
    postgres-ha-cnpg-2                                        1/1     Running     0             47d
    postgres-ha-cnpg-3                                        1/1     Running     0             86m
    postgres-ha-cnpg-pooler-556778f6fd-2tmd9                  1/1     Running     0             21d
    postgres-ha-cnpg-pooler-556778f6fd-qnp8k                  1/1     Running     0             21d
    postgres-monitor-7fd88546c7-h6tjn                         1/1     Running     0             21d
    postgres-monitor-7fd88546c7-l2wk7                         1/1     Running     0             21d
  2. すべてのDBインスタンスが実行中の場合は、次の記事「 PowerFlex 4.X: 4.X PowerFlex Manager UIからアラートを手動でクリアする方法
  3. presentation-serviceポッドを再起動/削除して、キャッシュされた状態をフラッシュします 
kubectl delete pod -n powerflex $(kubectl get pods -n powerflex | grep presentation | awk '{print $1}')

Betroffene Produkte

PowerFlex rack, ScaleIO
Artikeleigenschaften
Artikelnummer: 000453497
Artikeltyp: Solution
Zuletzt geändert: 16 Apr. 2026
Version:  1
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.