PowerFlex: Błąd INVALID_POSTGRES_INSTANCE_ROLE Po uaktualnieniu PFMP 4.8
Zusammenfassung: W tym artykule wyjaśniono, jak usunąć INVALID_POSTGRES_INSTANCE_ROLE alertu kosmetycznego po uaktualnieniu z wersji 4.6 do 4.8
Dieser Artikel gilt für
Dieser Artikel gilt nicht für
Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden.
In diesem Artikel werden nicht alle Produktversionen aufgeführt.
Symptome
Po uaktualnieniu z wersji 4.6 do 4.8 wyzwalane są poniższe alerty, które nie są usuwane przez potwierdzenie alertu

Ursache
są to przestarzałe alerty ze starych instancji bazy danych PGO CrunchyData (postgres-ha-cmo1-*), które zostały zastąpione przez CloudNativePG (postgres-ha-cnpg-*) podczas aktualizacji do wersji 4.8.
Stare zasobniki i PVC zniknęły, nowy klaster CNPG jest w dobrej kondycji, ale mapa konfiguracji monitorowania kondycji nadal odwołuje się do starych wystąpień, dlatego alerty są ponownie uruchamiane.
Lösung
- Sprawdzanie kondycji bazy danych
delladmin@mvm1:~>kubectl get pods -n powerflex | grep post configure-postgres-prerequirements-0-hw95r 0/1 Completed 0 47d postgres-ha-cnpg-1 1/1 Running 0 47d postgres-ha-cnpg-2 1/1 Running 0 47d postgres-ha-cnpg-3 1/1 Running 0 86m postgres-ha-cnpg-pooler-556778f6fd-2tmd9 1/1 Running 0 21d postgres-ha-cnpg-pooler-556778f6fd-qnp8k 1/1 Running 0 21d postgres-monitor-7fd88546c7-h6tjn 1/1 Running 0 21d postgres-monitor-7fd88546c7-l2wk7 1/1 Running 0 21d - Jeśli wszystkie stany bazy danych są uruchomione, ręcznie wyczyść alerty, korzystając z tego artykułu PowerFlex 4.X: Ręczne usuwanie alertów z interfejsu użytkownika PowerFlex Manager 4.X
- Uruchom ponownie/usuń zasobnik usługi prezentacji , aby opróżnić stan pamięci podręcznej
kubectl delete pod -n powerflex $(kubectl get pods -n powerflex | grep presentation | awk '{print $1}')Betroffene Produkte
PowerFlex rack, ScaleIOArtikeleigenschaften
Artikelnummer: 000453497
Artikeltyp: Solution
Zuletzt geändert: 16 Apr. 2026
Version: 1
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.