Troubleshooting von Problemen mit dem Zugriff auf die Bandbibliothek in NetWorker
Zusammenfassung: Dieser Artikel soll dem Support und NetWorker-Administratoren helfen, die Ursachen für die Unfähigkeit eines erkannten Roboters, Befehle zu akzeptieren, zu ermitteln.
Symptome
- Auf die erkannte Bandbibliotheksinstallation auf dem NetWorker-Speicher-Node oder -Server kann nicht zugegriffen werden
- Daten können aufgrund nicht verwendbarer Backuphardware nicht gesichert werden
- Fehler beim Zugriff auf den Roboter:
0x29Device busyThe requested resource is busyStr=<There is an input or output error.>No such deviceNo such file or directoryInappropriate ioctl for device
Ursache
Wenn die Bibliothek zuvor funktioniert hat und plötzlich nicht mehr funktioniert, betrachten Sie die letzte bekannte Änderung als wahrscheinliche Ursache:
- Unbehandelte Änderung der Bibliotheksadresse nach Neustart, Neuerkennung und Umbenennung des Geräts
- Mögliche Schäden aufgrund von Überspannung, Stromausfall oder anderen Umgebungsereignissen
- Ausfallereignisse oder Neukonfiguration von Transporthardware
- Installation, Änderung oder Löschung von Software oder Treibern im Zusammenhang mit Transport oder Robotik
Wenn die Bibliothek noch nie funktioniert hat, vergewissern Sie sich im NetWorker Hardware Compatibility Guide, dass die Hardware unterstützt wird (Anmeldung beim Dell Support-Account erforderlich). Denken Sie daran, dass es möglich ist, dass eine Bibliothek teilweise funktionsfähig ist. Die Erkennung allein ist keine Garantie für die Benutzerfreundlichkeit oder Unterstützbarkeit.
Lösung
Um Fehler beim Bibliothekszugriff zu beheben, überprüfen Sie die letzten Änderungen. Verwenden Sie dann grundlegende Vergleichstests und Vergleichstests von Drittanbietern, um zu bestätigen, ob ein beliebiger Host oder Prozess eine Antwort des Roboters auslösen kann.
Manchmal ist es wünschenswert, bestimmte Funktionen auf der Grundlage der verfügbaren Evidenz zu testen. Wenn Host A den Roboter abfragen kann, Host B jedoch nicht, reagiert der Roboter. Der Treiber von Host A blockiert möglicherweise den Roboter. Wenn Host B weiterhin Fehler empfängt, nachdem alle Hosts aus der Zone entfernt wurden, liegt bei Host B möglicherweise ein Treiber-, Konfigurations- oder Softwareproblem vor.
Wenn der Host vor dem Problem auf den Roboter zugegriffen hat, haben sich die Bewertungselemente höchstwahrscheinlich geändert. Untersuchen Sie Fehler oder bekannte Konfigurationsänderungen nach dem Ereignis.
Nachdem die Bibliothek erkannt wurde, verwenden Sie die folgenden Befehle, um grundlegende SCSI-Vorgänge über den Speichertransport zu testen, nicht über Ethernet oder die Webnutzeroberfläche. Stellen Sie immer sicher, dass die Betriebssystem-Patches auf dem neuesten Stand sind, insbesondere was den Storage betrifft.
nsrget -o:d auf dem betroffenen Server und den betroffenen Nodes.
-o:d Auf jedem Host mit Bändern, auf denen die Bänder mit dem Schreiben beschäftigt sind. Sie können dies über die NetWorker Management Console (NMC) unter Monitoring -> Devices überprüfen.
Der folgende Artikel enthält Informationen zum Abrufen und Verwenden von NSRGET: NetWorker: So verwenden Sie das nsrget-NetWorker-Datenerfassungs-Tool
Bibliothekszugriff: Betriebssystem:
- Windows: Es gibt keine native Möglichkeit, eine Bandbibliothek in Windows abzufragen.
mtxist ein Freeware-Dienstprogramm, das bei Bedarf getestet werden kann. Es verwendet das Wechslergerätehandle anstelle der SCSI-Adresse bei der Ausgabe von Befehlen (was Auswirkungen auf das Testen haben kann).
- Linux: Wie Windows, verfügt über keinen nativen Befehl zum Abfragen, verfügt aber auch über eine
mtxPort, für den das Gerätetreiberhandle erforderlich ist (wiederum anders als beim NetWorker-Zugriff darauf).
loaderinfo -f /dev/sg#
mtx -f /dev/sg# inquiry
- Solaris: Solaris enthält die
sgenTreiber für die native Bandbibliotheksunterstützung, aber keinmtxPort und andere native Bibliotheksbefehle dafür nicht vorhanden sind. Lesen Sie stattdessen den Abschnitt über NetWorker-Befehle, um den Bibliothekszugriff zu testen (siehe unten).
- AIX: AIX bietet keine Unterstützung für native Bandbibliotheken (
lusverwendet wird), und keinemtxPort dafür vorhanden ist. Lesen Sie stattdessen den Abschnitt über NetWorker-Befehle, um den Bibliothekszugriff zu testen (siehe unten).
- HP-UX:
mcist der native HP-UX-Befehl für die Manipulation des Mittelwechslers:
mc -p $(ioscan FnkC autoch | grep /dev/rac) -r MIDS -q
- NetWorker: Diese Befehle funktionieren auf einer relativ atomaren Ebene. Obwohl sie vom NetWorker-Support geschrieben, kompiliert und getestet werden, benötigen sie weder eine laufende NetWorker-Instanz noch eine NetWorker-Konfiguration von NetWorker. Im Allgemeinen gelten sie als zuverlässige, softwareunabhängige Low-Level-Testwerkzeuge. Um das Debuggen für die meisten Dienstprogramme zu verbessern, können Sie die folgenden Umgebungsvariablen hinzufügen:
SJI_DEBUG=9LUS_DEBUG=9 (lusdebug ffff on AIX)CDI_DEBUG=9SCSI_DEBUG=9JBDEBUG=9
Im Folgenden wird "<changer address>' variiert je nach Betriebssystem:
Windows: Initiator.Target.LUN (wie von inquire Befehl) oder \\.\changer# Treiber-Handle
Linux: Intiator.Target.LUN (wie von inquire Befehl) oder /dev/sg# Treiber-Handle
Solaris: /dev/scsi/changer/c#t#d# Treiberhandle
AIX: Initiator.Target.LUN (wie von inquire Befehl)
HP-UX: Initiator.Target.LUN (wie von inquire Befehl) oder /dev/rac/c#t#d# Treibergriff
sjirjc <changer address>
Fordert Daten vom Roboter an, wie z. B. die Anzahl der Laufwerke, unterstützte Funktionen usw.
sjisn <changer address>
Fordert Informationen zum Antriebselement und zur Seriennummer vom Roboter an.
sjirdtag <changer address>
Fordert Daten zur Position der Bandkassette zum Element an
cdi_inq -f <changer driver handle> -v
Fordert wichtige Produktdaten an (erfordert die Verwendung eines Treibergriffs)
ielem -a <changer address>
Versuche, Elemente neu zu initialisieren – können zu Unterbrechungen führen.
Bibliothekszugriff: Zurücksetzen der Bibliothek:
nsrjb -HEvvvvv
Gibt einen Reset-Befehl für eine problematische Bibliothek aus und erzwingt eine Neuinitialisierung des Elements.
nsrjb -IIvvvvv
Erzwingt eine Aktualisierung des NetWorker-NSR-Jukebox-Objekts basierend auf den von der Bibliothek gemeldeten Barcodes und den entsprechenden Werten in der Mediendatenbank.
nsrjb -HH
Erzwingt, dass die Jukebox alle Volumes entlädt und einen Soft-Reset versucht.
ielem -a ist ein ungefähres Äquivalent zu nsrjb -E Dies erfordert keine funktionsfähige NSR-Jukebox in NetWorker.
Transport – Konfiguration
- Für SAN: Stellen Sie sicher, dass sowohl der Roboter als auch der vorgesehene NetWorker-Robotersteuerungshost ordnungsgemäß beim Switch angemeldet sind, und überprüfen Sie das Zoning für den Roboter, um sicherzustellen, dass eine durchgängige Verbindung möglich ist.
- Roboter sind nicht dafür vorgesehen, von mehr als einem Host aufgerufen oder gesteuert zu werden. Sofern kein Bedarf besteht (z. B. ein partitionierter Roboter), stellen Sie sicher, dass nur der vorgesehene NetWorker-Roboter-Controller-Host in Zonen eingeteilt ist, um den Roboter anzuzeigen.
- Es ist möglich, SAS-Expander zu testen, um sicherzustellen, dass eine Roboterverbindung hergestellt wird. Bei der reinen Punkt-zu-Punkt-Technologie wie SCSI muss die Verbindung vom entsprechenden Host getestet werden.
Transport – Hardware
- Wenn Probleme auf Host- oder Transporthardwareebene erkannt werden, ziehen Sie in Betracht, den Switch oder Expander zu testen oder Kabel durch "zweifelsfrei funktionierende" Beispiele auszutauschen, um Verkabelungsprobleme auszuschließen.
- Überprüfen Sie die Firmware der Transporthardware und die Firmware des Roboters selbst auf Aktualität.
- Stellen Sie bei SCSI sicher, dass die Abschlusswiderstände korrekt platziert und fest sitzen, die Kabellängenbegrenzungen eingehalten werden und die richtigen Spannungen verwendet werden.
Hosttransport – Konfiguration
- Stellen Sie sicher, dass der betreffende Host über aktuelle Treiber und Firmware für seine Transporttreiber verfügt. Verwenden Sie
EMCReports(gebündelt mitnsrget -o:e) enthalten. - Stellen Sie sicher, dass alle erforderlichen HBA-Treiberkonfigurationen (Hostbusadapter) entsprechend dem Betriebssystem durchgeführt werden.
Hostsoftware – Ressourcensperre
- Suchen Sie für jeden Host, der in Zonen für die Anzeige des Roboters vorgesehen ist (idealerweise nur den designierten NetWorker-Host), nach Software, die versuchen könnte, auf den Roboter zuzugreifen, z. B. andere Backupsoftware, Überwachungssoftware oder eigenständige Dienstprogramme, die versuchen könnten, auf den Roboter zuzugreifen.
- Bei Solaris 10 ist der Roboter nicht zugänglich, wenn der NetWorker-Prozess nsrlcpd angehängt ist. Daher kann es unzugänglich (oder sogar nicht erkennbar) erscheinen, bis die Bibliothek in NetWorker deaktiviert wird (was
nsrlcpdablösen und sterben). - Wenn ein Nicht-NetWorker-Prozess im Verdacht steht, den Roboter oder ein Laufwerk zu sperren oder darauf zuzugreifen, finden Sie weitere Informationen zum Troubleshooting und zur Identifizierung unter Troubleshooting von überschriebenen Labels und SCSI-Resets in NetWorker.
Wenn das Betriebssystem die Bibliothek erkennt, die Bibliothek jedoch nicht auf Befehle reagiert, ist sie bis zu einem gewissen Grad funktionsfähig. Sie kann von einem anderen Prozess oder Host gesperrt sein, von Transportproblemen betroffen sein oder eine Fehlfunktion auf Komponentenebene aufweisen.
Wenn außer dem NetWorker Storage Node, der ihn steuern soll, kein Prozess oder Host auf den Roboter zugreift, lesen Sie den Abschnitt Troubleshooting von Bandbibliothek-Hardwareproblemen in NetWorker, um festzustellen, ob ein Problem mit dem Roboter selbst vorliegt.
Weitere Informationen
Stellen Sie sicher, dass Sie verstehen, dass Robotikprobleme, die als außerhalb des Anwendungsbereichs von NetWorker liegen (sprich: nicht mit Standardbetriebssystemmethoden aufgerufen werden können), nicht in den Umfang des NetWorker-Supports fallen.
Networker: Troubleshooting von Bandbibliotheksproblemen in NetWorker
Der Support kann anhand der oben genannten Kriterien Hilfestellung leisten, aber wir verfügen nicht über BS-, HBA- oder Robotik-Anbieterressourcen. Diese Einschränkung kann zu einer langwierigen, erfolglosen Fehlerbehebung führen.