AppSync: Återställning från AppSync-snapshot kan misslyckas på grund av att tidsgränsen har infaller
Zusammenfassung: Återställning från AppSync-snapshot till produktionsvärd misslyckades på grund av att tidsgränsen gick ut.
Dieser Artikel gilt für
Dieser Artikel gilt nicht für
Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden.
In diesem Artikel werden nicht alle Produktversionen aufgeführt.
Symptome
En återställningsåtgärd från Det grafiska användargränssnittet för AppSync hänger sig så småningom och misslyckas på grund av ett timeoutfel.
AppSync-händelserna visar:
I serverloggarna ser du att tidsgränsen är för öppen:
AppSync-händelserna visar:
<DATE &TIME>, Restore Copy, fc520a7d-b08d-41ab-9878-70608fdf8ea6, ORCL_000093, <hostyname>, AppSync kunde inte återställa ett eller alla av följande lagringsfilsystem: /my/path/data99,
I serverloggarna ser du att tidsgränsen är för öppen:
<DATE &TIME> INFO [MATA UTB standard - 8] [com.emc.archway.xio_commands. RestoreXIOSnapshotCommandBean] [AppSync_Server] [] d5f58e3c-43bd-4e2a-998f-4908473c3af0->>> avslutade återställnings-/uppdateringsvolymer på XIO-disksystemet <DATE & TIME> INFO [EJB default - 8] [com.emc.archway.xio_commands. RestoreXIOSnapshotCommandBean] [AppSync_Server] [] d5f58e3c-43bd-4e2a-998f-4908473c3af0->>> slutförd återställ/uppdatera volymer på XIO-disksystemet <DATE &TIME> VARNA [EJB standard - 8] [com.arjuna.ats.arjuna] [AppSync_Server] [] ARJUNA012077: Abort anropade redan avbruten atomisk åtgärd 0:ffff0a25bf41:-396b7557:61391564:19b548 <DATE & TIME> ERROR [EJB default - 8] [org.jboss.as.ejb3.invocation] [AppSync_Server] [] WDIOEJB0034: UTB-invocation failed on component RestoreXIOSnapshotCommandBean for method public boolean com.emc.archway.xio_commands. RestoreXIOSnapshotCommandBean.restorePhasePIT(com.emc.archway.context.ExecutionContext,java.util.Set,boolean): javax.ejb.EJBTransactionRolledbackException: javax.transaction.RollbackException: WEJB0447: Transaction 'Local transaction (delegate=TransactionImple < ac, BasicAction: 0:ffff0a25bf41:-396b7557:61391564:19b548 status: ActionStatus.ABORTED >, owner=Local transaction context for provider JBoss JTA transaction provider) har redan återställts till org.jboss.as.ejb3@17.0.1.Final//org.jboss.as.ejb3.tx.CMTTxInterceptor.endTransaction(CMTTxInterceptor.java:114)
Ursache
Ett antal snapshot var inblandade i återställningsåtgärden som orsakade fördröjning/timeout. Möjlig orsak har inte fastställts, men det kan vara ett prestanda-/långsamhetsproblem på resurser som disksystem och värd.
Lösung
Om du justerar transaktionens timeoutvärde kan AppSync inte avsluta tidsgränsen under återställningen.
- Gå till C:\EMC\AppSync\jboss\standalone\configuration\standalone.xml.
- Ändra värdet från standardvärdet 300 till det nya värdet 2 400 sekunder – <coordinator-environment default-timeout=2400
- Stoppa alla tjänster (EMC AppSync-datalagret och EMC AppSync-säkerhetstjänsten)
- Starta tjänsterna (EMC AppSync Datastore Service, EMC AppSync Security Service, EMC AppSync-servertjänsten)
Betroffene Produkte
AppSyncArtikeleigenschaften
Artikelnummer: 000191827
Artikeltyp: Solution
Zuletzt geändert: 28 Okt. 2025
Version: 4
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.