VPLEX: Health-check --full reports Call Home "Error" state post NDU

Summary: This article talks to the issue where an Error is reported in the command "health-check --full" post an NDU yet the Call Home functions properly. The workaround provided in this article ...

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Symptoms

An Error is reported in the command "health-check --full" post upgrade, yet the Call Home feature functions properly.

  • Pre-NDU "Health-check --full" does not report an error.
  • Post-NDU "Health-check --full" reports "Checking Call Home Status" as Error
  • ConnectEMC_config.xml file looks the same as pre NDU as post NDU.
  • No issues seen in connectemc related logs
  • The SMTP service is reachable and nonblocked.
  • Call-Home works right for every triggered call-home test.
  • The CLM system determines call home alerts being correctly received. Hence, confirming the Connecthome alerts are being received.

Comparing PRE and POST Non-Disruptive Upgrade (NDU)

PRE-NDU:

VPlexcli:/> health-check --full

Configuration (CONF):
Checking VPlexCli connectivity to directors.................... OK
Checking Directors Commission.................................. OK
Checking Directors Communication Status........................ OK
Checking Directors Operation Status............................ OK
Checking Inter-director management connectivity................ OK
Checking ports status.......................................... OK
Checking Call Home............................................. OK <<<<
Checking Connectivity.......................................... OK

POST-NDU:

VPlexcli:/> health-check --full

Configuration (CONF):
Checking VPlexCli connectivity to directors.................... OK
Checking Directors Commission.................................. OK
Checking Directors Communication Status........................ OK
Checking Directors Operation Status............................ OK
Checking Inter-director management connectivity................ OK
Checking ports status.......................................... OK
Checking Call Home Status...................................... Error <<<<

Checking the scan.log:

service@ManagementServer:/var/log/VPlex/cli> more  health_check_full_scan.log

Configuration (CONF):
Checking VPlexCli connectivity to directors.................... OK
Checking Directors Commission.................................. OK
Checking Directors Communication Status........................ OK
Checking Directors Operation Status............................ OK
Checking Inter-director management connectivity................ OK
Checking ports status.......................................... OK
Checking Call Home Status...................................... Error <<<<

Email Server under Notification type: 'onSuccess/onFailure' is either
Not reachable or invalid.
Check if Email Server IP address: '10.1.111.100' is reachable and valid.
Email Server under Notification type: 'Primary' and 'Failover' are either
Not reachable or invalid.
Check if Email Server IP address: '10.1.111.100' and '10.1.111.100' are
Reachable and valid.

Checking the ConnectEMC config file:

service@ManagementServer:/opt/emc/connectemc> cat ConnectEMC_config.xml

<?xml version="1.0" encoding="UTF-8" standalone="no" ?>

<ConnectEMCConfig SchemaVersion="1.1.0">  
  <ConnectConfig Type="Email">
    <Retries>7</Retries>
    <Notification>Primary</Notification>
    <Timeout>700</Timeout>
    <Description></Description>
    <BsafeEncrypt>no</BsafeEncrypt>
    <IPProtocol>IPV4</IPProtocol>
    <EmailServer>10.1.111.100</EmailServer>
    <EmailAddress>emailalert@EMC.com</EmailAddress>
    <EmailSender>VPlex_CKM00000000999@EMC.com</EmailSender>
    <EmailFormat>ASCII</EmailFormat>
    <EmailSubject>Call Home</EmailSubject>
    <STARTTLS>no</STARTTLS>
    <IncludeCallHomeData>no</IncludeCallHomeData>
    <InsertBefore></InsertBefore>
    <PreProcess></PreProcess>
    <PostProcess></PostProcess>
    <HeloParameter></HeloParameter>
  </ConnectConfig>

  <ConnectConfig Type="Email">
    <Retries>7</Retries>
    <Notification>Failover</Notification>
    <Timeout>700</Timeout>
    <Description></Description>
    <BsafeEncrypt>no</BsafeEncrypt>
    <IPProtocol>IPV4</IPProtocol>
    <EmailServer>10.1.111.100</EmailServer>
    <EmailAddress>emailalert@EMC.com</EmailAddress>
    <EmailSender> VPlex_CKM00000000999@EMC.com</EmailSender>
    <EmailFormat>ASCII</EmailFormat>
    <EmailSubject>Call Home</EmailSubject>
    <STARTTLS>no</STARTTLS>
    <IncludeCallHomeData>no</IncludeCallHomeData>
    <InsertBefore></InsertBefore>
    <PreProcess></PreProcess>
    <PostProcess></PostProcess>
    <HeloParameter></HeloParameter>
  </ConnectConfig>

  <ConnectConfig Type="Email">
    <Retries>7</Retries>
    <Notification>onSuccess/onFailure</Notification>
    <Timeout>700</Timeout>
    <Description></Description>
    <BsafeEncrypt>no</BsafeEncrypt>
    <IPProtocol>IPV4</IPProtocol>
    <EmailServer>10.1.111.100</EmailServer>
    <EmailAddress>customer@genericemailaddress.com</EmailAddress>
    <EmailSender>VPlex_CKM00000000999@EMC.com</EmailSender>
    <EmailFormat>ASCII</EmailFormat>
    <EmailSubject>Call Home</EmailSubject>
    <STARTTLS>no</STARTTLS>
    <IncludeCallHomeData>yes</IncludeCallHomeData>
    <InsertBefore></InsertBefore>
    <PreProcess></PreProcess>
    <PostProcess></PostProcess>
    <HeloParameter></HeloParameter>
  </ConnectConfig>
</ConnectEMCConfig>

Ping test of Email server IP:

service@vplexMM:/var/log/ConnectEMC/logs> ping 10.1.111.100

PING 10.1.111.100 (10.1.111.100) 56(84) bytes of data.
--- 10.1.111.100 ping statistics ---
6 packets transmitted, 0 received, 100% packet loss, time 5010ms <<< packet loss 100%

Testing that the Email Server can be reached over Telnet:

service@vplexMM:~> telnet 10.1.111.100 25

Trying 10.1.111.100...
Connected to 10.1.111.100
Escape character is '^]'.
220 emc.com
helo localhost
250 emc.com
mail from: VPlex_CKM00000000999@EMC.com
250 2.1.0 Ok
rcpt to:customer@genericemailaddress.com
250 2.1.0 Ok

Running the call home "test" to see if it reports as successful:
Note the time that you sent the test dial, and convert the local time to UTC.

VPlexcli:/notifications/call-home> test

call-home test was successful.

Per the above information from the ping and telnet checks, this tells us that the customer is allowing the SMTP service on port "25" only and not the ICMP "ping."

This error is expected and can be ignored once you verify that the test call home is working and appearing under /opt/emc/connectemc/archive. Having the noted the time that the connecthome test was sent check the archive folder for a file with the same date and timestamp, in UTC. IF you see this file, this indicates that the test call home was sent out by the VPLEX.

service@ManagementServer:/opt/emc/connectemc/archive> ll
-rw-r----- 1 service users 2814 Jun 25 13:17 RSC_CKM00000000999_062518_011656000.xml
-rw-r----- 1 service users 2814 Jun 25 10:54 RSC_CKM00000000999_062518_105401000.xml
-rw-r----- 1 service users 2814 Jun 25 11:11 RSC_CKM00000000999_062518_111102000.xml
-rw-r----- 1 service users 2814 Jun 25 11:48 RSC_CKM00000000999_062518_114834000.xml

To check if the test call home message was received by CLM, you must contact Dell VPLEX Support, or a Dell badged field engineer an as them to check. Mention this article.

 

Cause

Checking call home status is part of the health-check -- full script, which does the following:

  1. Check the email server for each notification type in the folder /opt/emc/connectemc/ConnectEMC_config.xml
  2. Ping the email server. If the server is not pingable for any reason (not reachable over network, server is shut down, ICMP service is blocked over firewall, the <EmailServer> is a DNS* name instead of the IP address in the ConnectEMC_config.xml file).
NOTE: The DNS feature is not supported for VPLEX, you can only use IP addresses.

As a result, the command "health-check --full" script fails and shows the following error:

Checking Call Home Status...................................... Error

The current health-check script checks if call home is enabled and generates a "Warning" state if it is disabled.

The health-check script also checks if the call home has been functioning properly with several verifications such as:

  • Checking call homes have been generated;
  • The call home email messages have been sent successfully sent;
    Or
  • If the SMTP server ping is alive.

If any of these verifications fail, the script's result is marked with an error as shown:

Checking Call Home Status...................................... Error

 

Resolution

After enabling the ICMP protocol on the firewall between the VPLEX and the customer's selected email server used (SCG, the customer's email server), the Call Home "Error" status should now not report the error.

VPlexcli:/> health-check --full

Configuration (CONF):
Checking VPlexCli connectivity to directors.................... OK
Checking Directors Commission.................................. OK
Checking Directors Communication Status........................ OK
Checking Directors Operation Status............................ OK
Checking Inter-director management connectivity................ OK
Checking ports status.......................................... OK
Checking Call Home Status...................................... OK <<<<
Checking Connectivity.......................................... OK
Checking COM Port Power Level.................................. OK
Checking Meta Data Backup...................................... OK
Checking Meta Data Slot Usage.................................. OK

 

Επηρεαζόμενα προϊόντα

VPLEX Series

Προϊόντα

VPLEX GeoSynchrony, VPLEX VS2, VPLEX VS6
Ιδιότητες άρθρου
Article Number: 000050121
Article Type: Solution
Τελευταία τροποποίηση: 07 Νοε 2025
Version:  4
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