PowerProtect | Eigenständiges DDBMA-Backup der SQL-AlwaysOn-Datenbank (AAG) schlägt fehl

Summary: Eigenständiges Data Domain DD Boost for Microsoft Applications (DDBMA)-Backup der SQL AAG-Datenbank (Always On Availability Group) schlägt fehl

Αυτό το άρθρο ισχύει για Αυτό το άρθρο δεν ισχύει για Αυτό το άρθρο δεν συνδέεται με κάποιο συγκεκριμένο προϊόν. Δεν προσδιορίζονται όλες οι εκδόσεις προϊόντων σε αυτό το άρθρο.

Symptoms

Backups scheinen erfolgreich ausgeführt zu werden, aber die gespeicherte Prozedur (master.dbo.emc_run_backup) meldet einen Fehler und gibt die folgenden Ereignisse an:

Fehlermeldung:

Successfully converted from group id to AG name.

149283:ddbmsqlsv: Start secondary backup job failed. host: <hostname>. error: Setting notification event failed on host: <hostname>.
85942:ddbmsqlsv: Stopping Federated backup - No jobs were started successfully. Unable to complete the federated backup.


 

Cause

Der SQL Server Agent-Job wird im Kontext des Nutzers ausgeführt, der dem SQL Server Agent-Service zugeordnet ist. Dieses Nutzerkonto verfügte über alle erforderlichen Berechtigungen (lokaler Administrator auf SQL Server, vollständige Windows Management Instrumentation (WMI)-Berechtigungen gemäß Microsoft Application Agent-Handbuch). Das Backup funktioniert auch, wenn es über das SQL Server Management Studio (SSMS)-Plug-in ausgeführt wird, das mit diesem Nutzer angemeldet ist (verbunden mit dem SQL Server Agent-Service).

Wenn der Backupnutzer kein lokaler Administrator ist, verfügt er nicht über die erforderlichenWMI-Berechtigungen. Dies erklärt, warum Backups auf der Benutzeroberfläche, die das Konto des angemeldeten Nutzers verwendet, erfolgreich sind, in SQL, die das SQL-Servicekonto verwendet, jedoch fehlschlagen.

Resolution

Vergewissern Sie sich, dass der Nutzer der lokalen Administratorgruppe angehört, und fügen Sie bei Bedarf das SQL-Servicekonto hinzu. Überprüfen Sie die Berechtigungen Log on as a batch job oder Log on as a service , die in der Regel über den lokalen Administratorstatus gewährt werden. Fügen Sie sie bei Abwesenheit manuell hinzu. Wenn die Probleme weiterhin bestehen, starten Sie den SQL-Service neu oder starten Sie den Server neu, um die lokalen Administratorrechte vollständig anzuwenden.

Επηρεαζόμενα προϊόντα

PowerProtect App Direct, PowerProtect Software
Ιδιότητες άρθρου
Article Number: 000192006
Article Type: Solution
Τελευταία τροποποίηση: 07 Οκτ 2025
Version:  4
Βρείτε απαντήσεις στις ερωτήσεις σας από άλλους χρήστες της Dell
Υπηρεσίες υποστήριξης
Ελέγξτε αν η συσκευή σας καλύπτεται από τις Υπηρεσίες υποστήριξης.