PowerFlex : État des périphériques en état d’erreur lors de la mise à niveau de CloudLink avec PFxM

Summary: Lors de la mise à niveau de CloudLink avec PowerFlex Manager 3.8, des problèmes peuvent entraîner l’échec de la mise à niveau du service.

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Symptoms

Le service en cours de mise à niveau échoue lors d’une mise à niveau du nœud SDS. L’agent CloudLink du nœud SDS a été mis à niveau, mais il sera toujours en mode maintenance. 

Cause

CloudLink 7.0, 7.02, 7.1.0, 7.1.1 n’ajoute pas de minuteur de mise en veille requis dans /opt/emc/extra/pre_run.sh. S’il est ajouté manuellement, PowerFlex Manager 3.8 supprime le minuteur de mise en veille lors d’une mise à niveau de service sur des nœuds SDS.  Sans la minuterie de veille, le service PowerFlex démarre avant que CloudLink n’ait déverrouillé les disques.  En conséquence, certains ou tous les disques se trouvent dans un état d’erreur. 

Resolution

Ce problème est résolu dans PowerFlex Manager 3.8.3.   

Il existe un correctif PowerFlex Manager 3.8.2 pour s’assurer que la minuterie de mise en veille est présente. 

Pour PowerFlex Manager 3.8.0 et 3.8.1, utilisez la méthode suivante pour effectuer des mises à niveau de service avec chiffrement CloudLink.

 

Mettez à niveau la ressource CloudLink avec RCM vers la version souhaitée. 

 1. Connectez-vous à PowerFlex Manager.

2. Accédez à l’onglet Ressources et sélectionnez Toutes les ressources, puis sélectionnez un CloudLink Center à mettre à niveau. Vous ne devez mettre à niveau qu’un seul nœud d’un cluster CloudLink Center. Les nœuds restants sont mis à niveau automatiquement.

3. Cliquez sur Update Resources.

4. Choisissez Autoriser PowerFlex Manager à effectuer les mises à jour du firmware et du logiciel maintenant ou Planifier les mises à jour du firmware et du logiciel.

5. Cliquez sur Appliquer, puis sur Oui pour confirmer.

Mettez à niveau automatiquement tous les agents.  

Connectez-vous à CloudLink Center

Les nœuds SDS auront chacun une alarme indiquant que l’agent CloudLink n’a pas encore été mis à niveau.

Définissez la politique Machine Agent Upgrade sur Auto pour le groupe de machines qui contient les nœuds SDS en cours de mise à niveau (cela déclenche une mise à niveau de l’agent CloudLink sur tous les nœuds SDS) : 

Agents > Machine Groups > Action > Modify Group > Machine Agent Upgrade.

Attendez quelques minutes que CloudLink mette à niveau tous les agents CloudLink sur les nœuds SDS vers la nouvelle version. Assurez-vous que les alarmes de l’agent CloudLink sur les nœuds SDS ont disparu.

Mettez à jour le fichier /opt/emc/extra/pre_run.sh.

Sur chaque nœud SDS mis à niveau, vérifiez le fichier /opt/emc/extra/pre_run.sh.

S’il n’existe pas à l’aide de « vi », créez le fichier avec toutes les commandes indiquées ci-dessous.

Si elle existe, à l’aide de « vi », ajoutez la minuterie « sleep 60 » comme indiqué ci-dessous.

/opt/emc/extra/pre_run.sh:

#!/bin/bash -f

if [ -f /sbin/svm ]; then
  echo svm is installed $(date) >> /var/log/svm-sds
  /sbin/svmd -l /var/log/svmd.log -p /var/run/svmd.pid &
  end=$((SECONDS+300))
  sleep 60
  while [ $SECONDS -lt $end ]; do
    /sbin/svm unlocked > /dev/null && break
    sleep 5
  done
fi

  4. Modifiez les autorisations sur le fichier pre_run.sh « chmod 755 /opt/emc/extra/pre_run.sh »  

 Redémarrez les nœuds et effacez les erreurs (facultatif) :

  • Mettez un nœud SDS en mode maintenance protégée.
  • Enregistrez les lettres de lecteur en cours d’utilisation (par exemple, sda-sdk ou sdb - sdl)
  • Redémarrez le nœud.
  • Une fois le redémarrage terminé, assurez-vous qu’il n’y a pas d’erreurs PowerFlex dans l’interface utilisateur PowerFlex.   Si c’est le cas, effacez les erreurs.
  • Vérifiez /opt/emc/extra/pre_run.sh contient toujours la minuterie de mise en veille 60. Si ce n’est pas le cas, ajoutez la minuterie « sleep 60 » et répétez l’opération à partir de l’étape 3.   
  • Vérifiez l’ordre des lettres du disque. Si les disques ont été réorganisés, réinitialisez-les à l’aide des commandes scli :
scli --query_all_sds
scli --query_sds -sds_id   
scli --update_sds_original_paths -sds_id  

7. S’il y a eu des erreurs PowerFlex lors du premier redémarrage, répétez les étapes 3 à 6.

8. Sortez le nœud du mode maintenance protégée.

9. Répétez les étapes 1 à 8 pour tous les autres nœuds SDS afin de confirmer que pre_run.sh est correctement configuré.   

  Démarrer la mise à niveau du service

  • 1. Faites l’inventaire de tous les nœuds dans PFxM et confirmez que CloudLink est conforme à la nouvelle RCM sur tous les nœuds SDS.
  • 2. Effectuez la mise à niveau RCM sur le service.

 

 Pour PowerFlex Manager 3.8.2, appliquez le correctif ci-joint avant les mises à niveau de service qui disposent du chiffrement CloudLink :

Avant de démarrer la mise à niveau RCM, appliquez le correctif PowerFlex Manager 3.8.2 :  

Prenez un snapshot de l’appliance PowerFlex Manager. (Supprimez le snapshot une fois l’opération terminée.)

Téléchargez le fichier .zip joint à cet article de la base de connaissances et décompressez-le.   

Copiez le fichier Dell-VxFM-asm-deployer-3.8.2-52.noarch.rpm dans le répertoire /var/tmp de l’appliance PowerFlex Manager.

Accédez à SSH à l’appliance PowerFlex Manager.

Assurez-vous qu’aucune tâche n’est en cours d’exécution sur PFxM.

Exécutez les commandes suivantes sur l’appliance PowerFlex Manager pour appliquer le correctif :

cd /var/tmp
sudo rpm -Fvh Dell-VxFM-asm-deployer-3.8.2-52.noarch.rpm
sudo shutdown -r now 

La mise à niveau RCM peut maintenant être exécutée et il ne devrait pas y avoir d’erreurs SDS sur les disques chiffrés lors du redémarrage des nœuds.   

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Ιδιότητες άρθρου
Article Number: 000202412
Article Type: Solution
Τελευταία τροποποίηση: 27 Νοε 2025
Version:  11
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