RHEL: Importera Dell-nyckel från linux.dell.com till Red Hat Enterprise Linux 9 fel med "Hash-algoritmen SHA1 är inte tillgänglig"

Summary: Om du importerar Dell-nyckeln som signerats av "PG Hypervisor Engineering" till Red Hat Enterprise Linux 9 uppstår felet "Signaturen stöds inte". Den här nyckeln används endast för VMware-ändamål utan fel och är inte nödvändig för andra Linux-versioner. ...

Αυτό το άρθρο ισχύει για Αυτό το άρθρο δεν ισχύει για Αυτό το άρθρο δεν συνδέεται με κάποιο συγκεκριμένο προϊόν. Δεν προσδιορίζονται όλες οι εκδόσεις προϊόντων σε αυτό το άρθρο.

Symptoms

Det går inte att importera en specifik offentlig Dell-nyckel på Red Hat Enterprise Linux version 9 vid

rpm -I https://linux.dell.com/files/pgp_pubkeys/0x274E9C32857A9594.asc

warning: Signature not supported. Hash algorithm SHA1 not available.


Det här felet kan även inträffa om den här nyckeln läggs till i konfigurationsfilen yum.repos.d för en lokal kopia av lagringsplatsen för Dell Update Package (DUP) och OpenManage Server Administrator (OMSA).

Cause

Red Hat Enterprise Linux 9 avvisar som standard import av nycklar exklusivt med äldre SHA1-hashning.

Resolution

Den här specifika nyckeln med filnamnet 0x274E9C32857A9594.asc används endast av Dell för signering av två DUP-kataloger som endast används för VMware ESXi- och vSAN-konfigurationer. Till skillnad från de andra offentligt publicerade nycklarna i https://linux.dell.com/files/pgp_pubkeys/ bör den här nyckeln inte användas för eller importeras till någon annan Linux-version. Den kan också tas bort som en GNU Privacy Guard (GPG)-nyckel i vilken /etc/yum.repos.d/-konfigurationsfil som helst. Alla andra nycklar signeras med både SHA2- och SHA512-hashvärden som är acceptabla för Red Hat Enterprise Linux 9-säkerhetsprinciper.

Επηρεαζόμενα προϊόντα

OpenManage Server Administrator
Ιδιότητες άρθρου
Article Number: 000217148
Article Type: Solution
Τελευταία τροποποίηση: 21 Απρ 2025
Version:  3
Βρείτε απαντήσεις στις ερωτήσεις σας από άλλους χρήστες της Dell
Υπηρεσίες υποστήριξης
Ελέγξτε αν η συσκευή σας καλύπτεται από τις Υπηρεσίες υποστήριξης.