PowerProtect: Przeglądarka raportów Data Manager nie może wysłać raportu e-mail przy użyciu serwera SMTP z włączoną obsługą protokołu StartTLS.

Summary: Raporty e-mail nie są odbierane przez użytkowników.

Αυτό το άρθρο ισχύει για Αυτό το άρθρο δεν ισχύει για Αυτό το άρθρο δεν συνδέεται με κάποιο συγκεκριμένο προϊόν. Δεν προσδιορίζονται όλες οι εκδόσεις προϊόντων σε αυτό το άρθρο.

Symptoms

Po dodaniu konfiguracji poczty e-mail do programu PowerProtect Data Manager (PPDM) raporty nie są odbierane za pośrednictwem wiadomości e-mail.

Na serwerze raportowania w pliku server.log występuje błąd podobny do poniższego:
2024-02-05 15:32:37,010 ERROR [com.emc.dpa.command.notification.NotificationSenderMDB] (Thread-131073) Problems while sending e-mail notification: com.sun.mail.smtp.SMTPSendFailedException: 451 5.7.3 STARTTLS is required to send mail [MailServer 2024-02-05T08:32:36.994Z 08DC257F199B3AC5]
 

Cause

Serwer poczty e-mail zdefiniowany w konfiguracji ma włączoną funkcję StartTLS. Wymaga od klientów korzystania z StartTLS podczas łączenia się w celu wysyłania wiadomości e-mail.

Resolution

Aby rozwiązać ten problem, protokół StartTLS musi być włączony w ramach konfiguracji przechowywanej na serwerze raportowania.

Aby rozwiązać ten problem, należy wykonać poniższe czynności.

Etapy dotyczące programu PowerProtect Data Manager 19.16

  1. Zaloguj się do serwera raportowania za pomocą konta administratora, a następnie zmień ustawienie na root. Jeśli wymagane są poświadczenia, skontaktuj się z zespołem pomocy technicznej firmy DELL Technologies , aby uzyskać poświadczenie.
  2. Zmień katalog na '/opt/emc/dpa/services/bin'
# cd /opt/emc/dpa/services/bin
 
  1. Uruchom następujące polecenie, aby uzyskać szczegółowe informacje o bieżącej konfiguracji:
# ./dpa.sh ds query "select * from apollo.mail_server_configuration"

  
  1. Zanotuj wartość zgłoszoną w sekcji f_id i f_start_tls_enabled. Poniżej przedstawiono przykład oczekiwanego wyniku:
# ./dpa.sh ds query "select * from apollo.mail_server_configuration"
EMC Data Protection Advisor
                 f_id                 |     f_lastmodified      |           f_credential_id            |  f_from_address   |     f_hostname     | f_port | f_security_protocol | f_start_tls_enabled
--------------------------------------+-------------------------+--------------------------------------+-------------------+--------------------+--------+---------------------+---------------------
 d61193eb-be0c-42aa-a841-7ef1b281d008 | 2023-12-12 09:02:01.978 | c7321673-3879-4c5e-b0f2-a0029f8815c9 | ppdm@yourcompany.com | smtp.emailserverdomain.com |    587 | None                | f
(1 row)
 
  1. Jeśli f_start_tls_enabled wartość jest ustawiona na "f", należy ją zmienić na "t". Aby wprowadzić tę zmianę, można użyć następującego polecenia:
./dpa.sh ds query "UPDATE apollo.mail_server_configuration SET  f_start_tls_enabled = 't' WHERE f_id = 'f_id identified from step above'"

  
Przykład:
# ./dpa.sh ds query "UPDATE apollo.mail_server_configuration SET  f_start_tls_enabled = 't' WHERE f_id = 'd61193eb-be0c-42aa-a841-7ef1b281d008'"

EMC Data Protection Advisor

UPDATE 1
 
  1. Uruchom ponownie usługi na serwerze raportowania przy użyciu poniższego polecenia:
# ./dpa.sh svc restart 
 

Kroki dotyczące programu PowerProtect Data Manager 19.17

  1. Zaloguj się do serwera raportowania za pomocą konta administratora, a następnie zmień ustawienie na root. Jeśli wymagane są poświadczenia, skontaktuj się z zespołem pomocy technicznej firmy DELL Technologies , aby uzyskać poświadczenie.

    Nuta: W kilku różnych krokach hasło jest wymieniane jako "Hasło123!". To musi być zaktualizowane prawdziwym hasłem.
     
  2. Uruchom następujące polecenie, aby uzyskać szczegółowe informacje o bieżącej konfiguracji:
# psql postgresql://reportinguser:'Password123!'@127.0.0.1:9003/apollo -c "select * from apollo.mail_server_configuration" 
 
  1. Zanotuj wartość zgłoszoną w sekcji f_id i f_start_tls_enabled. Poniżej przedstawiono przykład oczekiwanego wyniku:
# psql postgresql://reportinguser:'Password123!'@127.0.0.1:9003/apollo -c "select * from apollo.mail_server_configuration"    
EMC Data Protection Advisor                     
f_id                 |     f_lastmodified      |           f_credential_id            |  f_from_address   |     f_hostname     | f_port | f_security_protocol | f_start_tls_enabled    
--------------------------------------+-------------------------+--------------------------------------+-------------------+--------------------+--------+---------------------+---------------------     
d61193eb-be0c-42aa-a841-7ef1b281d008 | 2023-12-12 09:02:01.978 | c7321673-3879-4c5e-b0f2-a0029f8815c9 | ppdm@yourcompany.com | smtp.emailserverdomain.com |    587 | None                | f    
(1 row)   

  

 

  1. Jeśli f_start_tls_enabled wartość jest ustawiona na "f", należy ją zmienić na "t". Aby wprowadzić tę zmianę, można użyć następującego polecenia:
#psql postgresql://reportinguser:'Password123!'@127.0.0.1:9003/apollo -c "UPDATE apollo.mail_server_configuration SET f_start_tls_enabled = 't' WHERE f_id = 'f_id identified from step above'" 
 
Przykład:
# psql postgresql://reportinguser:'Password123!'@127.0.0.1:9003/apollo -c "UPDATE apollo.mail_server_configuration SET  f_start_tls_enabled = 't' WHERE f_id = 'd61193eb-be0c-42aa-a841-7ef1b281d008'"  
 
EMC Data Protection Advisor  
 
UPDATE 1 
 
  1. Uruchom ponownie usługi na serwerze raportowania przy użyciu poniższego polecenia:
# systemctl start reporting-service.service reporting-data-collector.service  reporting-data-processor.service reporting-generator.service 

 

Etapy dotyczące programu PowerProtect Data Manager 19.18

  1. Zaloguj się do serwera raportowania za pomocą konta administratora, a następnie zmień ustawienie na root. Jeśli wymagane są poświadczenia, skontaktuj się z zespołem pomocy technicznej firmy DELL Technologies , aby uzyskać poświadczenie.

    Nuta: W kilku różnych krokach hasło jest wymieniane jako "Hasło123!". To musi być zaktualizowane prawdziwym hasłem.
     
  2. Uruchom następujące polecenie, aby uzyskać szczegółowe informacje o bieżącej konfiguracji:
 
# psql postgresql://reportinguser:'Password123!'@127.0.0.1:9003/reporting -c "select * from reportconfig.mail_server_configuration" 
 
  1. Zanotuj wartość zgłoszoną w sekcji f_id i f_start_tls_enabled. Poniżej przedstawiono przykład oczekiwanego wyniku:
EMC Data Protection Advisor
                     f_id                 |     f_lastmodified      |           f_credential_id            |  f_from_address   |     f_hostname     | f_port | f_security_protocol | f_start_tls_enabled    
--------------------------------------+-------------------------+--------------------------------------+-------------------+--------------------+--------+---------------------+---------------------     
d61193eb-be0c-42aa-a841-7ef1b281d008 | 2023-12-12 09:02:01.978 | c7321673-3879-4c5e-b0f2-a0029f8815c9 | ppdm@yourcompany.com | smtp.emailserverdomain.com |    587 | None                | f    
(1 row)    
 
  1. Jeśli f_start_tls_enabled wartość jest ustawiona na "f", należy ją zmienić na "t". Aby wprowadzić tę zmianę, można użyć następującego polecenia:
psql postgresql://reportinguser:'Password123!'@127.0.0.1:9003/reporting -c "UPDATE reportconfig.mail_server_configuration SET  f_start_tls_enabled = 't' WHERE f_id = 'f_id identified from step above'"   
 
Przykład:
# psql postgresql://reportinguser:'Password123!'@127.0.0.1:9003/reporting -c "UPDATE reportconfig.mail_server_configuration SET  f_start_tls_enabled = 't' WHERE f_id = 'd61193eb-be0c-42aa-a841-7ef1b281d008'"  

EMC Data Protection Advisor  
 
UPDATE 1 
 
  1. Uruchom ponownie usługi na serwerze raportowania przy użyciu poniższego polecenia:
# systemctl start reporting-service.service reporting-data-collector.service  reporting-data-processor.service reporting-generator.service 

Επηρεαζόμενα προϊόντα

PowerProtect Data Manager, PowerProtect Data Manager Essentials
Ιδιότητες άρθρου
Article Number: 000221887
Article Type: Solution
Τελευταία τροποποίηση: 26 Μαΐ 2025
Version:  3
Βρείτε απαντήσεις στις ερωτήσεις σας από άλλους χρήστες της Dell
Υπηρεσίες υποστήριξης
Ελέγξτε αν η συσκευή σας καλύπτεται από τις Υπηρεσίες υποστήριξης.