PowerProtect Data Manager: VMware Plugin Restarting Due To Java Heap Space Error

Summary: Alert received in PowerProtect Data Manager (PPDM) User Interface (UI): Component Virtual Machine (VM) Ware Plugin is restarting on host ppdm01.domain.local.

Αυτό το άρθρο ισχύει για Αυτό το άρθρο δεν ισχύει για Αυτό το άρθρο δεν συνδέεται με κάποιο συγκεκριμένο προϊόν. Δεν προσδιορίζονται όλες οι εκδόσεις προϊόντων σε αυτό το άρθρο.

Symptoms

The following alert was received in the PPDM UI: Component VMware Plugin is restarting on host ppdm01.domain.local.

The below messages are found on the below logs:

sysmgr.log:

2025-05-20T01:46:15.157Z WARN [] [Thread-22] [][][][TRACE_ID:bf2b101996cc3884][] [c.e.b.s.d.d.ServiceComponent.isComponentRunningCheckUsingScript(435)] - Component VMwarePlugin is not running
2025-05-20T01:46:15.594Z ERROR [] [Thread-22] [][ALERT:SYS0052][][TRACE_ID:bf2b101996cc3884][] [c.e.d.e.c.s.m.DefaultMessageResourceModifier.printAlertLog(143)] - Date: May 20, 2025 03:46:15 AM; Summary: Component VMware Plugin is restarting on host ppdm01.domain.local.; Details: This component was detected as not running on the PowerProtect Data Manager system, and has been restarted automatically on the specified host.; Recommended Action: If the component was stopped manually, you can ignore this alert. If the component stopped without user intervention and this alert continues to appear, contact Dell Customer Support.; Detail Summaries: null; Status: UNACKNOWLEDGED

vmware-plugin.out:

2025-05-20T01:45:43.373Z PPDM liveness HEARTBEAT from service vmware-plugin
java.lang.OutOfMemoryError: Java heap space
Dumping heap to /var/log/brs/vmware-plugin/java_pid69079.hprof ...
Heap dump file created [365106841 bytes in 2.321 secs]
Terminating due to java.lang.OutOfMemoryError: Java heap space

Cause

The vmware-plugin service ran out of memory.

This is evident from the error message:

java.lang.OutOfMemoryError: Java heap space

The maximum memory the vmware-plugin service can allocate is by default 312MB, as specified in the file /usr/local/brs/lib/vmware-plugin/bin/vmware-plugin.

Also, the garbage collection logs (jvm-gc-vmware-plugin.log) show that the Java process was experiencing allocation failures, leading to a full pause in the garbage collection process:

[2025-05-20T01:45:57.775+0000] GC(59719) Pause Full (Allocation Failure) 219M->219M(223M) 95.545ms
[2025-05-20T01:45:58.067+0000] GC(59722) Pause Full (Allocation Failure) 219M->219M(223M) 94.374ms
[2025-05-20T01:45:58.265+0000] GC(59724) Pause Full (Allocation Failure) 219M->219M(223M) 100.429ms

These errors and logs indicate that the vmware-plugin service was terminated due to a Java heap space error, causing the service to restart.

Resolution

To clear the alert in the PPDM UI, remove the java heap dump.

If this was a one-time issue, monitor for future occurrences.

If the service is unresponsive too often, contact Dell Customer Support for further assistance, providing a PPDM log bundle.

Επηρεαζόμενα προϊόντα

PowerProtect Data Manager
Ιδιότητες άρθρου
Article Number: 000323079
Article Type: Solution
Τελευταία τροποποίηση: 14 Ιαν 2026
Version:  2
Βρείτε απαντήσεις στις ερωτήσεις σας από άλλους χρήστες της Dell
Υπηρεσίες υποστήριξης
Ελέγξτε αν η συσκευή σας καλύπτεται από τις Υπηρεσίες υποστήριξης.