Eseguire la disinstallazione dopo aver risolto il problema di migrazione da 5.x a 6.x

Summary: Il problema di migrazione è stato risolto causando errori di autenticazione nello script di riavvio.

Αυτό το άρθρο ισχύει για Αυτό το άρθρο δεν ισχύει για Αυτό το άρθρο δεν συνδέεται με κάποιο συγκεκριμένο προϊόν. Δεν προσδιορίζονται όλες οι εκδόσεις προϊόντων σε αυτό το άρθρο.

Symptoms

Il cliente non è in grado di riavviare lo script di migrazione/aggiornamento a causa di un errore di autenticazione.

 

Cause

La causa del problema era dovuta a un errore di autenticazione. Nell'aggiornamento a InsightIQ 6.0, IIQ 5.x viene arrestato e IIQ 6.0 viene installato. Quando si riattiva l'aggiornamento dopo aver risolto il problema di migrazione, gli script chiedono di eseguire l'autenticazione, ma l'operazione ha esito negativo poiché IIQ 5.x non è disponibile. In questo modo l'aggiornamento non riesce.

Resolution

Se si sospetta di riscontrare questo problema, assicurarsi di aprire una richiesta di assistenza al supporto per ottenere il file indicato nella risoluzione. Ciò consente di verificare che il problema sia stato riscontrato, in quanto presenta problemi simili che il piano d'azione riportato di seguito non affronta. Quando si apre un caso, estrai le informazioni da https://www.dell.com/support/kbdoc/en-us/000014272 (per visualizzare questo articolo è necessario un account del supporto Dell).

NOTA: NON CONTINUARE SE NON È STATO ESEGUITO L'AGGIORNAMENTO ALLA VERSIONE 6.0 O 6.0.1 E SI VERIFICANO PROBLEMI CON LA PULIZIA O IL PASSAGGIO ALLA VERSIONE SUCCESSIVA DI INSIGHTIQ 6.X.

  1. Scaricare prima il pacchetto perform_uninstall_and_cleanup_on_5.x_setup.tgz .

  2. Estrarre il bundle

    1. Vedete la struttura in questo modo,
      [root@hostname1 perform_uninstall_and_cleanup_on_5.x_setup]# ls -l
      total 48
      -rwxr-xr-x. 1 root root  8684 Aug 12 13:17 helper_methods.sh
      -rwxr-xr-x. 1 root root  3645 Aug 12 13:17 logging.sh
      drwxr-xr-x. 3 root root    96 Aug 12 13:17 ova
      -rwxr-xr-x. 1 root root   358 Aug 12 13:17 ova_post.sh
      -rwx--x--x. 1 root root 12752 Aug 12 13:17 perform_uninstall_and_cleanup_on_iiq_simple.sh
      -rwxr-xr-x. 1 root root  8090 Aug 12 13:17 perform_uninstall_and_cleanup.sh
      -rw-r--r--. 1 root root  1165 Aug 12 13:17 README.md
      drwxr-xr-x. 2 root root    98 Aug 12 13:17 uninstall_5.x
  3. Visualizza README.md

  4. Conferma del tipo IIQ e attivazione dello script

    • Per IIQ Simple, eseguire quanto segue:
      ./perform_uninstall_and_cleanup_on_iiq_simple.sh
    • Per IIQ Scale, eseguire i seguenti passaggi:
      ./perform_uninstall_and_cleanup.sh -m <ip> -p <password> -u <ip> -v <password> -w <ip> -x <password>
  5. Controllare i registri

    showupg -l

 

Προϊόντα

PowerScale InsightIQ
Ιδιότητες άρθρου
Article Number: 000362054
Article Type: Solution
Τελευταία τροποποίηση: 15 Δεκ 2025
Version:  3
Βρείτε απαντήσεις στις ερωτήσεις σας από άλλους χρήστες της Dell
Υπηρεσίες υποστήριξης
Ελέγξτε αν η συσκευή σας καλύπτεται από τις Υπηρεσίες υποστήριξης.