PowerScale. Команды AD sudo перестают работать после модернизации

Summary: После модернизации PowerScale OneFS команды sudo три раза запрашивают пароль, а затем не могут выполнить команду с ошибкой «sudo: 3 попытки ввода неверного пароля»

Αυτό το άρθρο ισχύει για Αυτό το άρθρο δεν ισχύει για Αυτό το άρθρο δεν συνδέεται με κάποιο συγκεκριμένο προϊόν. Δεν προσδιορίζονται όλες οι εκδόσεις προϊόντων σε αυτό το άρθρο.

Symptoms

Пользователь Active Directory (в данном случае имя пользователя AD — «PowerScale») в роли системного администратора по-прежнему разрешает вход по протоколу SSH, команда завершается следующим образом:

cluster-1# ssh DOMAIN\\PowerScale@cluster-1
(DOMAIN\PowerScale@cluster-1) Password: 
PowerScale OneFS 9.12.0.1
Could not chdir to home directory /ifs/home/DOMAIN/PowerScale: No such file or directory
cluster-1% sudo -s

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

For security reasons, the password you type will not be visible.

Password: 
Sorry, try again.
Password: 
Sorry, try again.
Password: 
sudo: 3 incorrect password attempts
cluster0-1% 

Ошибки в /var/log/auth.log похожи на:

2026-01-09T14:08:46.964341-05:00 <4.6> isi-9510-1(id1) sshd[9292]: Accepted keyboard-interactive/pam for DOMAIN\PowerScale from 10.20.48.1 port 31599 ssh2
2026-01-09T14:09:02.165862-05:00 <4.1> isi-9510-1(id1) sudo[9315]: DOMAIN\PowerScale : 3 incorrect password attempts ; TTY=pts/1 ; PWD=/ ; USER=root ; COMMAND=/bin/zs

Cause

Обновление sudo привело к ошибке имен пользователей Active Directory в верхнем регистре. Обратите внимание, что это относится только к средам, в которых пользователям Active Directory требуется запрашивать пароль, это не должно повлиять на команды sudo без пароля. Защищенные паролем запросы содержат записи в 'isi_visudo' Типа того:

DOMAIN\\powerscale ALL=(ALL) PASSWD: ALL

Resolution

Инженерный отдел PowerScale обнаружил эту проблему и работает над ее устранением. Пользователи могут отредактировать имя пользователя в Active Directory так, чтобы оно было написано в нижнем регистре:

Экран свойств

Как и в случае с любыми изменениями в Active Directory, для их выполнения может потребоваться некоторое время. Если пользователь по-прежнему не работает, запустите сбор журнала и обратитесь в службу поддержки PowerScale.

Ιδιότητες άρθρου
Article Number: 000413077
Article Type: Solution
Τελευταία τροποποίηση: 12 Ιαν 2026
Version:  1
Βρείτε απαντήσεις στις ερωτήσεις σας από άλλους χρήστες της Dell
Υπηρεσίες υποστήριξης
Ελέγξτε αν η συσκευή σας καλύπτεται από τις Υπηρεσίες υποστήριξης.