ECS: Oracle RMAN-program støder på HTTP 501-fejl Ikke implementeret efter opgradering til ECS 3.8.0.1 - 3.8.0.4
Summary: På grund af en ECS-regression kan Oracle Recovery Manager (RMAN)-sikkerhedskopieringsprogrammet støde på HTTP-fejl 501 "Ikke implementeret" efter opgradering til ECS 3.8.0.1 - 3.8.0.4.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Efter opgradering til ECS 3.8.0.1 - 3.8.0.4 kan programanmodninger mislykkes med HTTP-fejlen "501 Not Implemented", hvis alle parametre, der bruges i anmodningen, ikke er på en intern ECS-liste over understøttede enheder.
Fejl set på RMAN:
Bekræft problem på ECS:
Command:
Eksempel:
Hvis du tager requestID som eksempel, skal du yderligere spore fejlen som nedenfor:
Kommando:
- Det er bekræftet, at Oracle Recovery Manager (RMAN) Backup App er berørt af dette problem.
- Problemet påvirker Oracle RMAN, hvis der skrives direkte til ECS. Hvis Oracle RMAN skriver til ECS via et andet program, påvirkes det ikke.
- Andre programmer kan blive påvirket, hvis de bruger en lignende konfiguration, hvor alle parametre i anmodningen ikke er en del af den understøttede liste.
Fejl set på RMAN:
RMAN-03009: failure of backup command on ORA_SBT_TAPE_1 channel at 11/20/2023 15:15:13 ORA-19506: failed to create sequential file, name="DB_FIP_20231120_mj2bv7g0_503507_1_1", parms="" ORA-27028: skgfqcre: sbtbackup returned error ORA-19511: non RMAN, but media manager or vendor specific failure, error text: KBHS-01404: See trace file /soft/oracle19/diag/rdbms/fip/fip/trace/sbtio_25047_140117933847552.log for details KBHS-00700: HTTP response error 'Not Implemented'
Bekræft problem på ECS:
Command:
svc_log -f "does not support operation with signature B" -start '<Timeline errors received in ECS> -sr dataheadsvc -n all -sf
Eksempel:
# svc_log -f "does not support operation with signature B" -start '1 hours ago' -sr dataheadsvc -n all -sf svc_log v1.0.31 (svc_tools v2.14.0) Started 2023-11-22 15:34:17 Running on nodes: <All nodes> Time range: 2023-11-21 03:34:17 - 2023-11-22 15:34:17 Filter string(s): 'does not support operation with signature B' Show filename(s): True Show nodename(s): True Search reclaim logs (if any): False 169.254.1.5 dataheadsvc.log.20231121-134402.gz 2023-11-21T12:01:51,006 [qtp379782668-6225-88a5e8cf:18bedd2e9f0:d5e:4-s3-136.165.238.100] ERROR S3Service.java (line 638) does not support operation with signature B?not-implemented, request Id 88a5e8cf:18bedd2e9f0:d5e:4
Hvis du tager requestID som eksempel, skal du yderligere spore fejlen som nedenfor:
Kommando:
# svc_log -f "request ID highlighted from previous step" -sr dataheadsvc dataheadsvc-access -start <Timeline of requestID> -sfEksempel:
#svc_log -f "88a5e8cf:18bedd2e9f0:d5e:4" -sr dataheadsvc dataheadsvc-access -start 1h -sf svc_log v1.0.31 (svc_tools v2.14.0) Started 2023-11-22 15:45:40 Running on nodes: <All nodes> Time range: 2023-11-21 03:45:40 - 2023-11-22 15:45:40 Filter string(s): '88a5e8cf:18bedd2e9f0:d5e:4' Show filename(s): True Show nodename(s): True Search reclaim logs (if any): False <output truncated> . . 169.254.1.5 dataheadsvc.log.20231121-134402.gz 2023-11-21T12:01:51,006 [qtp379782668-6225-88a5e8cf:18bedd2e9f0:d5e:4-s3-136.165.238.100] ERROR S3Service.java (line 638) does not support operation with signature B?not-implemented, request Id 88a5e8cf:18bedd2e9f0:d5e:4 169.254.1.5 dataheadsvc-access.log 2023-11-21 12:01:51,007 88a5e8cf:18bedd2e9f0:d5e:4 136.165.232.207:9020 136.165.238.100:4249 dba-rman-prod - HEAD ul-rman-prod ul-rman-prod-01 ul-rman-prod-01 format=xml&x-BlockSize=262144&x-CopyNumber=0&x-Dbid=808640723&x-Dbname=RCAT&x-FileName=DB_RCAT_20231121_1i2c0uuu_63538_1_1&x-Incarnation=fpC63dLILKPb&x-NetTest=FALSE&x-Node=node1.hostname&x-OpenTime=2023-11-21%2012%3A01%3A51 &x-ReqCnt=34&x-ReqTime=2023-11-21%2012%3A01%3A51&x-SbtApi=sbtbackup&x-SbtOp=BeginUpload&x-SbtVersion=19.0.0.1&x-SessionId=0AA9580D05342089E063F7EDA5880453&x-System=Linux%20x86%2064-bit&x- SystemId=13&x-User=oracle HTTP/1.1 501 2 - - 1 - - - - 'x-amz-date: 20231121T120151Z' 'Connection: close' 'X-Amz-Content-SHA256: e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855' . . <output truncated>
Cause
Dette problem skyldes en regression, der blev introduceret i ECS STORAGE-28517.
- Hvis applikationen ikke bruger nogen parametre, støder den ikke på HTTP 501-fejlen.
- Hvis applikationen bruger parametre:
- Hvis du bruger mindst én parameter fra listen over understøttede parametre (nedenfor), rapporteres der ingen HTTP 501-fejl.
- Hvis alle de parametre, der bruges i forespørgslen, ikke findes på listen over understøttede parametre, rapporteres fejlen HTTP 501.
| "acl", "lifecycle", "object-lock", "enable-object-lock", "location", "logging", "notification", "policy", "requestPayment", "torrent", "delete", "uploadId", "uploads", "versioning", "versions", "website ", "tagging", "cors", "accessmode", "fileaccess", "ping", "cors", "endpoint", "isstaleallowed", "query", "replication", "replicationInfo", "legal-hold", "retention", "retentionUpdate", "searchmetadata", "snapshot", "snapshots", "snapshotId", "empty-bucket-status", "select", "detailedReplicationStatus" |
Resolution
Problemet er løst ved at starte ECS 3.8.0.5.
- Hvis du påvirkes af dette problem efter opgradering til ECS 3.8.0.1 - 3.8.0.4, skal du åbne en sag hos teknisk support for at få rettelsen.
- Hvis du bruger Oracle RMAN og planlægger at opgradere til ECS 3.8.0.1 - 3.8.0.4, skal du informere Services, mens de planlægger opgraderingen, så de anmoder om en særlig programrettelse til opgraderingen. Denne specielle programrettelse løser dette problem.
BEMÆRK: Da problemet er løst i nyere kode, anbefales det at opgradere til en version med rettelsen.
Affected Products
ECS, ECS Appliance, ECS Appliance Gen 1, ECS Appliance Gen 2, ECS Appliance Gen 3, ECS Appliance Hardware Series, ECS Appliance Software with Encryption, ECS Appliance Software without Encryption, ECS Software, Elastic Cloud StorageArticle Properties
Article Number: 000219799
Article Type: Solution
Last Modified: 11 Mar 2024
Version: 8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.