ECS. Приложение Oracle RMAN сталкивается с ошибкой HTTP 501 Не реализовано после модернизации до ECS 3.8.0.1–3.8.0.4

Summary: Из-за регрессии ECS приложение резервного копирования Oracle Recovery Manager (RMAN) может столкнуться с ошибкой HTTP 501 «Не реализовано» после модернизации ECS до версии 3.8.0.1–3.8.0.4. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

После модернизации ECS до версии 3.8.0.1–3.8.0.4 запросы приложений могут завершаться сбоем с ошибкой HTTP «501 Not Implemented», если все параметры, используемые в запросе, не входят во внутренний список поддерживаемых параметров ECS.
  • Подтверждено, что эта проблема затрагивает приложение резервного копирования Oracle Recovery Manager (RMAN). 
  • Проблема влияет на Oracle RMAN при записи напрямую в ECS. Если Oracle RMAN выполняет запись в ECS через другое приложение, это не повлияет на нее. 
  • Это может повлиять на работу других приложений, если они используют аналогичную конфигурацию, в которой все параметры запроса не входят в список поддерживаемых. 
 
Ошибка, наблюдаемая в RMAN:
RMAN-03009: failure of backup command on ORA_SBT_TAPE_1 channel at 11/20/2023 15:15:13 ORA-19506: failed to create sequential file,
name="DB_FIP_20231120_mj2bv7g0_503507_1_1", parms="" ORA-27028: skgfqcre: sbtbackup returned error ORA-19511: non RMAN, but media manager or vendor specific failure, 
error text: KBHS-01404: See trace file /soft/oracle19/diag/rdbms/fip/fip/trace/sbtio_25047_140117933847552.log for details KBHS-00700: HTTP response error 'Not Implemented'

Проверьте проблему с помощью ECS:

Command:
svc_log -f "does not support operation with signature B" -start '<Timeline errors received in ECS> -sr dataheadsvc -n all -sf

Пример.
# svc_log -f "does not support operation with signature B" -start '1 hours ago' -sr dataheadsvc -n all -sf
svc_log v1.0.31 (svc_tools v2.14.0)                 Started 2023-11-22 15:34:17

Running on nodes:              <All nodes>
Time range:                    2023-11-21 03:34:17 - 2023-11-22 15:34:17
Filter string(s):              'does not support operation with signature B'
Show filename(s):              True
Show nodename(s):              True
Search reclaim logs (if any):  False

169.254.1.5 dataheadsvc.log.20231121-134402.gz 2023-11-21T12:01:51,006 [qtp379782668-6225-88a5e8cf:18bedd2e9f0:d5e:4-s3-136.165.238.100] 
ERROR  S3Service.java (line 638) does not support operation with signature B?not-implemented, request Id 88a5e8cf:18bedd2e9f0:d5e:4

Взяв в качестве примера requestID, отследим ошибку следующим образом:

Команда:
# svc_log -f "request ID highlighted from previous step" -sr dataheadsvc dataheadsvc-access -start <Timeline of requestID> -sf
Пример.
#svc_log -f "88a5e8cf:18bedd2e9f0:d5e:4" -sr dataheadsvc dataheadsvc-access -start 1h -sf
svc_log v1.0.31 (svc_tools v2.14.0)                 Started 2023-11-22 15:45:40

Running on nodes:              <All nodes>
Time range:                    2023-11-21 03:45:40 - 2023-11-22 15:45:40
Filter string(s):              '88a5e8cf:18bedd2e9f0:d5e:4'
Show filename(s):              True
Show nodename(s):              True
Search reclaim logs (if any):  False

<output truncated>
.
.
169.254.1.5 dataheadsvc.log.20231121-134402.gz 2023-11-21T12:01:51,006 [qtp379782668-6225-88a5e8cf:18bedd2e9f0:d5e:4-s3-136.165.238.100] 
ERROR  S3Service.java (line 638) does not support operation with signature B?not-implemented, request Id 88a5e8cf:18bedd2e9f0:d5e:4

169.254.1.5 dataheadsvc-access.log 2023-11-21 12:01:51,007 88a5e8cf:18bedd2e9f0:d5e:4 136.165.232.207:9020 136.165.238.100:4249 dba-rman-prod - HEAD ul-rman-prod ul-rman-prod-01 
ul-rman-prod-01 format=xml&x-BlockSize=262144&x-CopyNumber=0&x-Dbid=808640723&x-Dbname=RCAT&x-FileName=DB_RCAT_20231121_1i2c0uuu_63538_1_1&x-Incarnation=fpC63dLILKPb&x-NetTest=FALSE&x-Node=node1.hostname&x-OpenTime=2023-11-21%2012%3A01%3A51
&x-ReqCnt=34&x-ReqTime=2023-11-21%2012%3A01%3A51&x-SbtApi=sbtbackup&x-SbtOp=BeginUpload&x-SbtVersion=19.0.0.1&x-SessionId=0AA9580D05342089E063F7EDA5880453&x-System=Linux%20x86%2064-bit&x-
SystemId=13&x-User=oracle HTTP/1.1 501 2 - - 1 - - - - 'x-amz-date: 20231121T120151Z' 'Connection: close' 'X-Amz-Content-SHA256: e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855'
.
.
<output truncated>

Cause

Эта проблема вызвана регрессией, внедренной в ECS STORAGE-28517.
  1. Если приложение не использует никаких параметров, оно не сталкивается с ошибкой HTTP 501. 
  2. Если приложение использует параметры:
    1. При использовании хотя бы одного параметра из списка поддерживаемых параметров (см. ниже) ошибки HTTP 501 не отображаются. 
    2. Если все параметры, используемые в запросе, не входят в список поддерживаемых параметров, то сообщается об ошибке HTTP 501. 
Ниже приведен список поддерживаемых параметров. Если приложение не использует ни один из этих параметров в рамках запроса к ECS, будет выведена ошибка 501.
 
"acl",
"lifecycle",
"object-lock",
"enable-object-lock",
"location",
"logging",
"notification"
, "policy",
"requestPayment",
"torrent",
"delete",
"uploadId",
"uploads",
"versioning", "versions
",
"website",
"tagging",
"cors",
"accessmode",
"fileaccess",
"ping",
"cors",
"endpoint",
"isstaleallowed", "query",

"replication",
"replicationInfo",
"legal-hold", "retention",

"retentionUpdate",
"searchmetadata",
"snapshot",
"
snapshots", "snapshotId",
"empty-bucket-status",
"select",
"detailedReplicationStatus"

Resolution

Проблема устранена, начиная с версии ECS 3.8.0.5.
  • При возникновении этой проблемы после модернизации до ECS 3.8.0.1–3.8.0.4 откройте заявку в службе технической поддержки для получения исправления.
  • Если вы используете Oracle RMAN и планируете обновление до версии ECS 3.8.0.1–3.8.0.4, сообщите об этом службам при планировании модернизации, чтобы они запросили специальное исправление для модернизации. Это специальное исправление исправит эту проблему. 
    ПРИМЕЧАНИЕ. Поскольку проблема устранена в более новом коде, рекомендуется выполнить модернизацию до версии с исправлением. 

Affected Products

ECS, ECS Appliance, ECS Appliance Gen 1, ECS Appliance Gen 2, ECS Appliance Gen 3, ECS Appliance Hardware Series, ECS Appliance Software with Encryption, ECS Appliance Software without Encryption, ECS Software, Elastic Cloud Storage
Article Properties
Article Number: 000219799
Article Type: Solution
Last Modified: 11 Mar 2024
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.