NetWorker: Troubleshooting Backup Failures Due to VSS Issues

Summary: Backups of a Windows client are failing due to Microsoft Volume Shadow copy Service (VSS) issues. There are several different reasons that could result in VSS failing to process a snapshot on the client operating system; e.g: Unstable VSS writer, or insufficient space to create a snapshot. VSS is required for SYSTEM STATE or DISASTER RECOVERY: save sets or when completing Block-Based Backups (BBB). VSS must be stable and working correctly on the host operating system before it can be used with NetWorker backups. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Backups of a Windows client are failing due to VSS issues. There are several different reasons that could result in VSS failing to process a snapshot on the client operating system; for example: Unstable VSS writer, or insufficient space to create a snapshot.
NOTE: This KB outlines steps for Windows or NetWorker admins, but persistent VSS issues must be raised to Microsoft support for further investigation.

These issues are typically indicated in the backup logs which can be observed in the NMC.
VSS OTHER: ERROR: VSS failed to process snapshot: 
90108:save: Unable to save the SYSTEM STATE save sets: cannot create the snapshot. 
7259:save: VSS reports adding volume [C:\] <file:///C:/]> to snapshot set failed for both hardware/software provider.VSS OTHER: ERROR: VSS failed to process snapshot: Unexpected VSS provider error.
VSS OTHER: ERROR: VSS failed to process snapshot: Insufficient storage available to create either the shadow copy storage file or other shadow copy data. (VSS error 0x8004231f)
90108:save: Unable to save the SYSTEM STATE save sets: cannot create the snapshot.
VSS-related events are also visible in the Windows Event Viewer on the client.

Cause

VSS is a Windows operating system function. VSS is required for SYSTEM STATE or DISASTER RECOVERY:\ save sets or when completing Block-Based Backups (BBB). VSS must be stable and working correctly on the host operating system before it can be used with NetWorker backups.

Resolution

First rule out a potential capacity issue. Microsoft recommends leaving 10-15% of a drives total capacity available for completing VSS snapshots. If the capacity is above 90%, VSS snapshots may fail.

To test whether or not VSS is working correctly on the client operating system, run the following commands from an administrative command prompt:
1. Check the VSS writers status: vssadmin list writers
Example:

c:\>vssadmin list writers
vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
(C) Copyright 2001-2012 Microsoft Corp.

Writer name: 'System Writer'
Writer Id: {e8132975-6f93-4464-a53e-1050253ae220}
Writer Instance Id: {34a07e16-fcdb-4ab0-b603-d58c0f741c9a}
State: [1] Stable
Last error: No error
...
...
NOTE: The above output is an example of one of the writers; however, ALL writers should be Stable, No error.


2. If the writers are stable check for preexisting snapshots, there should be none: vssadmin list shadows
Example:

c:\>vssadmin list shadows
vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
(C) Copyright 2001-2012 Microsoft Corp.

No items found that satisfy the query.

3. If there are snapshots listed, delete them: vssadmin delete shadows /all
Example:
c:\>vssadmin delete shadows /all
vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
(C) Copyright 2001-2012 Microsoft Corp.

Do you really want to delete 1 shadow copies (Y/N): [N]? y

Successfully deleted 1 shadow copies.
4. Once there are no snapshots, and if the disk drive is below 90% capacity usage, attempt to create a snapshot: vssadmin create shadow /for=DRIVE_LETTER:\ 
Example: 
c:\>vssadmin create shadow /for=C:\
vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
(C) Copyright 2001-2012 Microsoft Corp.

Successfully created shadow copy for 'C:\'
    Shadow Copy ID: {1f6a1448-daad-4e68-a334-31dd40a64dd9}
    Shadow Copy Volume Name: \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy2
NOTE: You must do this for each critical volume required for SYSTEM STATE or DISASTER_RECOVERY:\ save sets.


5. If you successfully created a snapshot, delete it using the command from step 3 and run a backup of this client. If the backup fails with a VSS issue, contact Dell NetWorker support for assistance. It is also recommended to engage Microsoft support in the event collaboration is needed between NetWorker support and Microsoft support. 

Additional Information

VSS Space Requirements: https://technet.microsoft.com/en-us/library/cc161409.aspx This hyperlink is taking you to a website outside of Dell Technologies.
VSS Information: https://msdn.microsoft.com/en-us/library/windows/desktop/aa384625(v=vs.85).aspx This hyperlink is taking you to a website outside of Dell Technologies.

Workaround:

The following workaround can be used to obtain successful backups without VSS.

WARNING: This is not intended to be used as a solution. This is intended as an interim workaround to use until the VSS issues are addressed. Without VSS, you cannot perform DISASTER_RECOVERY:\ or SYSTEM_STATE backups. Only the file system data is protected. This workaround is not possible when performing Block-Based Backups (BBB).
  1. Log in to the NetWorker Management Console (NMC).
  2. Ensure View->Diagnostic Mode is enabled in the NMC.
  3. Access the Windows client's properties from the Protection->Clients tab.
  4. In the General tab of the client properties, change the Save sets field to only include volume, folder, or file names (For example: C:\).
NOTE: Save set All cannot be used. DISASTER_RECOVERY:\ cannot be specified.
  1. In the Apps & Modules tab, set vss:*=off under Save operations.
  2. Perform a backup of the client.
  3. Once the VSS issues are resolved, remove the vss:*=off setting and set the client's save set field to All, or include the DISASTER_RECOVERY:\ save set to obtain system state.

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000031318
Article Type: Solution
Last Modified: 20 Jun 2025
Version:  4
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