Dell Unity: The system could not start an automatic copy of data from one or more drives (Dell Correctable)

Summary: How to handle the Spare Drive alert message: The system could not start an automatic copy of data from one or more drives in pool Pool(x), because spare drives are not available.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Below shows the alert as seen in the Unity Unisphere UI:

Unity Alert screen picture

The Data Collection logs show that the event repeated daily.
Example:
A 12/20/20 08:45:09.127 Health 60342 [CRIT] User: The system could not start an automatic copy of data from one or more drives in pool Poolx, because spare drives are not available.
A 12/21/20 08:45:39.187 Health 60342 [CRIT] User: The system could not start an automatic copy of data from one or more drives in pool Poolx, because spare drives are not available.

Cause

- The alert message indicates that there were no spare disks available in the array for the disk type that failed. However, for a dynamic pool, the data is copied to the spare extent space in the pool.
In this case, the message is an informational event, not a problem event.

- Dynamic pools use the standard distributed sparing algorithm and create spare space extents across the disks in the pool.
There are enough spare extents reserved for each different disk type in a dynamic pool. There is one disk's worth of spare space for every 31 disks of the same type in the pool.

- Dynamic pools still check to see if if a physical spare disk is available outside of the pool. If no spare disk is available, then the data is copied to the free extents in the pool.

- The alert message is logged every 24 hours until a faulted drive has been replaced and the data copied back to the drive.

- If the alert message continues after disk replacement and all the disk data is copied back, there is likely another issue that needs addressed.

Resolution

Check that any failed disk is replaced and online.
Check that there are no other disks degraded or End of Life (EOL) status.

Should the error message continue after all data is copied then there is likely another issue that needs attention.

In this case, contact the Dell Technical Support Center or your service representative for assistance and reference this Dell Knowledge Base Article ID.

Additional Information

Other Dell KB article to reference:
KB 000081898: Dell Unity: After replacing a drive Alert: The system could not start an automatic copy of data.

Example of the daily alerts seen:
A 12/20/20 08:45:09.127 Health 60342 [CRIT] User: The system could not start an automatic copy of data from one or more drives in pool Poolx, because spare drives are not available.
A 12/21/20 08:45:39.187 Health 60342 [CRIT] User: The system could not start an automatic copy of data from one or more drives in pool Poolx, because spare drives are not available.
A 12/22/20 08:46:38.831 Health 60342 [CRIT] User: The system could not start an automatic copy of data from one or more drives in pool Poolx, because spare drives are not available.
A 12/23/20 08:47:23.745 Health 60342 [CRIT] User: The system could not start an automatic copy of data from one or more drives in pool Poolx, because spare drives are not available.
A 12/24/20 08:47:31.757 Health 60342 [CRIT] User: The system could not start an automatic copy of data from one or more drives in pool Poolx, because spare drives are not available.

Products

Dell EMC Unity, Dell EMC Unity Family |Dell EMC Unity All Flash
Article Properties
Article Number: 000183486
Article Type: Solution
Last Modified: 05 Jul 2024
Version:  5
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