Avamar: La sessione DTLT scade con un errore di timeout

Summary: Una sessione DTLT (Desktop Laptop) scade con un errore di timeout dovuto a un problema di configurazione.

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Symptoms

Una sessione DTLT (Desktop Laptop) viene segnalata come scaduta da qualsiasi client, utilizzando qualsiasi browser:

Your Avamar client's session has expired.
To start a new session, close your web browser and launch a request from the system tray or menu bar icon.
 
Errore di scadenza del client DTLT
 

Il registro di traccia DTLT (/usr/local/avamar-tomcat/logs/DTLT_Trace.log Segnala il seguente errore:

2017-03-01 17:04:47,493 ERROR [ajp-bio-8109-exec-3]-actions.DTLTTopLevelAction: U n e x p e c t e d   l o g i n   e x c e p t i o n
javax.security.auth.login.LoginException: adc-XXXX.domain.com: Name or service not known
    at com.sun.security.auth.module.Krb5LoginModule.attemptAuthentication(Unknown Source)
..
2017-03-01 17:20:15,959 ERROR [ajp-bio-8109-exec-6]-auth.JaasLoginModuleUserAuth: Invalid Login
javax.security.auth.login.LoginException: adc-XXXX.domain.com: Name or service not known
    at com.sun.security.auth.module.Krb5LoginModule.attemptAuthentication(Unknown Source)
    at com.sun.security.auth.module.Krb5LoginModule.login(Unknown Source)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
 

Il test dell'accesso LDAP (Lightweight Directory Access Protocol) per un account amministratore LDAP nell'interfaccia utente di Avamar segnala i seguenti tipi di errori:

Errore LDAP - Timeout ricezione

 

Errore LDAP - Disallineamento clock

 
Per testare l'accesso LDAP di un account amministratore LDAP dall'interfaccia utente di Avamar:
un. Amministrazione
b. Gestione LDAP
c. Gestione dei servizi directory
d. Prova
e. Immettere le credenziali LDAP.

Cause

La causa è probabilmente una delle seguenti:
  • Un problema con le configurazioni LDAP (Lightweight Directory Access Protocol) o Kerberos versione 5 (Krb5) sulla griglia Avamar
  • Il file /usr/local/avamar/etc/ldap.properties è configurato in modo errato
  • L'account LDAP non è stato autenticato correttamente con la griglia Avamar

Resolution

1. Verificare che l'opzione /usr/local/avamar/etc/ldap.properties Il file è configurato correttamente.

Campione:

ldap.url.domain.com=ldap\://abc-XXXX.domain.com\:389
ldap.qualified-name-default=domain.com
ldap.search.results.per.page=1000
mcgui.trace=true

ldap.identifier.adani.default=domain
 

I riferimenti per il file di configurazione LDAP sono disponibili nelle guide all'amministrazione e nelle guide alla sicurezza del prodotto per la versione specifica dell'ambiente.

Anche i seguenti articoli possono essere d'aiuto: 
 

2. Assicurarsi che sia possibile eseguire il ping del server LDAP dalla griglia Avamar e viceversa.

3. Assicurarsi che la rete telnet sia al server LDAP che alla griglia Avamar sulla porta 389 funzioni.

4. Testare l'accesso LDAP di un account amministratore LDAP dall'interfaccia utente di Avamar:
un. Amministrazione
b. Gestione LDAP
c. Gestione dei servizi directory
d. Prova
e. Immettere le credenziali LDAP.
 

Per "Autenticazione non riuscita" o qualsiasi altro errore relativo all'autenticazione, reimpostare la password amministratore LDAP in Active Directory ed eseguire nuovamente il test.

Per l'errore "Clock Skew too great", consultare Avamar: Come configurare NTP su una griglia a più nodi Avamar utilizzando l'utilità asktime.

Se i problemi persistono, creare uno Swarm con il team SER di Avamar per assistenza.

Additional Information

Gli errori di configurazione LDAP sono elencati nella Guida all'amministrazione di Avamar (un esempio della versione 7.3 riportato di seguito):

kA2f1000000RNQGCA4_4_0
 

Affected Products

Avamar

Products

Avamar
Article Properties
Article Number: 000024848
Article Type: Solution
Last Modified: 18 Sept 2025
Version:  6
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