NetWorker File System Backup Fails to Back up Oracle RMAN Backup Files but Backups All Other Files

Summary: There is no warning for the user when an unsupported VSS writer (such as the Oracle VSS writer) is detected. Oracle files are skipped during a NetWorker File system backup without warning. ...

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Symptoms

Using a Windows server that has an Oracle database that is installed on it where the default Oracle VSS Writer services are installed and enabled.

Using Oracle RMAN to create some local backup to disk, saving the backup generated files to a local directory. Whenever the file system backup is performed, it completes successfully. However, when logs are checked, it is clear that NetWorker has not backed up the oracle files.

Cause

When a standard NetWorker file system backup is performed on this machine, all Oracle backup files are detected by the Oracle VSS Writer and gets added to a list that is then provided to NetWorker for backup. The NetWorker Client software does not support Oracle VSS Writer, a temporary directive to skip all files on the supplied list is generated automatically. As a result, all Oracle backup files are skipped without any warning to the NetWorker user. The backup is successful, but no Oracle backup files have been backed up.

Resolution

The current workaround for this issue is to perform the save operation with the "VSS:*=off" option or have Oracle VSS writer disabled or uninstalled. This can be set in the client properties through the NetWorker Management Console (NMC):
 
Screenshot NetWorker Management Console Client Properties
Figure 1: Screenshot NetWorker Management Console Client Properties 

An official Request for Enhancement (reference RFE # NW-I-1965) isn raised with the Dell NetWorker Product Management team to request a warning system be implemented in future NetWorker versions, so that the skipped files are more easily detected by the user. Your Dell Site Account Manager or sales representative can track and link all RFEs.
Article Properties
Article Number: 000200983
Article Type: Solution
Last Modified: 02 June 2023
Version:  3
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