IDPA: Fout extra tekens in configuratieregel genegeerd: tijdens configuratie van externe logboekregistratie (syslog forwarding) op ACM

Summary: Fout "extra tekens in configuratieregel genegeerd: '*' [v8.2106.0] " tijdens configuratie van externe logboekregistratie (syslog forwarding) op ACM. Het probleem heeft betrekking op de configuratie van externe logboekregistratie (syslog forwarding) op ACM. Een foutmelding 'extra tekens in de configuratieregel genegeerd: '*' [v8.2106.0]' wordt aangetroffen bij het opnieuw starten van de rsyslog-service, waardoor logboeken niet kunnen worden doorgestuurd naar de externe server. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Wanneer u probeert de rsyslog-service opnieuw op te starten met behulp van de onderstaande opdracht, mislukt de bewerking.
systemctl restart

Bij het controleren van de status van rsyslog met de onderstaande opdracht wordt een foutmelding weergegeven:
systemctl status rsyslog
 
error: extra characters in config line ignored: ‘’ [v8.2106.0]"

Deze fout voorkomt dat logboeken worden doorgestuurd naar de externe server. Het probleem is terug te voeren op een vreemde '*' in het /etc/rsyslog.conf bestand dat verwijderd moet worden.
# systemctl status rsyslog
● rsyslog.service - System Logging Service
   Loaded: loaded (/usr/lib/systemd/system/rsyslog.service; enabled; vendor preset: disabled)
   Active: active (running) since Tue 2024-04-02 14:32:04 UTC; 6s ago
     Docs: man:rsyslogd(8)
http://www.rsyslog.com/doc/
  Process: 27195 ExecReload=/bin/kill -HUP $MAINPID (code=exited, status=0/SUCCESS)
  Process: 40849 ExecStartPre=/usr/sbin/rsyslog-service-prepare (code=exited, status=0/SUCCESS)
Main PID: 40853 (rsyslogd)
    Tasks: 10 (limit: 512)
   CGroup: /system.slice/rsyslog.service
           └─40853 /usr/sbin/rsyslogd -n -iNONE
Apr 02 14:32:04 acm-8300-crk systemd[1]: Starting System Logging Service...
Apr 02 14:32:04 acm-8300-crk systemd[1]: Started System Logging Service.
Apr 02 14:32:04 acm-8300-crk rsyslogd[40853]: error: extra characters in config line ignored: '*' [v8.2106.0]
Apr 02 14:32:04 acm-8300-crk rsyslogd[40853]: warning: ~ action is deprecated, consider using the 'stop' statement instead [v8.2106.0 try  https://www.rsyslog.com/e/2307 ]
Apr 02 14:32:04 acm-8300-crk rsyslogd[40853]: imuxsock: Acquired UNIX socket '/run/systemd/journal/syslog' (fd 3) from systemd.  [v8.2106.0]
Apr 02 14:32:04 acm-8300-crk rsyslogd[40853]: origin software="rsyslogd" swVersion="8.2106.0" x-pid="40853" x-info="[https://www.rsyslog.com start
 

Cause

De fout wordt veroorzaakt door een extra sterretje ('*') in het bestand /etc/rsyslog.conf. Dit moet worden verwijderd voor de juiste configuratie en werking van syslog forwarding.

Resolution

1. Controleer of het rsyslog-pakket is geïnstalleerd:
acm:~ # rpm -qa |grep rsyslog
rsyslog-8.24.0-3.39.1.x86_64
2. Controleer of de rsyslog-service is ingeschakeld:
acm:~ # systemctl is-enabled rsyslog
enabled
3.Open /etc/rsyslog.conf in een tekstverwerker.
             Verwijder de '*' van de onderstaande regel en voeg de Syslog-vermelding toe.
$template RemoteLogs,"/data01/logs/ESX/%HOSTNAME%/%PROGRAMNAME%.log"* =>Extra
$template RemoteLogs,"/data01/logs/ESX/%HOSTNAME%/%PROGRAMNAME%.log" 
*.*  ?RemoteLogs  
&~
           Na wijzigingen
$template RemoteLogs,"/data01/logs/ESX/%HOSTNAME%/%PROGRAMNAME%.log"
$template RemoteLogs,"/data01/logs/ESX/%HOSTNAME%/%PROGRAMNAME%.log" 
 *.* @xxx.xxx.xxx.xxx:514 
 &~ 
             waarbij xxx.xxx.xxx.xxx het IP-adres van de externe loghost is. 
4. Sla het bestand op en sluit het. 
:wq!
5. Start het rsyslog-proces opnieuw met de volgende opdracht:
# systemctl restart rsyslog

Affected Products

Integrated Data Protection Appliance Family

Products

Integrated Data Protection Appliance Software
Article Properties
Article Number: 000225742
Article Type: Solution
Last Modified: 20 June 2024
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.