NetWorker: license server returns error due to hostname change
Summary: NetWorker license server returns error due to hostname change.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
License server hostname has changed
NetWorker Management Console (NMC)
On the NetWorker server, launch the NMC Administration window, right-click the server, and then select Properties from the list. In the Licensing tab of the Server Properties window, browse to and select the license file to populate the CLP license text field.
While validating license file from NMC the following error appears:
Checking CLP connection using '/nsr/lic/licspec.properties'.
Checking license properties file '/nsr/lic/licspec.properties'
Found 'license.path=/nsr/lic/_NETWV_3651067_06-Oct-2018.lic'
Checking license file '/nsr/lic/_NETWV_3651067_06-Oct-2018.lic'
157364:nsrlic: Unable to check out 'NETWORKER_UPDATE': status = -16 'Cannot read data from license server system. (-16,287)'
157364:nsrlic: Unable to check out 'NETWORKER_CAPACITY': status = -16 'Cannot read data from license server system. (-16,287)'
157363:nsrlic: License file '/nsr/lic/_NETWV_3651067_06-Oct-2018.lic' issues found: 0
FAILED
The
lmgrd service is running, but the error still appears "Cannot read data from license server system"
Cause
NetWorker Server was connected to the old license server.
The hostname of the license server has changed.
Port 27000 and 27001 was not opened.
The hostname of the license server has changed.
Port 27000 and 27001 was not opened.
Resolution
- Killed the
lmgrdservice - Start
lmgrdservice and read the license file
[root@emc]# lmutil lmreread -c /opt/emc/licenses
lmutil - Copyright (c) 1989-2014 Flexera Software LLC. All Rights Reserved.
lmreread successful
- Check connectivity between the License server and NetWorker server.
nslookupand ping is working fine but when we check for port its failing on license server
[root@emclicenseserver]# curl -kv hostname:27001
* About to connect() to hostname port 27001 (#0)
* Trying 10.33.16.154... Connection refused
* couldn't connect to host
- Open ports 27000 and 27001 at OS level and open it
- Update the license server name as specified in license file in
nsradminas it has old license server name and user has changed the hostname
nsradmin> p type: nsr
type: NSR;
name:hostname;
version: \
NetWorker 9.1.1.5.Build.288 CLP Capacity License;
comment: ;
CLP License server: oldlichostname;
CLP License server port: 27000;
refresh license conformance report: No;
nsradmin> update CLP License server: newlichostname
CLP License server: newlichostname;
Update? y
updated resource id 3.0.118.14.163.194.113.75.0.0.0.0.10.33.16.151(8147)
nsradmin> p type: nsr
type: NSR;
name: hostname;
version: \
NetWorker 9.1.1.5.Build.288 CLP Capacity License;
comment: ;
CLP License server: newlichostname;
CLP License server port: 27000;
refresh license conformance report: No;
- Reboot the NetWorker server
- From NMC Administration window -> click on server name -> server Properties -> Licensing tab -> Click on CLP license text to browse the license file -> Click ok. Browse the file and check if it is validated successfully.
Affected Products
NetWorker, NetWorker Management ConsoleArticle Properties
Article Number: 000044563
Article Type: Solution
Last Modified: 10 Mar 2026
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.