PowerProtect: Windows FLR Browse kann auf einige Dateien nicht zugreifen mit Fehler 400 Zugriff verweigert
Summary: Wenn Sie eine FLR unter Windows durchführen, werden die Backups ohne Probleme gemountet, aber beim Durchsuchen der Verzeichnisse können einige oder alle Verzeichnisse aufgrund von 400 nicht geöffnet und durchsucht werden: Fehler "Zugriff verweigert". Der Nutzer, der zum Mounten des Backups verwendet wird, kann auf diese Dateien zugreifen und verfügt über Berechtigungen auf der ursprünglichen VM für diese Ordner. Sie können über den Einhängepunkt mit demselben Nutzer auf diese Dateien zugreifen. ...
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Symptoms
Beim Durchsuchen von Windows-Dateien im FLR-Assistenten tritt ein Fehler auf, wenn versucht wird, auf bestimmte Ordner zuzugreifen, um sie zu durchsuchen:
Beim Zugriff auf den folgenden Einhängepunkt auf der Ziel-VM mit dem Mount-Nutzer (entweder AD-Nutzer oder lokaler Administrator).
Error: 400: failed to update FLR session. Could not get directory contents. Unable to retrieve file list from 'VM Name' (VM IS) path 'FolderPath' offset 0. Unable to perform FLR operation "browse_files" on VM 'FSSRV' (vm-1031). Cannot stat 'C:\Program Files (x86)\EMC\vProxy FLR Agent\flr\mountpoints\FLRxxxxxxx\File_Path'. Create file C:\Program Files (x86)\EMC\vProxy FLR Agent\flr\mountpoints\FLR25469754941\xxxxxxx\File_Path: Access is denied
Beim Zugriff auf den folgenden Einhängepunkt auf der Ziel-VM mit dem Mount-Nutzer (entweder AD-Nutzer oder lokaler Administrator).
'C:\Program Files (x86)\EMC\vProxy FLR Agent\flr\mountpoints\FLRxxxxxxx\File_Path'Dann ist es möglich, diese Ordner ohne Probleme anzuzeigen und zu durchsuchen.
Cause
Der ursprüngliche Pfad oder die Verzeichnisse verfügen nicht über Berechtigungen für den SYSTEM-Nutzer zum Zugriff auf diese Pfade, was dieses Problem verursacht hat, da es der SYSTEM-Nutzer der Ziel-VM ist, der zum Durchsuchen der Verzeichnisse verwendet wird, nicht der Nutzer, der zum Mounten der FLR auf der Ziel-VM verwendet wird.
Microsoft empfiehlt außerdem, den SYSTEM-Nutzer nicht aus Ordnern oder Verzeichnissen zu entfernen:
Die Berechtigungen des SYSTEM-Kontos können aus einer Datei entfernt werden, es wird jedoch nicht empfohlen, sie zu entfernen.
https://learn.microsoft.com/en-us/windows/security/identity-protection/access-control/local-accounts
Microsoft empfiehlt außerdem, den SYSTEM-Nutzer nicht aus Ordnern oder Verzeichnissen zu entfernen:
Die Berechtigungen des SYSTEM-Kontos können aus einer Datei entfernt werden, es wird jedoch nicht empfohlen, sie zu entfernen.
https://learn.microsoft.com/en-us/windows/security/identity-protection/access-control/local-accounts
Resolution
Fügen Sie den Nutzer SYSTEM zu den Windows-Betriebssystemverzeichnissen und -pfaden auf dem ursprünglichen Host hinzu und erstellen Sie ein neues Backup, nachdem Sie diese Berechtigung hinzugefügt haben. Die FLR aller zukünftigen Backups, die nach dieser Änderung auf dem Windows-VM-Host erstellt wurden, wird für den Suchvorgang erfolgreich sein.
Für alle älteren Backups, die erstellt werden, wenn der SYSTEM-Nutzer nicht auf diese Ordner und Verzeichnisse zugreifen kann, muss die folgende Problemumgehung befolgt werden:
PowerProtect Data Manager: So führen Sie eine Recovery auf Dateiebene (FLR) durch, wenn FLR fehlschlägt oder von der VM nicht unterstützt wird.
NVP-vProxy: So führen Sie eine Recovery auf Dateiebene durch, wenn FLR fehlschlägt oder von der VM nicht unterstützt wird.
ODER
Melden Sie sich nach dem Mounten des Backups mithilfe der FLR-Benutzeroberfläche mit dem Mount-Nutzer bei der Ziel-VM an.
Greifen Sie direkt auf den Mount-Punkt zu und übertragen Sie die Dateien in das gewünschte Verzeichnis.
Nachdem die Dateien verschoben wurden, brechen Sie den FLR-Prozess ab.
Ändern Sie die Seite auf dem PowerProtect Data Manager während der Übertragung dieser Informationen nicht, da dies dazu führt, dass die FLR unmountet wird.
Im PowerProtect Data Manager – Benutzerhandbuch für virtuelle Maschinen:
Um alle Festplattenlaufwerke einer Sicherungskopie zu durchsuchen, sollte die Kopie von einer virtuellen Maschine stammen, die über die folgenden Windows-Berechtigungseinstellungen verfügt.
Geben Sie in den Erweiterten Sicherheitseinstellungen für die lokale Festplatte
auf jeder Festplattenlaufwerksebene sowohl für den SYSTEM - als <auch für den COMPUTERNAMEN>\Administratorprinzipal:○
Folgendes ein: Zulassen
○ Zugriff: Vollzugriff
○ Gilt für: Dieser Ordner, Unterordner und Dateien
Wenn in einer der Quelldateien oder -ordner SYSTEM und <COMPUTERNAME>\Administratoren im Pfad der Sicherungskopie, von der wiederhergestellt wird, fehlt, schlägt das Durchsuchen der Wiederherstellung auf Dateiebene möglicherweise fehl.
Es wird ein Fehler angezeigt, der darauf hinweist, dass der Zugriff verweigert wurde, und der Wiederherstellungsvorgang schlägt fehl.
Für alle älteren Backups, die erstellt werden, wenn der SYSTEM-Nutzer nicht auf diese Ordner und Verzeichnisse zugreifen kann, muss die folgende Problemumgehung befolgt werden:
PowerProtect Data Manager: So führen Sie eine Recovery auf Dateiebene (FLR) durch, wenn FLR fehlschlägt oder von der VM nicht unterstützt wird.
NVP-vProxy: So führen Sie eine Recovery auf Dateiebene durch, wenn FLR fehlschlägt oder von der VM nicht unterstützt wird.
ODER
Melden Sie sich nach dem Mounten des Backups mithilfe der FLR-Benutzeroberfläche mit dem Mount-Nutzer bei der Ziel-VM an.
Greifen Sie direkt auf den Mount-Punkt zu und übertragen Sie die Dateien in das gewünschte Verzeichnis.
Nachdem die Dateien verschoben wurden, brechen Sie den FLR-Prozess ab.
Ändern Sie die Seite auf dem PowerProtect Data Manager während der Übertragung dieser Informationen nicht, da dies dazu führt, dass die FLR unmountet wird.
Im PowerProtect Data Manager – Benutzerhandbuch für virtuelle Maschinen:
Um alle Festplattenlaufwerke einer Sicherungskopie zu durchsuchen, sollte die Kopie von einer virtuellen Maschine stammen, die über die folgenden Windows-Berechtigungseinstellungen verfügt.
Geben Sie in den Erweiterten Sicherheitseinstellungen für die lokale Festplatte
auf jeder Festplattenlaufwerksebene sowohl für den SYSTEM - als <auch für den COMPUTERNAMEN>\Administratorprinzipal:○
Folgendes ein: Zulassen
○ Zugriff: Vollzugriff
○ Gilt für: Dieser Ordner, Unterordner und Dateien
Wenn in einer der Quelldateien oder -ordner SYSTEM und <COMPUTERNAME>\Administratoren im Pfad der Sicherungskopie, von der wiederhergestellt wird, fehlt, schlägt das Durchsuchen der Wiederherstellung auf Dateiebene möglicherweise fehl.
Es wird ein Fehler angezeigt, der darauf hinweist, dass der Zugriff verweigert wurde, und der Wiederherstellungsvorgang schlägt fehl.
Article Properties
Article Number: 000224705
Article Type: Solution
Last Modified: 11 Jul 2024
Version: 1
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