PowerProtect: La navegación FLR de Windows no puede acceder a algunos archivos con el error 400 de acceso denegado
Summary: Cuando se realiza una FLR en Windows, los respaldos se montan sin problemas, pero cuando se navega por los directorios, algunos o todos los directorios no se pueden abrir ni navegar debido al error 400: Error de acceso denegado. El usuario que se utilizó para montar el respaldo puede acceder a estos archivos y tiene permisos en la VM original para estas carpetas. Pueden acceder a estos archivos desde el punto de montaje con el mismo usuario. ...
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Symptoms
Cuando se examinan archivos de Windows en el asistente de FLR, se produce un error cuando se intenta acceder a ciertas carpetas para navegar en ellas:
Cuando se accede al siguiente punto de montaje en la VM de destino con el usuario de montaje (ya sea usuario de AD o administrador local).
Error: 400: failed to update FLR session. Could not get directory contents. Unable to retrieve file list from 'VM Name' (VM IS) path 'FolderPath' offset 0. Unable to perform FLR operation "browse_files" on VM 'FSSRV' (vm-1031). Cannot stat 'C:\Program Files (x86)\EMC\vProxy FLR Agent\flr\mountpoints\FLRxxxxxxx\File_Path'. Create file C:\Program Files (x86)\EMC\vProxy FLR Agent\flr\mountpoints\FLR25469754941\xxxxxxx\File_Path: Access is denied
Cuando se accede al siguiente punto de montaje en la VM de destino con el usuario de montaje (ya sea usuario de AD o administrador local).
'C:\Program Files (x86)\EMC\vProxy FLR Agent\flr\mountpoints\FLRxxxxxxx\File_Path'A continuación, será posible ver y revisar estas carpetas sin ningún problema.
Cause
La ruta o los directorios originales no tienen permisos para que el usuario SYSTEM acceda a estas rutas, lo que causó este problema, ya que es el usuario SYSTEM de la VM de destino el que se utiliza para navegar por los directorios, no el usuario utilizado para montar la FLR en la VM de destino.
Microsoft también recomienda que el usuario del SISTEMA no se elimine de carpetas o directorios:
Los permisos de la cuenta del SISTEMA se pueden eliminar de un archivo, pero no se recomienda eliminarlos.
https://learn.microsoft.com/en-us/windows/security/identity-protection/access-control/local-accounts
Microsoft también recomienda que el usuario del SISTEMA no se elimine de carpetas o directorios:
Los permisos de la cuenta del SISTEMA se pueden eliminar de un archivo, pero no se recomienda eliminarlos.
https://learn.microsoft.com/en-us/windows/security/identity-protection/access-control/local-accounts
Resolution
Agregue el usuario SYSTEM a las rutas y directorios del SO Windows en el host original, realice un respaldo nuevo después de agregar este permiso y la FLR de todos los respaldos futuros realizados después de que se realizó este cambio en el host de la VM de Windows se realizará correctamente para la operación de navegación.
Para todos los respaldos más antiguos realizados cuando el usuario SYSTEM no puede acceder a estas carpetas y directorios, se debe seguir la siguiente solución alternativa:
PowerProtect Data Manager: Cómo realizar una recuperación a nivel de archivos (FLR) cuando la FLR falla o no es compatible con la VM.
Proxy de NVP vProxy: Cómo realizar una recuperación a nivel de archivos cuando la FLR falla o la VM no la soporta.
O
Inicie sesión en la VM de destino después de montar el respaldo mediante la interfaz del usuario de FLR con el usuario de montaje.
Acceda directamente al punto de montaje y transfiera los archivos al directorio requerido.
Después de transferir los archivos, cancele el proceso de FLR.
No cambie la página en PowerProtect Data Manager mientras transfiere esta información, ya que esto provoca que la FLR se desmonte.
De la Guía del usuario de la máquina virtual de PowerProtect Data Manager
: Para navegar por todas las unidades de disco de una copia de respaldo, la copia debe ser de una máquina virtual que tenga los siguientes ajustes de permisos de Windows.
En la Configuración de seguridad avanzada del disco
local en cada nivel de unidad de disco, para la entidad principal
SYSTEM y <COMPUTER-NAME>\Administrators:○ Escriba: Permitir
○ Acceso: Control
total○ Se aplica a: Esta carpeta, subcarpetas y archivos
Si en alguno de los archivos o carpetas de origen faltan los archivos SYSTEM y <COMPUTER-NAME>\Administrators en la ruta de la copia de respaldo desde la cual se realiza la restauración, la navegación de la restauración a nivel de archivos podría fallar.
Habrá un error que indica que se denegó el acceso y la operación de restauración fallará.
Para todos los respaldos más antiguos realizados cuando el usuario SYSTEM no puede acceder a estas carpetas y directorios, se debe seguir la siguiente solución alternativa:
PowerProtect Data Manager: Cómo realizar una recuperación a nivel de archivos (FLR) cuando la FLR falla o no es compatible con la VM.
Proxy de NVP vProxy: Cómo realizar una recuperación a nivel de archivos cuando la FLR falla o la VM no la soporta.
O
Inicie sesión en la VM de destino después de montar el respaldo mediante la interfaz del usuario de FLR con el usuario de montaje.
Acceda directamente al punto de montaje y transfiera los archivos al directorio requerido.
Después de transferir los archivos, cancele el proceso de FLR.
No cambie la página en PowerProtect Data Manager mientras transfiere esta información, ya que esto provoca que la FLR se desmonte.
De la Guía del usuario de la máquina virtual de PowerProtect Data Manager
: Para navegar por todas las unidades de disco de una copia de respaldo, la copia debe ser de una máquina virtual que tenga los siguientes ajustes de permisos de Windows.
En la Configuración de seguridad avanzada del disco
local en cada nivel de unidad de disco, para la entidad principal
SYSTEM y <COMPUTER-NAME>\Administrators:○ Escriba: Permitir
○ Acceso: Control
total○ Se aplica a: Esta carpeta, subcarpetas y archivos
Si en alguno de los archivos o carpetas de origen faltan los archivos SYSTEM y <COMPUTER-NAME>\Administrators en la ruta de la copia de respaldo desde la cual se realiza la restauración, la navegación de la restauración a nivel de archivos podría fallar.
Habrá un error que indica que se denegó el acceso y la operación de restauración fallará.
Article Properties
Article Number: 000224705
Article Type: Solution
Last Modified: 11 Jul 2024
Version: 1
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