PowerProtect: Windows FLR Browse ei pysty käyttämään joitakin tiedostoja, joissa on 400 Access denied -virhe

Summary: Kun teet FLR: n Windowsissa, varmuuskopiot asennetaan ilman ongelmia, mutta hakemistoja selattaessa joitain tai kaikkia hakemistoja ei avata ja selata 400: n vuoksi: Käyttö estetty -virhe. Varmuuskopioinnin ottanut käyttäjä voi käyttää näitä tiedostoja, ja hänellä on alkuperäisen virtuaalikoneen käyttöoikeudet kyseisiin kansioihin. He voivat käyttää näitä tiedostoja liityntäkohdasta saman käyttäjän kanssa. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Kun selaat Windows-tiedostoja ohjatulla FLR-toiminnolla, tapahtuu virhe, kun yrität käyttää tiettyjä kansioita selataksesi niitä:
Error: 400: failed to update FLR session. Could not get directory contents. Unable to retrieve file list from 'VM Name' (VM IS) path 'FolderPath' offset 0. Unable to perform FLR operation "browse_files" on VM 'FSSRV' (vm-1031). Cannot stat 'C:\Program Files (x86)\EMC\vProxy FLR Agent\flr\mountpoints\FLRxxxxxxx\File_Path'. Create file C:\Program Files (x86)\EMC\vProxy FLR Agent\flr\mountpoints\FLR25469754941\xxxxxxx\File_Path: Access is denied

Kun käytät alla olevaa liityntäkohtaa kohdevirtuaalikoneessa käyttöönotettavan käyttäjän (joko AD-käyttäjän tai paikallisen järjestelmänvalvojan) kanssa.
 'C:\Program Files (x86)\EMC\vProxy FLR Agent\flr\mountpoints\FLRxxxxxxx\File_Path'
Sitten on mahdollista tarkastella ja käydä läpi näitä kansioita ilman ongelmia.

Cause

Alkuperäisellä polulla tai hakemistoilla ei ole SYSTEM-käyttäjän oikeuksia käyttää näitä polkuja, mikä aiheutti tämän ongelman, koska hakemistojen selaamiseen käytetään kohdevirtuaalikoneen SYSTEM-käyttäjää, ei käyttäjää, jota käytetään FLR:n liittämiseen kohdevirtuaalikoneeseen.
Microsoft suosittelee myös, että SYSTEM-käyttäjää ei poisteta kansioista tai hakemistoista:
SYSTEM-tilin käyttöoikeudet voidaan poistaa tiedostosta, mutta emme suosittele niiden poistamista.
https://learn.microsoft.com/en-us/windows/security/identity-protection/access-control/local-accounts Tämä hyperlinkki johtaa Dell Technologiesin ulkopuoliseen sivustoon.

Resolution

Lisää SYSTEM-käyttäjä Windows-käyttöjärjestelmän hakemistoihin ja polkuihin alkuperäisessä isännässä, ota uusi varmuuskopio tämän käyttöoikeuden lisäämisen jälkeen, niin kaikkien tämän muutoksen tekemisen jälkeen Windows-virtuaalikoneen isännässä tehtyjen tulevien varmuuskopioiden FLR onnistuu selaustoiminnossa.

Jos varmuuskopiointi tehdään vanhemmalla varmuuskopioinnilla, kun SYSTEM-käyttäjä ei voi käyttää näitä kansioita ja hakemistoja, on käytettävä seuraavaa kiertotapaa:
PowerProtect Data Manager: Kuinka suorittaa tiedostotason palautus (FLR), kun virtuaalikone epäonnistuu tai ei tue sitä.

NVP-vProxy: Kuinka suorittaa tiedostotason palautus, kun FLR epäonnistuu tai virtuaalikone ei tue sitä.

TAI

kirjaudu kohdevirtuaalikoneeseen varmuuskopioinnin asentamisen jälkeen FLR-käyttöliittymän avulla käyttöönoton käyttäjän kanssa.
Käytä asennuskohtaa suoraan ja siirrä tiedostot haluttuun hakemistoon.
Kun tiedostot on siirretty, peruuta FLR-prosessi. 
Älä muuta PowerProtect Data Managerin sivua, kun siirrät näitä tietoja, koska FLR:n asennus irrotetaan sen vuoksi.

PowerProtect Data Manager Virtual Machine -käyttöoppaasta:

Jos haluat selata varmuuskopion kaikkia levyasemia, kopion on oltava virtuaalikoneesta, jolla on seuraavat Windows-käyttöoikeusasetukset.
Valitse Paikallisen levyn
suojauksen lisäasetukset Jokaisella levyasematasolla sekä SYSTEM- että <COMPUTER-NAME>\Administrators Principal:○ Type:
Salli
○ Käyttö: Täydet hallintaoikeudet
○ Koskee seuraavia: Tämä kansio, alikansiot ja tiedostot
Jos jokin lähdetiedosto tai -kansio puuttuu palautettavan varmuuskopion polusta SYSTEM ja <COMPUTER-NAME>\Administrators , tiedostotason palautuksen selaus saattaa epäonnistua.
Näyttöön tulee virheilmoitus, joka ilmaisee, että käyttö on estetty ja palautustoiminto epäonnistuu.
Article Properties
Article Number: 000224705
Article Type: Solution
Last Modified: 11 Jul 2024
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.