Avamar: Hyper-V Federated cluster client registration failing

Summary: Knowledgebase (KB) article that provides workarounds for Avamar cluster registration failures.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

When trying to register a federated cluster client (Exchange DAG or Microsoft Hyper-V) to the Avamar grid using the Avamar Cluster Wizard, it may fail:

av_cluster_config_wizard ERROR<0000>: Cannot create network resource of 'Av-EMC-DAG resource' in 'backup cluster client for EMC-DAG' for 'Backup Agent resource for EMC-DAG' because of the following error:
CreateClusterGroupNetworkResource returns failure. 
av_cluster_config_wizard DEBUG<0000>: UpdateStatusAndList: Cannot create network resource of 'Av-EMC-DAG resource' in 'backup cluster client for EMC-DAG' for 'Backup Agent resource for EMC-DAG' because of the following error:
CreateClusterGroupNetworkResource returns failure. 
av_cluster_config_wizard DEBUG<0000>: UpdateStatusAndList: Failed to create a cluster group for the agent 
av_cluster_config_wizard ERROR<0000>: Failed to create a cluster group for the agent
146 ClusterTool_workflow::install_agent] Error in CreateAvagentClusterService error=5054 
 191 ClusterTool_workflow::install_agent] Error in [CreateAvagentClusterService]
"Error in CreateAvagentClusterService error=5054 "

Alternatively, clear the option "Bring Avamar Exchange DAG client/Windows CSV client online and register with Avamar server." Then manually register it by bringing the cluster Backup Agent service online using the Failover Cluster Management tool. As a result, the following error such as Event ID 1194 from Cluster Event Viewer logs may occur:

":  Cluster Network Name resource 'Av-01-HVCLUSTER01 resource failed to create its associated computer object in domain 'EMCAvamar.com' for the following reason:  Unable to create computer account.

The text for the associated error code is:  Access is denied."

Cause

Active Directory (AD) computer objects (such as Windows servers) may not have permission to create child objects such as the Avamar cluster client.

 

Resolution

Log in to the AD domain controller (DC) and run the Delegate Permissions Wizard. Use the following procedures below:

  1. Log in to the domain controller.

  2. Open "Active Directory Users and Computers" Microsoft Management Console (MMC) snap-in.

  3. Right-click Domain Name and select Delegate Control. Click Next > ADD.

  4. Then click Next, choose "Object Types" and select Computers > OK.

  5. Add the Computer Names (all the cluster nodes plus the name of the Exchange DAG or Hyper-V CSV cluster service) in the TextField > Check Names > OK.

  6. Once the Computer Objects are added, then click Next.

  7. Choose Create a Custom Task To Delegate > Next.

  8. Choose > Only the Following Object in the folder.

  9. Enable "Computer Objects" from the list and check "Selected object in the folder," then click Next.

  10. Enable the option "Full Control" and then click Next. Finally click the Finish button to complete the Wizard.

Then rerun the Avamar Cluster Configuration Wizard to register the Exchange DAG or Hyper-V CSV client.

Alternatively, manually create the Avamar federated cluster client (such as Av-01-DAG or Av-01-HVCLUSTER01) computer object using the Active Directory Users and Computers tool. After the Avamar cluster client is created in the default OU for computer objects, then do the following:

  1. Enable advanced functionality in Active Directory Users and Computers by going to the View menu and select Advanced Features.

  2. Add the computer objects of the cluster nodes to the Security Tab of the Avamar cluster's computer object. Also add the computer objects for name of the Exchange DAG or Hyper-V cluster service. Once that is done, grant each computer object Full Control.

  3. Disable the computer object in AD.

Then rerun the Avamar Cluster Wizard to register the Exchange DAG or Hyper-V CSV client. Alternatively, the Avamar federated cluster client was registered but not brought online using the Cluster Configuration Wizard. For this scenario, bring the DELL Backup Agent cluster service online using the Failover Cluster Manager tool.

 

Affected Products

Avamar, Avamar Plug-in for Hyper-V VSS
Article Properties
Article Number: 000047547
Article Type: Solution
Last Modified: 30 Dec 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.