PowerStore: Unable to Create a New Virtual Machine Snapshot

Summary: Virtual Machine snapshot creation fails in vSphere.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Creating a Virtual Machine snapshot in vSphere fails with the below error:

"Operation failed!

Status: Unable to access file snapshot "

vCenter Snapshot failure message

An attempt to migrate the VM to another host did not resolve the issue. It caused a failure to power the VM back on and reported "insufficient resources" as the error.

A review of the following confirmed that there was not a resource issue:

  • Volume size on the PowerStore
  • Datastore size in vSphere
  • vSphere HA settings
  • Virtual Machine CPU and RAM 

Cause

Many issues can contribute to snapshot creation failures such as file locks, lack of space, and so forth. In this case, the underlying cause for the snapshot creation failure and the failure to power back on after a migration attempt, could not be determined.

Resolution

The issue was resolved by creating a new virtual machine with the same name and pointing it to the original VMDK files, then deleting the old virtual machine.

Additional Information

For additional information about VM snapshot failures and causes, see VMware's Knowledge Base site This hyperlink is taking you to a website outside of Dell Technologies..

Affected Products

PowerStore
Article Properties
Article Number: 000186074
Article Type: Solution
Last Modified: 20 Sept 2024
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.