PowerScale: SmartConnect Service IP Address may Reside on Multiple Nodes after 8.2 Upgrade

Summary: This article describes how to identify and resolve issues found when two or more of the same SmartConnect Service IPs (SSIP) are on two or more nodes.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Committing an upgrade from versions prior to OneFS 8.2 and going to OneFS 8.2.x may result in duplicate SSIPs across two or more nodes in the cluster. Symptoms that are seen during the issue are failure to ping the SSIP and failure to resolve the zone name associated with that SSIP. 

To identify if there are duplicate SSIP addresses on the cluster, run the following command:

# isi_for_array ifconfig | grep "zone 0"

From the returned SSIPs, look for any duplicates between the nodes.
For example:

cluster-1: inet 1.2.3.4 netmask 0xfffff800 broadcast 1.2.3.255 zone 0 cluster-3: inet 1.2.3.4 netmask 0xfffff800 broadcast 1.2.3.255 zone 0

Cause

This can occur when there is a simultaneous change from within our network daemon isi_flexnet_d and the upgrade commit.

Resolution

To resolve the issue, restart the isi_dnsiq_d and isi_smartconnect_d daemons on the affected nodes, and then reassess.

# isi_for_array -n <affected nodes> 'pkill isi_dnsiq_d isi_smartconnect_d'
 
Note: In the example above, the command looks like the following:
# isi_for_array -n1,3 'pkill isi_dnsiq_d isi_smartconnect_d'

Affected Products

Isilon

Products

PowerScale OneFS
Article Properties
Article Number: 000170716
Article Type: Solution
Last Modified: 21 May 2025
Version:  4
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