PowerScale: OneFS: Upozornění na chybějící potřebná hlavní názvy služeb (SPN) serveru AD pro NFS HTTP HDFS

Summary: Správci mohou někdy zaznamenat výstrahy, které indikují, že chybí hlavní názvy služeb NFS, HTTP nebo HDFS.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Za určitých podmínek se může vygenerovat výstraha na chybějící hlavní názvy služeb (SPN). Kontroly hlavního názvu služby (SPN) se obvykle provádějí poté, co v clusteru dojde k následujícím událostem:
  • Cluster nebo uzel byl restartován.
  • Procesy a/nebo služby CELOG se resetují
  • Pravidelné kontroly CELOG prostřednictvím monitoru CELOG
  • Přidání nového poskytovatele služby AD
  • Změna konfigurace sítě (pokud je fond nakonfigurován s názvy a aliasy zón SmartConnect)
Cluster PowerScale OneFS hlásí následující výstrahu:
AD server missing needed SPN(s) HOST/sczone.domain.com, HOST/sczone, nfs/sczone.domain.com, nfs/sczone, hdfs/sczone.domain.com, hdfs/sczone; try 'isi auth ads spn check'

Cause

Systém upozornění CELOG pravidelně provádí kontrolu u každého poskytovatele AD, aby ověřil, zda jsou hlavní názvy služeb (SPN) správně zaregistrovány, a může hlásit, že názvy SPN "chybí". K tomu dochází také při spuštění při spouštění uzlů.

Logika použitá při kontrole CELOG je následující:
  1. U každého poskytovatele služby AD zkontrolujte existující registrované názvy SPN proti nakonfigurovaným názvům zón a aliasům SmartConnect. Pokud byl fond s nakonfigurovaným názvem zóny SmartConnect změněn (například včetně nového aliasu), kontrola hlavního názvu služby (SPN) u poskytovatele služby AD by zkontrolovala aktualizované informace.
  2. Pokud byl v dřívějších verzích systému OneFS nakonfigurován export NFS s charakterem zabezpečení krb5, předpokládalo by se, že pro každou zónu/alias SC jsou potřeba názvy SPN NFS. U verze 8.0.0.5/8.0.1.2/8.1.0.1 a novějších se předpokládá, že systém NFS ve výchozím nastavení chybí (pokud již není zaregistrován). Byly odebrány kontroly zabezpečení exportu NFS.
  3. Pokud je HDFS licencovaný, OneFS předpokládá, že pro každou zónu nebo alias SC jsou potřeba hlavní názvy služby HDFS. To platí i v případě, že samotná služba není v clusteru povolená.
  4. Kontroly hlavního názvu služby HTTP se provádějí automaticky bez ohledu na konfiguraci clusteru, protože služba je ve výchozím nastavení povolená. Pro kontrolu hlavního názvu služby HTTP neexistují žádné zvláštní podmínky.
Výstraha je nejčastější, když se procesy načítají nebo znovu načítají, když se cluster restartuje a když se v clusteru vytvoří poskytovatel služby AD.
 
Poznámka: CELOG a isi auth ads spn check se vzájemně vylučují a při určování chybějících hlavních názvů služby (SPN) používají různé funkce nebo logiku. Například isi auth ads spn check příkaz nemá žádné kontroly pro názvy SPN založené na NFS, HTTP nebo HDFS. Předpokládá se, že chybí zóny SC bez odpovídajícího hlavního názvu služby (SPN ).

Resolution

Samotná výstraha má poradní charakter a vztahuje se na jednu nebo více domén AD. Hlavní názvy služeb (SPN) nemusí být nutně vyžadovány z pohledu systému OneFS, s výjimkou samotného názvu clusteru, který je zaregistrován ve výchozím nastavení. Výchozí názvy SPN, jako jsou tyto, by se nikdy neměly odebírat. Místo toho jsou vyžadovány, aby se klienti mohli připojit ke clusteru pomocí ověřování protokolem Kerberos prostřednictvím protokolu SMB, NFS nebo HDFS. Protokoly Kerberos s protokolem SMB jsou zahrnuty pod hlavní název služby (SPN) hostitele, stejně jako CIFS spadá pod obor hlavního názvu služby hostitele.

Pokyny ke správě hlavních názvů služby (SPN) z clusteru najdete v příručkách pro správu vaší verze systému OneFS na stránce Informační centra PowerScale OneFS .

V opačném případě může být výstraha ignorována, pokud jsou hlavní názvy služeb (SPN) považovány za zbytečné, nebo je možné je zaregistrovat, aby se výstrahě v budoucnu zabránilo.

Affected Products

PowerScale OneFS

Products

PowerScale OneFS
Article Properties
Article Number: 000167340
Article Type: Solution
Last Modified: 24 May 2024
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.