nsrck SYSTEM warning Cannot lock file index for client '<Client Name>' (For mange åpne filer)

Summary: NetWorker-servere som kjører versjon 19.4.0.2 og 19.5.0.0, kan støte på et problem der både automatiserte og manuelt kjørende NSRCK-kommandoer vil mislykkes med «for mange åpne filer»-feil. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

NetWorker-servere som kjører versjon 19.4.0.2 og 19.5.0.0, kan støte på et problem der både automatiserte og manuelt kjørende NSRCK-kommandoer mislykkes med «for mange åpne filer»-feil.
  • NSRCK som en del av policyen for serverbeskyttelse mislykkes uten at det oppstår en feil eller feil i brukergrensesnittet, feil logges i policyloggen og Daemon.raw-filer:
    • Policylogg
      • 96467 1624042989 2 1 24 15160 10448 0 Server.Domain.com nsrck SYSTEM-advarsel 43 Kan ikke låse filindeks for klienten %s (%s) 2 12 20 Client.Domain.com 24 19 For mange åpne filer
    • Daemon.raw
      • 71193 1622838475 0 0 0 5876 5980 0 Server.Domain.com nsrd NSR-informasjon 9 %s %s: %s 3 11 10 2935:Indeks 11 12 19362: Merknad 49 70 195146 32 Kontrollindeks for klienten '%s'.  1 0 20 Client.Domain.com
      • 96467 1622838492 2 1 24 6444 7952 0 Server.Domain.com nsrck SYSTEM-advarsel 43 Kan ikke låse filindeks for klienten %s (%s) 2 12 20 Client.Domain.com 24 19 For mange åpne filer
  • Hvis du kjører NSRCK via kommandolinjen, returneres følgende feil:
    • nsrck SYSTEM warning Cannot lock file index for client '' (For mange åpne filer)
  • NetWorker Client File Indexes (CFI) vil fortsette å vokse og bruke lagring, noe som kan føre til at systemet blir ustabilt hvis all lagring forbrukes på vertsstasjonen
  • Sikkerhetskopierings- og gjenopprettingsjobber kan av og til mislykkes hvis de kjører samtidig som NSRCK

Cause

Dette problemet skyldes en kodefeil som ble introdusert i den opprinnelige versjonen av 19.4.0.2 Cumulative Hotfix (CHF) &19.5.0.0.

Resolution

Produkt (operativsystem eller driftsmiljø)
 
NetWorker Server 19.4.0.3
NetWorker Server 19.5.0.1
Handlingstype
 
Bruk hurtigreparasjon
Handling er nødvendig
 
Bruk riktig hurtigreparasjon basert på den berørte versjonen som for øyeblikket er installert
Hvem kan fullføre handlingen
 
NetWorker-administrator
Problemet er løst i dette operativsystemet, dette driftsmiljøet eller denne programvaren
 
 
Løsningsdetaljer Løsning:
NetWorker-servere som kjører 19.4.0.2, må bruke 19.4.0.3 kumulativ hurtigreparasjon (CHF) for å løse dette problemet.

NetWorker-servere som kjører 19.5.0.0, må bruke den kumulative hurtigreparasjonen 19.5.0.1 for å løse dette problemet.

Midlertidig løsning:
Du kan omgå dette problemet ved å øke antallet tilgjengelige filbeskrivelser på operativsystemnivå.  For Linux-systemer:

 
  1. Slik sikrer du en vedvarende innstilling ved å redigere /etc/sysctl.conf-filen:

# vi /etc/sysctl.conf
 
  1. Legg til et konfigurasjonsdirektiv som følger:

fs.file-max =

der er et desimaltall som definerer det maksimale antallet åpne filer.  32768 er den anbefalte innstillingen for store NetWorker-implementeringer og er et godt utgangspunkt.

 
  1. Lagre og lukk filen. Du kan enten starte maskinen på nytt eller skrive inn følgende kommando for å tvinge alle prosesser for å få den nye verdien:

# sysctl -p

(preferanse er for en omstart).

Merk: For å omgå problemet må administratorer kanskje definere verdier som er høyere enn det som er anbefalt ovenfor, hvert system vil være annerledes.  Se dokumentasjonen for operativsystemet om sikre driftsgrenser når du øker disse verdiene.
Løsningsvurderinger Det anbefales på det sterkeste at Hotifx tas i bruk så snart som mulig.

Det er svært viktig at verdiene for filbeskrivelsen for operativsystemet gjenopprettes til verdier innenfor området som er definert i veiledningen for ytelse og optimalisering etter at hurtigreparasjonen er tatt i bruk.

Products

NetWorker
Article Properties
Article Number: 000188258
Article Type: Solution
Last Modified: 23 Aug 2022
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.