ECS: V aplikaci Oracle RMAN dochází k chybě HTTP 501 Neimplementováno po upgradu na verzi ECS 3.8.0.1–3.8.0.4
Summary: Kvůli regresi ECS může zálohovací aplikace Oracle Recovery Manager (RMAN) po upgradu na verzi ECS 3.8.0.1 – 3.8.0.4 narazit na chybu HTTP 501 "Not Implemented".
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Po upgradu na verzi ECS 3.8.0.1–3.8.0.4 mohou požadavky aplikace selhat s chybou HTTP "501 Not Implemented", pokud všechny parametry použité v požadavku nejsou na interním podporovaném seznamu ECS.
Při kontrole RMAN se zobrazuje chyba:
Ověřte problém v příkazu ECS:
Command:
Příklad:
Vezmeme-li requestID jako příklad, dále sledujte chybu, jak je uvedeno níže:
Command:
- Bylo potvrzeno, že se tento problém týká zálohovací aplikace Oracle Recovery Manager (RMAN).
- Problém má vliv na Oracle RMAN při zápisu přímo do systému ECS. Pokud Oracle RMAN zapisuje do systému ECS prostřednictvím jiné aplikace, nebude ovlivněna.
- Jiné aplikace mohou být ovlivněny, pokud používají podobnou konfiguraci, kde všechny parametry v požadavku nejsou součástí seznamu podporovaných aplikací.
Při kontrole RMAN se zobrazuje chyba:
RMAN-03009: failure of backup command on ORA_SBT_TAPE_1 channel at 11/20/2023 15:15:13 ORA-19506: failed to create sequential file, name="DB_FIP_20231120_mj2bv7g0_503507_1_1", parms="" ORA-27028: skgfqcre: sbtbackup returned error ORA-19511: non RMAN, but media manager or vendor specific failure, error text: KBHS-01404: See trace file /soft/oracle19/diag/rdbms/fip/fip/trace/sbtio_25047_140117933847552.log for details KBHS-00700: HTTP response error 'Not Implemented'
Ověřte problém v příkazu ECS:
Command:
svc_log -f "does not support operation with signature B" -start '<Timeline errors received in ECS> -sr dataheadsvc -n all -sf
Příklad:
# svc_log -f "does not support operation with signature B" -start '1 hours ago' -sr dataheadsvc -n all -sf svc_log v1.0.31 (svc_tools v2.14.0) Started 2023-11-22 15:34:17 Running on nodes: <All nodes> Time range: 2023-11-21 03:34:17 - 2023-11-22 15:34:17 Filter string(s): 'does not support operation with signature B' Show filename(s): True Show nodename(s): True Search reclaim logs (if any): False 169.254.1.5 dataheadsvc.log.20231121-134402.gz 2023-11-21T12:01:51,006 [qtp379782668-6225-88a5e8cf:18bedd2e9f0:d5e:4-s3-136.165.238.100] ERROR S3Service.java (line 638) does not support operation with signature B?not-implemented, request Id 88a5e8cf:18bedd2e9f0:d5e:4
Vezmeme-li requestID jako příklad, dále sledujte chybu, jak je uvedeno níže:
Command:
# svc_log -f "request ID highlighted from previous step" -sr dataheadsvc dataheadsvc-access -start <Timeline of requestID> -sfPříklad:
#svc_log -f "88a5e8cf:18bedd2e9f0:d5e:4" -sr dataheadsvc dataheadsvc-access -start 1h -sf svc_log v1.0.31 (svc_tools v2.14.0) Started 2023-11-22 15:45:40 Running on nodes: <All nodes> Time range: 2023-11-21 03:45:40 - 2023-11-22 15:45:40 Filter string(s): '88a5e8cf:18bedd2e9f0:d5e:4' Show filename(s): True Show nodename(s): True Search reclaim logs (if any): False <output truncated> . . 169.254.1.5 dataheadsvc.log.20231121-134402.gz 2023-11-21T12:01:51,006 [qtp379782668-6225-88a5e8cf:18bedd2e9f0:d5e:4-s3-136.165.238.100] ERROR S3Service.java (line 638) does not support operation with signature B?not-implemented, request Id 88a5e8cf:18bedd2e9f0:d5e:4 169.254.1.5 dataheadsvc-access.log 2023-11-21 12:01:51,007 88a5e8cf:18bedd2e9f0:d5e:4 136.165.232.207:9020 136.165.238.100:4249 dba-rman-prod - HEAD ul-rman-prod ul-rman-prod-01 ul-rman-prod-01 format=xml&x-BlockSize=262144&x-CopyNumber=0&x-Dbid=808640723&x-Dbname=RCAT&x-FileName=DB_RCAT_20231121_1i2c0uuu_63538_1_1&x-Incarnation=fpC63dLILKPb&x-NetTest=FALSE&x-Node=node1.hostname&x-OpenTime=2023-11-21%2012%3A01%3A51 &x-ReqCnt=34&x-ReqTime=2023-11-21%2012%3A01%3A51&x-SbtApi=sbtbackup&x-SbtOp=BeginUpload&x-SbtVersion=19.0.0.1&x-SessionId=0AA9580D05342089E063F7EDA5880453&x-System=Linux%20x86%2064-bit&x- SystemId=13&x-User=oracle HTTP/1.1 501 2 - - 1 - - - - 'x-amz-date: 20231121T120151Z' 'Connection: close' 'X-Amz-Content-SHA256: e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855' . . <output truncated>
Cause
Tento problém je způsoben regresí zavedenou v úložišti ECS-28517.
- Pokud aplikace nepoužívá žádné parametry, nedojde k chybě HTTP 501.
- Pokud aplikace používá parametry:
- Pokud používáte alespoň jeden parametr ze seznamu podporovaných parametrů (níže), nehlásí se žádné chyby HTTP 501.
- Pokud všechny parametry použité v dotazu nejsou v seznamu podporovaných parametrů, zobrazí se chyba HTTP 501.
| "acl", "lifecycle", "object-lock", "enable-object-lock", "umístění", "protokolování", "oznámení", "policy", "requestPayment", "torrent", "delete", "uploadId", "uploads", "uploads", "verzování", "verze", "web", "označování", "cors", "accessmode", "fileaccess", "ping", "cors", "endpoint", "isstaleallowed", "query", "replication", "replicationInfo", "legal-hold", "retention ", "retentionUpdate", "searchmetadata", "snapshot", "snapshots", "snapshotId", "empty-bucket-status", "select", "detailedReplicationStatus" |
Resolution
Problém je vyřešen od verze ECS 3.8.0.5.
- Pokud se tento problém objeví po upgradu na verzi ECS 3.8.0.1–3.8.0.4, otevřete případ u technické podpory a získejte opravu.
- Pokud používáte Oracle RMAN a plánujete upgrade na verzi ECS 3.8.0.1–3.8.0.4, informujte při plánování upgradu oddělení služeb, aby si vyžádalo speciální opravu pro upgrade. Tato speciální oprava by měla opravu tohoto problému.
POZNÁMKA: Vzhledem k tomu, že problém je opravený v novějším kódu, doporučujeme upgradovat na verzi s opravou.
Affected Products
ECS, ECS Appliance, ECS Appliance Gen 1, ECS Appliance Gen 2, ECS Appliance Gen 3, ECS Appliance Hardware Series, ECS Appliance Software with Encryption, ECS Appliance Software without Encryption, ECS Software, Elastic Cloud StorageArticle Properties
Article Number: 000219799
Article Type: Solution
Last Modified: 11 Mar 2024
Version: 8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.