NetWorker: Korrigieren inkonsistenter NSR-Peerinformationen

Summary: NSR-Peer-Informationsfehler während Backup und Recovery. Es gibt bereits einen Computer mit dem Namen (client_name). Wählen Sie entweder einen anderen Namen für Ihren Rechner aus oder löschen Sie den Eintrag "NSR peer information" für (client_name) auf dem Host: (host_name) ' ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Backups, Recoveries und Kommunikationen schlagen auf dem Client mit den folgenden Fehlern fehl:
 

'nsrexecd: SYSTEM error: There is already a machine using the name (client_name). Either choose a different name for your machine, or delete the "NSR peer information" entry for (client_name) on host: (host_name)'
'nsrexecd: SYSTEM error: Connection reset by peer'

 nsrexecd.exe kann zu Anwendungsfehlern auf einem oder mehreren Clients führen, einschließlich Server oder Speicher-Nodes.

Cause

Der Ordner res\nsrladb ist das Startverzeichnis der neuen zertifikatbasierten Hostauthentifizierung (nsrauth). Sie enthält sowohl das lokale Zertifikat des einzelnen Clients als auch eine zwischengespeicherte Kopie aller Hosts, mit denen er kommuniziert hat.

Bei der ersten Verbindung fordert ein Host das Zertifikat für den Host, mit dem er eine Verbindung herstellt, an und erhält es und speichert dieses Zertifikat für einen zukünftigen Vergleich zwischen. Abgesehen von gelenkten Recoveries und Storage Nodes würde in einer Standardumgebung jedes Clientzertifikat auf dem NetWorker-Server und den Storage Nodes und das Serverzertifikat auf jedem Client und Storage Node zwischengespeichert. Diese zwischengespeicherten Zertifikate werden im Zweig "Lokale Hosts" der Struktur "Konfiguration" angezeigt

Wenn ein Client neu installiert wird, wird das Zertifikat lokal auf dem Client neu erzeugt. Dies führt dazu, dass die zwischengespeicherte Kopie des Clientzertifikats des Servers ungültig wird, was zu den Fehlern führt. Die gleiche Bedingung ergibt sich durch einfaches Umbenennen von nsrladb auf dem Client.
 

Resolution

Die NSR-Peer-Informationen werden auf Clientebene und nicht auf Serverebene festgelegt. Mit anderen Worten: Sie müssen eine Verbindung zur NSRLA und nicht zur NSR-Datenbank herstellen. Dazu müssen Sie eine Verbindung über "nsradmin -p nsrexec" oder "nsradmin -p nsrexecd" herstellen. "nsradmin" allein stellt eine Verbindung zum NetWorker-Server her.

Löschen Sie das nicht übereinstimmende/zwischengespeicherte alte Zertifikat des Clients (client_name) auf dem NetWorker-Host, der die Fehlermeldung (host_name) erzeugt. Falls der NetWorker-Server aktualisiert/neu installiert wurde, muss das Serverzertifikat mithilfe der starken nsrauth-Authentifizierung von jedem Client entfernt werden. In beiden Fällen ist der Korrekturvorgang derselbe und einer der folgenden:

  1. Löschen Sie das Zertifikat für den Client, das von einem beliebigen Host mit einer Kopie des alten aktualisiert wurde, über lokale Hosts in NMC
  2. Altes/zwischengespeichertes Zertifikat über die Befehlszeile vom betroffenen Client löschen

So löschen Sie die Peer-Informationen des Clientcomputers (vom Server)
 

nsradmin -s <host_name> -p nsrexec
nsradmin> delete type: nsr peer information; peer hostname: <client_name>

 

So löschen Sie die Peer-Informationen auf dem Clientcomputer
 

nsradmin -p nsrexec
nsradmin> print type: nsr peer information
delete 

 
Weitere Informationen finden Sie unter: 

Additional Information

Sie können alle Zertifikate sicher löschen, da sie bei der nächsten Verbindung sowieso aktualisiert werden. Möglicherweise sind Peerinformationen sowohl für den Langnamen (FQDN) als auch für den Kurznamen vorhanden. Beachten Sie, dass das Zwischenspeichern von Zertifikaten nur für Clients aktiviert ist, deren Authentifizierungsmethode nsrauth als Teil des Werts enthält.

Workaround je nach Version:
  1. Durch Deaktivieren von nsrauth nur auf Server- und Speicher-Nodes (und Neustarten von NW) wird dieses Problem endgültig behoben.
  2. Legen Sie den NetWorker-Server auf den Modus nsrauth oder nsrauth/oldauth fest.
Der Olduth-Modus kann für NetWorker-Server nicht verwendet werden, wenn er mit NMC 8.0 verwendet wird.

Ein NetWorker-Server der Versionen 7.5.x, 7.6.x oder 8.0 im oldauth-Modus kann nicht mit NMC 8.0 verwendet werden, das sich standardmäßig im nsrauth/oldauth-Modus befindet.

Affected Products

NetWorker

Products

NetWorker, NetWorker Series
Article Properties
Article Number: 000024312
Article Type: Solution
Last Modified: 25 Apr 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.