Connectrix: Jak odstranit problémy s komunikací z uzlu Fibre Channel na port přepínače nebo SFP pomocí eliminace, nápověda.

Summary: Tento článek vysvětlujte, jak odstranit problémy s komunikací z uzlu Fibre Channel na port přepínače nebo SFP pomocí eliminace.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Jak odstranit problémy s komunikací z uzlu Fibre Channel na port přepínače nebo SFP pomocí eliminace?

Příliš mnoho proaktivních výměn SFP
Selhání připojení
G port
Nesvítí
Neprovozní sekvence (NOS)
Sekvence mimo linku (OLS)
Ztráta signálu
Vadný port SFP
Odstraňování problémů s portem FC
Chyby na portu FC

Cause

Proaktivně bylo vyměněno příliš mnoho portů SFP, zatímco problém leží mimo SFP nebo přepínač.

Resolution

Řešení tohoto problému:

  1. Určete uzel a port přepínače, kterých se selhání komunikace týká.
  2. Ověřte, zda je port přepínače spuštěný pro správu (není blokovaný, je zapnutý) nebo povolený.
  3. Než budete pokračovat, ujistěte se, že k připojenému zařízení vedou redundantní cesty.

 

VÝSTRAHA: Než budete pokračovat, ujistěte se, že víte, jak váš uzel zareaguje, pokud získá nové FCID. Některé verze operačních systémů AIX a HP-UX nereagují na tyto změny dobře, protože FCID je zabudováno v hardwarové cestě k úložnému zařízení. Pokud kabel přesunete, je možné, že nebudete mít k dispozici data. V případě pochybností se obraťte na pracovníka technické podpory společnosti EMC.

 

  1. Chcete-li vyloučit port SFP jako příčinu problému, postupujte následovně:
POZNÁMKA:  Pokud dojde k problému s portem SFP, tento postup představuje nejrychlejší způsob, jak zařízení znovu uvést do režimu online.

 

  1. Zkontrolujte volný port na přepínači.
  2. Zakažte určený volný port na přepínači.
  3. Přesuňte kabel z portu, který chcete prozkoumat, do nového zakázaného volného portu v předchozím kroku.
  4. Přepněte zakázaný port do povoleného stavu (nebo do stavu pro správu) a přiveďte zařízení zpět do režimu online.
  5. Vymažte/vynulujte statistiky/čítače na přepínači.

Informace o produktech Brocade naleznete v článku znalostní databáze: 

Connectrix řady B Brocade: Jak vyčistit rozhraní a čítače ASIC u přepínačů a řídicích členů Connectrix Brocade řady B 

Informace o produktech Cisco naleznete v článku znalostní databáze: 

Connectrix – Cisco řady MDS: Jak vymazat rozhraní a čítače ASIC na MDS

 

  1. Sledujte port pomocí příslušných příkazů po dobu 4–6 hodin.

 

VÝSLEDKY:

  • Pokud se čítače chyb zvýší, problém leží mimo přepínač a je třeba upozornit zákazníka/uživatele/správce pole SAN:

 

    • Nový port SFP a kabel je třeba vyčistit. (Abyste zabránili kontaminaci znečištěného kabelu u SFP, zvažte použití profesionální čisticí sady.)
    • Připojené zařízení musí dále zkontrolovat strana, která zařízení podporuje.
    • Pokud se na přepínači Cisco stav „errdisabled“ vrátí bez navýšení čítače, je nutné otevřít servisní požadavek pro další šetření backendu.

 

  • Pokud se počet chyb nezvýší (nebo se stav Errdisabled na přepínači Cisco nevrátí), je SFP na předchozím portu vadné; otevřete servisní požadavek pro výměnu SFP a poskytněte výše uvedené výsledky analýzy, včetně výstupů protokolu, podrobností SFP (SM nebo MM, rychlost atd.)

 

POZNÁMKA: Stejný postup můžete provést od kroku 6, pokud jste vyměnili kabel nebo připojené zařízení, a to tak, že zkontrolujete čítače.

 

Additional Information

POZNÁMKA: Ve většině případů, kdy optický transceiver SFP definitivně selže, se v protokolu událostí zobrazí jasné optické selhání.


Selhání hardwaru lze snadno izolovat použitím jednoduchého algoritmu. Pokud se nejedná o tento kus hardwaru, jde i jiný kus. Opakujte postup, dokud neizolujete chybu poukazující na problémový hardware.


PŘÍKLADY BROCADE:

POZNÁMKA: Vysvětlení nebo popis čítačů ve výstupu porterrshow naleznete v článku nápovědy znalostní databáze: (Příklady zvýrazněné níže.)
Connectrix řady B: Jak interpretovat výstup příkazu porterrshow Brocade a co znamenají počítadla. Nápověda



Příklad 1: Chyby ENC OUT, LINK FAIL a LOSS SYNC:

 

porterrshow        :
CURRENT CONTEXT -- 3 , 111
     frames        enc  crc  crc    too   too   bad  enc   disc  link  loss  loss  frjt  fbsy  c3timeout    pcs
     tx     rx     in   err  g_eof  shrt  long  eof  out   c3    fail  sync  sig               tx    rx     err
xx:  849.1k 493.2k 0    0    0      0     0     0    2.3m  0     4     6     0     0     0     0      0     0


Obecná příčina:
Platí pouze v případě, že během posledních 24 hodin došlo k vymazání statistik portu. Tyto čítače jinak klasifikujte jako historické. Vymažte statistiku portu (jak je uvedeno v bodu 9) a po 4–6 hodinách zkontrolujte čítače a znovu zachyťte data.

Z chyb je patrné, že spojení selhalo, došlo ke ztrátě synchronizace a chybám „enc out“, které také mohou zahrnovat chybu „loss sig“.
Tyto kombinace chyb obecně označují restartování hostitele nebo resetování připojení externího přepínače. Chyby „enc out“ jsou způsobeny během rychlého vyjednávání v rámci inicializace připojení.

Očekávané akce:
Ověřte, zda má zařízení připojené k portu legitimní důvod přejít do režimu offline či online. Například při restartování hostitele. Pokud ne, vytvořte servisní požadavek.


Příklad 2: ENC OUT:

porterrshow        :
CURRENT CONTEXT -- 3 , 111
     frames        enc  crc  crc    too   too   bad  enc   disc  link  loss  loss  frjt  fbsy  c3timeout    pcs
     tx     rx     in   err  g_eof  shrt  long  eof  out   c3    fail  sync  sig               tx    rx     err
xx:  849.1k 493.2k 0    0    0      0     0     0    2.3m  0     0     0     0     0     0     0      0     0


Obecná příčina:
Platí pouze v případě, že během posledních 24 hodin došlo k vymazání statistik portu. Tyto čítače jinak klasifikujte jako historické. Vymažte statistiku portu (jak je uvedeno v bodu 9) a po 4–6 hodinách zkontrolujte čítače a znovu zachyťte data.

Chyby „enc out“ bez jakýchkoli souvisejících chyb poukazují na znečištěný kabel.

Očekávané akce:
Zkontrolujte a očistěte všechny optické plochy na kabelu a SFP připojené k tomuto portu a připojeným zařízením.


Příklad 3: CRC a CRC G_EOF:

porterrshow        :
CURRENT CONTEXT -- 3 , 111
     frames        enc  crc  crc    too   too   bad  enc   disc  link  loss  loss  frjt  fbsy  c3timeout    pcs
     tx     rx     in   err  g_eof  shrt  long  eof  out   c3    fail  sync  sig               tx    rx     err
xx:  849.1k 493.2k 0    1.2k 1.2k   0     0     0    0     0     0     0     0     0     0     0      0     0


Obecná příčina:
Platí pouze v případě, že během posledních 24 hodin došlo k vymazání statistik portu. Tyto čítače jinak klasifikujte jako historické. Vymažte statistiku portu (jak je uvedeno v bodu 9) a po 4–6 hodinách zkontrolujte čítače a znovu zachyťte data.

Rámec vstupuje do portu přepínače s chybou CRC, ale konec rámce je stále označený jako bezchybný.
To znamená, že se jedná o první port, který registruje vadný rámec, a problém se tedy týká modulu SFP / kabelu / připojeného zařízení na tomto konkrétním portu.

Očekávané akce:
Viz výchozí akce v řešení.

U portu ISL vymažte statistiky (jak je uvedeno v bodu 9) a po 4–6 hodinách zkontrolujte čítače a znovu zachyťte data, shromážděte soubory supportsave z obou přepínačů a otevřete servisní požadavek pro normální odstraňování problémů.

 

Příklad 4: CRC:

porterrshow        :
CURRENT CONTEXT -- 3 , 111
     frames        enc  crc  crc    too   too   bad  enc   disc  link  loss  loss  frjt  fbsy  c3timeout    pcs
     tx     rx     in   err  g_eof  shrt  long  eof  out   c3    fail  sync  sig               tx    rx     err
xx:  849.1k 493.2k 0    1.2k 0      0     0     0    0     0     0     0     0     0     0     0      0     0


Obecná příčina:
Platí pouze v případě, že během posledních 24 hodin došlo k vymazání statistik portu. Tyto čítače jinak klasifikujte jako historické. Vymažte statistiku portu (jak je uvedeno v bodu 9) a po 4–6 hodinách zkontrolujte čítače a znovu zachyťte data.

Port nahrává rámec vstupující do přepínače s chybným rámcem CRC, který je však již označen jako chybný. To se obvykle zobrazuje na F portech ISL a NPIV.

Očekávané akce:
Pokud se na portu NPIV zaprotokolují chyby CRC, nechte zařízení prověřit u dodavatele služeb údržby!
U portu ISL zkontrolujte, zda některý port v topologii Fabric neobsahuje zaprotokolovanou chybu crc g_oef a akce jako v příkladu 3.


Příklad 5: Chyby PCS ERR, LINK FAIL a LOSS SYNC:

porterrshow        :
CURRENT CONTEXT -- 3 , 111
     frames        enc  crc  crc    too   too   bad  enc   disc  link  loss  loss  frjt  fbsy  c3timeout    pcs
     tx     rx     in   err  g_eof  shrt  long  eof  out   c3    fail  sync  sig               tx    rx     err
xx:  849.1k 493.2k 0    0    0      0     0     0    0     0     4     4     0     0     0     0      0     466


Obecná příčina:
Platí pouze v případě, že během posledních 24 hodin došlo k vymazání statistik portu. Tyto čítače jinak klasifikujte jako historické. Vymažte statistiku portu (jak je uvedeno v bodu 9) a po 4–6 hodinách zkontrolujte čítače a znovu zachyťte data.

To platí pouze pro platformy, které podporují porty s rychlostí 10 Gb/s nebo 16 Gb/s a vyšší (6505/6510/6520/DCX-8510) a byly představeny s platformou Condor3 ASIC 5. generace.

ER_PCS_BLK uvádí počet bloků chyb PCS (Physical Coding Sublayer). Tento čítač je ekvivalentní chybě enc_out pro připojení 8 Gb /4 Gb a používá se pouze pro rychlost 10 Gb a 16 Gb a vyšší.
Z chyb je patrné selhání připojení, ztráta synchronizace a chyby „pcs err“, které také mohou zahrnovat chybu „loss sig“.
Tyto kombinace chyb obecně označují restartování hostitele nebo resetování připojení externího přepínače.
Chyby „pcs“ jsou způsobeny během rychlého vyjednávání v rámci inicializace připojení.

Očekávané akce:
Ověřte, zda má zařízení připojené k portu legitimní důvod přejít do režimu offline a online. Například při restartování hostitele. Pokud ne, vytvořte servisní požadavek.


Příklad 6: PCS ERR:

porterrshow        :
CURRENT CONTEXT -- 3 , 111
     frames        enc  crc  crc    too   too   bad  enc   disc  link  loss  loss  frjt  fbsy  c3timeout    pcs
     tx     rx     in   err  g_eof  shrt  long  eof  out   c3    fail  sync  sig               tx    rx     err
xx:  849.1k 493.2k 0    0    0      0     0     0    0     0     0     0     0     0     0     0      0     466


Obecná příčina:
Platí pouze v případě, že během posledních 24 hodin došlo k vymazání statistik portu. Tyto čítače jinak klasifikujte jako historické. Vymažte statistiku portu (jak je uvedeno v bodu 9) a po 4–6 hodinách zkontrolujte čítače a znovu zachyťte data.

Chyby „PCS ERR“ bez jakýchkoli souvisejících chyb poukazují na znečištěný kabel.

Očekávané akce:
Zkontrolujte a očistěte všechny optické plochy na kabelu a SFP připojené k tomuto portu a připojeným zařízením.

 


PŘÍKLADY CISCO:

Příklad 1: Errdisabled:

Errdisabled – nedochází k nárůstu chyb rozhraní
 

fc1/1 is down (Error disabled - bit error rate too high)
    Hardware is Fibre Channel, SFP is short wave laser w/o OFC (SN).
    5 minutes input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
    5 minutes output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
      179 frames input, 7668 bytes
        0 discards, 0 errors
        0 CRC,  0 unknown class
        0 too long, 0 too short
      23 frames output, 1320 bytes
        0 discards, 0 errors
      1 input OLS, 1 LRR, 0 NOS, 1 loop inits
      2 output OLS, 0 LRR, 0 NOS, 1 loop inits
    Interface last changed at Thu Jun  5 01:51:00 2014

 

Obecná příčina:
Stav „Errdisabled“ rozhraní může být trochu zavádějící, protože čítače rozhraní mohou být na front-endu čisté, ačkoli se zdá, že přepínač vypíná port se stavem „errdisabled“ a čítače chyb se zvyšují na backendu (ASIC/interní/síťová karta).

Očekávané akce:
Viz výchozí akce v řešení. Pokud se objeví znovu, shromážděte výstup podrobností technické podpory a otevřete servisní požadavek.
 

POZNÁMKA: Informace o stavu „Errdisabled“ od společnosti Cisco: K bitovým chybám může dojít z následujících důvodů:
  • Vadný nebo poškozený kabel
  • Vadný nebo poškozený port SFP
  • Port SFP je určen pro rychlost 1 Gb/s, ale používá se i rychlost 2 Gb/s.
  • Port SFP je určen pro rychlost 2 Gb/s, ale používá se i rychlost 4 Gb/s.
  • Krátké kabely se používají pro dlouhé vzdálenosti nebo se dlouhé kabely používají pro krátké vzdálenosti.
  • Krátkodobá ztráta synchronizace
  • Uvolněné kabelové připojení na jednom nebo obou koncích
  • Nesprávné připojení SFP na jednom nebo obou koncích


Prahová hodnota bitových chyb je nastavena na výskyt 15 chyb za 5 minut. Ve výchozím nastavení přepínač při dosažení prahové hodnoty rozhraní zakáže. Rozhraní můžete znovu povolit postupným zadáním níže uvedených příkazů.

shutdown
no shutdown
Přepínač můžete nakonfigurovat tak, aby při překročení prahové hodnoty rozhraní nezakázal.


Ve výchozím nastavení prahová hodnota rozhraní zakáže.


Příklad 2:   CRC

Nárůst chyb CRC
 

fc13/1 is down (Initializing)
    Port description is ***
    Hardware is Fibre Channel, SFP is long wave laser cost reduced.
    5 minutes input rate 32 bits/sec, 4 bytes/sec, 0 frames/sec
    5 minutes output rate 32 bits/sec, 4 bytes/sec, 0 frames/sec
      162 frames input, 6136 bytes
        0 discards, 17 errors
        17 CRC,  0 unknown class
        0 too long, 17 too short
      74 frames output, 6304 bytes
        2 discards, 0 errors
      108 input OLS, 54 LRR, 2 NOS, 0 loop inits
      83 output OLS, 26 LRR, 56 NOS, 0 loop inits
    Interface last changed at Tue May 27 08:37:20 2014


Obecná příčina:

Port nahrává rámec vstupující do přepínače se špatným kódem CRC, ale dobrým koncem rámce. Čítač CRC se zvýší pouze na konkrétním portu příchozího přenosu dat, přičemž dojde k zaprotokolování chyby, a veškerá šetření by měla být provedena na tomto fyzickém spojení.

Očekávané akce:
Viz výchozí akce v řešení.

Vymažte statistiky portů (jak je uvedeno výše v bodu 9) a po 4–6 hodinách zkontrolujte čítače a znovu zachyťte data.

 

Příklad 3: NOS

Neprovozní sekvence (NOS)

show int fc1/1 counters
fc1/1
    5 minutes input rate 1753296 bits/sec, 219162 bytes/sec, 199 frames/sec
    5 minutes output rate 2310384 bits/sec, 288798 bytes/sec, 194 frames/sec
    2741512190 frames input, 2542476084276 bytes
      0 class-2 frames, 0 bytes
      2741512190 class-3 frames, 2542476084276 bytes
      0 class-f frames, 0 bytes
      0 discards, 0 errors, 0 CRC
      0 unknown class, 0 too long, 0 too short
    3410405365 frames output, 5164364339412 bytes
      0 class-2 frames, 0 bytes
      3410405365 class-3 frames, 5164364339412 bytes
      0 class-f frames, 0 bytes
      0 discards, 0 errors
    1 input OLS, 1 LRR, 0 NOS, 307 loop inits
    289 output OLS, 289 LRR, 289 NOS, 289 loop inits
    0 link failures, 0 sync losses, 0 signal losses
     48276 BB credit transitions from zero
      16 receive B2B credit remaining
      3 transmit B2B credit remaining
      3 low priority transmit B2B credit remaining

 

Obecná příčina:

Ztráta připojení před vyjednáváním spojení.


Očekávané akce:
Zkontrolujte vrstvu 1 (fyzická vrstva) a zdrojové zařízení.

Affected Products

Connectrix

Products

Connectrix, Connectrix B-Series Hardware, Connectrix MDS-Series Hardware
Article Properties
Article Number: 000028863
Article Type: Solution
Last Modified: 29 Jul 2025
Version:  9
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.