NVP-vProxy: Los respaldos fallan con el código de recurso no encontrado: -404 "Caducando la sesión inactiva"

Summary: Los respaldos de máquinas virtuales (VM) realizados con el dispositivo vProxy de NetWorker VMware Protection (NVP) fallan de forma intermitente, lo que indica que la sesión quedó obsoleta. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

La integración de protección de VMware de NetWorker (NVP) está configurada con el dispositivo con vProxy. Los respaldos fallan intermitentemente con un resource not found mensaje en NetWorker Management Console. Se completa un respaldo posterior para la máquina virtual, pero puede afectar a otras máquinas virtuales.

El registro de respaldo de máquina virtual y el mensaje de NetWorker Management Console muestran lo siguiente:
{"Text":"Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9","Code":-404}
El registro de acciones de respaldo muestra lo siguiente:
MM/DD/YY HH:MM:SS [VM_NAME]: Unable to obtain backup status from vProxy after 5 attempts, failing the backup: Received an HTTP code: 404, libCURL message: "", vProxy message: "Error received from vProxy ="-404: Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9". ", url: "https://ii170-vproxy01.fastenal.com:9090/api/v1/BackupVmSessions/44ab916f-7519-40f9-9d2e-e90394782ed9", body: " ".
MM/DD/YY HH:MM:SS [VM_NAME]: Unable to download vProxy Session log into file '/nsr/logs/policy/VMWare Protection/[WORKFLOW]/461300-[VM_NAME]-YYYY-MM-DD-HH-MM-SS.log': Possible wrong vProxy hostname or port, resource path not found. Received an HTTP code: 404, libCURL message: "", url: "https://[VPROXY_NAME]:9090/api/v1/BackupVmSessions/44ab916f-7519-40f9-9d2e-e90394782ed9/log".
MM/DD/YY HH:MM:SS [VM_NAME]: Backup failed.
MM/DD/YY HH:MM:SS The size of proxied data written has not been set.
MM/DD/YY HH:MM:SS Save-set ID '849786629' (client '[VCENTER_NAME]': save-set 'vm:50308677-bf8b-c786-0140-6a9c4409b90f:[VCENTER_NAME]') is aborted.
El vbackupd-engine.log vProxy muestra lo siguiente:
YYYY/MM/DD HH:MM:SS TRACE:  Ending go routine of main session loop for *resources.BackupVmSessions (vm-29424) [VM_NAME].
YYYY/MM/DD HH:MM:SS NOTICE: 44ab916f-7519-40f9-9d2e-e90394782ed9:vm-29424:[VM_NAME]: Backup session is exiting
YYYY/MM/DD HH:MM:SS TRACE:  Resource Update 44ab916f-7519-40f9-9d2e-e90394782ed9:externalId=[VCENTER_NAME]:vm-29424:state=Success:deletable=true.
YYYY/MM/DD HH:MM:SS INFO:   Saved resource map to "/opt/emc/vproxy/runtime/state/vbackupd/BackupVmSessions.gob".
YYYY/MM/DD HH:MM:SS NOTICE: Aging out inactive session BackupVmSessions - 44ab916f-7519-40f9-9d2e-e90394782ed9 ([VCENTER_NAME]:vm-29424) last accessed YYYY-MM-DD HH:MM:SS -0500 CDT.
YYYY/MM/DD HH:MM:SS TRACE:  Deleting logfiles of session '44ab916f-7519-40f9-9d2e-e90394782ed9'...
YYYY/MM/DD HH:MM:SS TRACE:  Deleting log file "/opt/emc/vproxy/runtime/logs/vbackupd/44ab916f-7519-40f9-9d2e-e90394782ed9.log" while deleting session "44ab916f-7519-40f9-9d2e-e90394782ed9"...
YYYY/MM/DD HH:MM:SS INFO:   File '/opt/emc/vproxy/runtime/logs/vbackupd/44ab916f-7519-40f9-9d2e-e90394782ed9.log' is moved to '/opt/emc/vproxy/runtime/logs/recycle/vbackupd/44ab916f-7519-40f9-9d2e-e90394782ed9.log'.
YYYY/MM/DD HH:MM:SS INFO:   Deleted log file "/opt/emc/vproxy/runtime/logs/vbackupd/44ab916f-7519-40f9-9d2e-e90394782ed9.log" while deleting session "44ab916f-7519-40f9-9d2e-e90394782ed9".
YYYY/MM/DD HH:MM:SS TRACE:  Deleting resource: [VCENTER_NAME]:vm-29424 - 44ab916f-7519-40f9-9d2e-e90394782ed9 ...
YYYY/MM/DD HH:MM:SS INFO:   Deleted resource: [VCENTER_NAME]:vm-29424 - 44ab916f-7519-40f9-9d2e-e90394782ed9.
YYYY/MM/DD HH:MM:SS INFO:   Saved resource map to "/opt/emc/vproxy/runtime/state/vbackupd/BackupVmSessions.gob".
YYYY/MM/DD HH:MM:SS INFO:   Aged out 1 'BackupVmSessions' sessions, 0 remaining
YYYY/MM/DD HH:MM:SS ERROR:  Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9
YYYY/MM/DD HH:MM:SS ERROR:  Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9
YYYY/MM/DD HH:MM:SS ERROR:  Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9
YYYY/MM/DD HH:MM:SS ERROR:  Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9
YYYY/MM/DD HH:MM:SS ERROR:  Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9
YYYY/MM/DD HH:MM:SS ERROR:  Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9
YYYY/MM/DD HH:MM:SS TRACE:  Handling Action GetLog for 44ab916f-7519-40f9-9d2e-e90394782ed9 ...
YYYY/MM/DD HH:MM:SS ERROR:  Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9
YYYY/MM/DD HH:MM:SS TRACE:  Reply sent successfully for "GetLog".

Cause

NetWorker Server comprueba continuamente el estado de la sesión de respaldo y solicita los registros una vez finalizada la sesión de respaldo. El vProxy completa el respaldo y envejece la sesión después de que NetWorker Server no solicita una actualización durante un par de minutos. A medida que la sesión se vuelve antigua, el vProxy ya no puede proporcionar al servidor de NetWorker una actualización de estado o registros y falla con el resource not found error. Las demoras en la solicitud de estado de NetWorker Server generalmente se deben a la alta latencia entre el nodo de almacenamiento de NetWorker y la comunicación de Data Domain.

Resolution

La latencia del nodo de almacenamiento de NetWorker a Data Domain se debe reducir a menos de 50 ms durante la ejecución del respaldo. Esta pauta se documenta en la sección "Consideraciones sobre el tamaño de la ventana TCP y la latencia de red" de la Guía de planificación de la optimización del rendimiento de Dell NetWorker. Si no se puede reducir la latencia, se recomienda configurar un nodo de almacenamiento de NetWorker en el sitio remoto para administrar los dispositivos Data Domain.

En el siguiente artículo, se detalla cómo realizar algunas soluciones de problemas de red: NetWorker: Cómo solucionar problemas relacionados con la red.

En el artículo anterior, se detalla cómo realizar un ping con marca de tiempo desde el nodo de almacenamiento de NetWorker y Data Domain. Confirme que las zonas horarias coincidan y deje la operación de ping en ejecución en segundo plano y salida a un archivo. Cuando se reproduzca el problema de respaldo, compruebe el rango de tiempo del archivo de salida ping para la alta latencia durante el período en que se observó el problema de respaldo. 

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000034020
Article Type: Solution
Last Modified: 03 Oct 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.