ECS:GeoDrive: Error: 12029 - サーバーとの接続を確立できなかった

Summary: GeoDriveエラー:12029 - ECSをGeoDriveクライアントに追加しているときに、「サーバーとの接続を確立できませんでした」というエラーが発生する。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

ユーザー ガイドに従ってGeoDrive WindowsクライアントにECSを追加する場合、IPを追加した後の接続テスト中にエラー メッセージが表示されることがあります。

Error: 12029 - A connection with the server could not be established
Error: 12029 - サーバーとの接続を確立できなかった 

Cause

WindowsまたはGeoDriveクライアントがECSに接続できません。

Resolution

ロード バランサー(LB)が使用されているかどうか、またはECSノードに直接接続されているかどうかをお客様に確認します

telnetなどのツールを使用して、WindowsクライアントからECSデータIPポート9020(HTTP)/9021(HTTPS)への接続をテストします
お客様のWindowsクライアントでtelnetが有効になっていない場合は、(Windows機能を)一時的に有効にするか、同じサブネット上のクライアントを使用するように依頼します

例:

C:\>telnet 10.1.1.1 9021
Connecting To 10.1.1.1...Could not open connection to the host, on port 9021: Connect failed

C:\>

接続できない場合は、次の手順を確認する必要があります。

  • お客様は、必要なポートがお客様の環境のファイアウォールでブロックされていないことを確認する必要があります。
  • 正しいECS IPアドレスが使用されます。ECS側で管理IPではなくネットワーク分離が有効になっている場合は、データIPアドレスが使用されていることを確認します。

ECSに接続し、ネットワーク分離が有効になっているかどうかを確認し、データのIPアドレスを確認します。
例:

admin@ecs1:~> getrackinfo -n
Named networks
==============
Node ID      Network           Ip Address     Netmask            Gateway         VLAN               Interface
1            repl              10.1.1.211     255.255.255.0      10.1.1.201      16                 public
1            data              10.1.2.202     255.255.255.0      10.1.2.201      123                public
2            repl              10.1.1.212     255.255.255.0      10.1.1.201      16                 public
2            data              10.1.2.203     255.255.255.0      10.1.2.201      123                public
3            repl              10.1.1.213     255.255.255.0      10.1.1.201      16                 public
3            data              10.1.2.204     255.255.255.0      10.1.2.201      123                public
4            repl              10.1.1.214     255.255.255.0      10.1.1.201      16                 public
4            data              10.1.2.205     255.255.255.0      10.1.2.201      123                public
5            repl              10.1.1.215     255.255.255.0      10.1.1.201      16                 public
5            data              10.1.2.206     255.255.255.0      10.1.2.201      123                public

上記の例では、IP 10.1.2.202 - 206 が正しく、GeoDriveクライアント構成に使用する必要があります。

以下のログファイルは、このファイル内でWindowsクライアントのIPアドレスを検索することで、最終的に詳細なトラブルシューティングに役立ちます。(上記のケースでは、データヘッドが接続を取得していないため、接続の試行は表示されません)。
 /opt/emc/caspian/fabric/agent/services/object/main/log/dataheadsvc.log

また、svc_logを使用して、すべてのノードのすべてのdataheadsvc.logsからWindowsクライアントのIPアドレスを検索することもできます。

admin@ecs1:~> svc_log -f '10.x.x.x' -sr dataheadsvc -n all -sn -sf

Additional Information

ユーザーの認証情報が誤って構成されている場合も、同じエラーが表示されることがあります
1.ユーザー ID は Object User.
である必要があります。2.シークレット アクセス キーは、オブジェクト ユーザー用に生成されたS3キーである必要があります。

ユーザーIDとシークレット アクセス キーは、GeoDriveから次の手順で編集できます。
ホスト>>、[Add GeoDrive]を押し>>編集するホスト>>編集します。 

Affected Products

GeoDrive for Windows

Products

GeoDrive for Windows, ECS Appliance, Elastic Cloud Storage
Article Properties
Article Number: 000045612
Article Type: Solution
Last Modified: 30 May 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.