Dell Unity: Сервер зберігання даних зафіксував внутрішній збій у гіпервізорі VMware. Код помилки:0x5c0000c

Summary: Сервер зберігання даних зафіксував внутрішній збій у гіпервізорі VMware. Будь ласка, перегляньте журнали подій на стороні гіпервізора VMware. (Код помилки:0x5c0000c)

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Середовище клієнта:
Гіпервізор Dell Technologies Unity Array
ESXi - Безкоштовна версія
(без серверів vSphere)

При підготовці сховища даних VMware з Array (Block DataStore) не вдалося створити файл з наступною помилкою:

The storage server detected an internal failure in the VMware hypervisor. Please review the event logs on the VMware hypervisor side. (Error Code:0x5c0000c)

Створення Lun проходить успішно, і клієнт все ще може сканувати та додавати Lun вручну до сховища даних.

Така ж помилка реєструється і при видаленні сховища даних з Unity.

 

Cause

Це не проблема з Array. Безкоштовна версія ESXi не допускає жодних модифікацій у порівнянні з VAAI. Він дозволяє виконувати лише операції «лише для читання».

Про вищезазначену помилку також може повідомлятися під час операцій NAS NFS, а також під час операцій видалення сховища даних з тієї ж причини.

 

Resolution

Перевірте ліцензію ESXi. Якщо у нього немає платної ліцензії, він блокує будь-які операції на кшталт «Створення сховища даних». Безкоштовна версія ESXi дозволяє працювати лише «лише для читання».

Щоб перевірити це, на хості ESXi перевірте наявність повідомлення "vim.fault.RestrictedVersion" у /var/log/hostd.log.

Приклад з коробки клієнта (10.x.x.1xx — це IP Unity у цьому прикладі, а 10.x.x.2xx — IP гіпервізора esxi):

2016-09-01T00:02:04.043Z [31380B70 info 'Vimsvc.ha-eventmgr' opID=hostd-fcae] Event 365 : User root@10.0.0.xxx logged in as gSOAP/2.8
2016-09-01T00:02:04.058Z [31380B70 verbose 'Default' opID=EB2968DD-00001161 user=root] AdapterServer: target='vmodl.query.PropertyCollector:ha-property-collector', method='waitForUpdates'
2016-09-01T00:02:04.065Z [31D80B70 info 'Vimsvc.TaskManager' opID=hostd-81d8 user=root] Task Created : haTask--vim.SearchIndex.findByIp-40794283
2016-09-01T00:02:04.066Z [31D80B70 verbose 'Solo.SearchIndex' opID=hostd-81d8 user=root] FindByAttribute: dcRef = <null>, attrVal = 10.x.x.2xx, vmSearch = false
2016-09-01T00:02:04.071Z [31D80B70 verbose 'Solo.SearchIndex' opID=hostd-81d8 user=root] FindByAttribute: returning vim.HostSystem:ha-host
2016-09-01T00:02:04.071Z [31D80B70 info 'Vimsvc.TaskManager' opID=hostd-81d8 user=root] Task Completed : haTask--vim.SearchIndex.findByIp-40794283 Status success
2016-09-01T00:02:04.156Z [2F640B70 info 'Solo.Vmomi' opID=hostd-e2e2 user=root] Activation [N5Vmomi10ActivationE:0x30997200] : Invoke done [rescanHba] on [vim.host.StorageSystem:storageSystem]
2016-09-01T00:02:04.156Z [2F640B70 verbose 'Solo.Vmomi' opID=hostd-e2e2 user=root] Arg hbaDevice:
--> "vmhba33"
2016-09-01T00:02:04.156Z [2F640B70 info 'Solo.Vmomi' opID=hostd-e2e2 user=root] Throw vim.fault.RestrictedVersion
2016-09-01T00:02:04.156Z [2F640B70 info 'Solo.Vmomi' opID=hostd-e2e2 user=root] Result:
--> (vim.fault.RestrictedVersion) {
-->    dynamicType = <unset>,
-->    faultCause = (vmodl.MethodFault) null,
-->    msg = "",
--> }
2016-09-01T00:02:04.174Z [31380B70 verbose 'Default' opID=hostd-2bc7 user=root] CloseSession called for session id=c3304bfa-1fb1-10d4-9873-259b210357ea
2016-09-01T00:02:04.175Z [31380B70 info 'Vimsvc.ha-eventmgr' opID=hostd-2bc7 user=root] Event 366 : User root@10.x.x.xxx logged out (login time: Thursday, 01 September, 2016 00:02:03, number of API invocations: 0, user agent: gSOAP/2.8)

Отже, у наведеному вище журналі зазначено, що Unity увійшла в систему та отримала помилку vim.fault.RestrictedVersion, тому вона вийшла з системи, не завершивши створення "сховища даних" і повідомляє "Код помилки:0x5c0000c"

Клієнт повинен оплатити ліцензію/сервери vCenter або надати сховище даних вручну.

 

Affected Products

Dell EMC Unity Family

Products

Dell EMC Unity Family
Article Properties
Article Number: 000052030
Article Type: Solution
Last Modified: 22 Oct 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.