ViPR Controller: Order fails with Encountered an SMIS error when attempting to query existing exports: Error when attempting to query LUN masking information: For input string: ""

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Symptoms

No reported changes.

The user is unable to create a volume with the following errors and symptoms:

GUI shows:

Message: Error 12023: Encountered an error in export create: Encountered an SMIS error when attempting to query existing exports: Error when attempting to query LUN masking information: For input string: ""


Controllersvc logs show that ViPR Controller is querying Solutions Enabler/Storage Management Initiative Specification (SE/SMI-S):

vipr2 vipr2 controllersvc 2017-05-11 16:32:25,704 [10178|exportGroupCreate|60fad611-7ec8-4633-bd57-dfd1955c55a2e46115e5-f396-4c64-86b9-45f3e58dfd19] INFO CIMObjectPathQueryFactory.java (line 541) ExecQuery: SELECT * FROM SE_StorageHardwareID WHERE InstanceID like '1234567891011121'


 Debug controllersvc logs show that the DeviceNumber is coming back blank from SE/SMIS:

vipr2 vipr2 controllersvc 2017-05-11 16:32:25,870 [10178|exportGroupCreate|60fad611-7ec8-4633-bd57-dfd1955c55a2e46115e5-f396-4c64-86b9-45f3e58dfd19] DEBUG CIMPropertyFactory.java (line 131) instance :instance of Symm_ProtocolControllerForUnit_LMV_SV {
DeviceNumber = "";
Antecedent = "root/emc:Symm_LunMaskingView.CreationClassName=\"Symm_LunMaskingView\",DeviceID=\"MV-1234567891011\",SystemCreationClassName=\"Symm_StorageSystem\",SystemName=\"SYMMETRIX-+-012345678910\"";
Dependent = "root/emc:Symm_StorageVolume.CreationClassName=\"Symm_StorageVolume\",DeviceID=\"0007C\",SystemCreationClassName=\"Symm_StorageSystem\",SystemName=\"SYMMETRIX-+-012345678910\"";
};



ViPR then fails with the following error:

vipr2 vipr2 controllersvc 2017-05-11 16:32:25,870 [10178|exportGroupCreate|60fad611-7ec8-4633-bd57-dfd1955c55a2e46115e5-f396-4c64-86b9-45f3e58dfd19] DEBUG CIMPropertyFactory.java (line 132) propertyName :DeviceNumber
vipr2 vipr2 controllersvc 2017-05-11 16:32:25,870 [10178|exportGroupCreate|60fad611-7ec8-4633-bd57-dfd1955c55a2e46115e5-f396-4c64-86b9-45f3e58dfd19] ERROR VmaxExportOperations.java (line 1744) Encountered an SMIS error when attempting to query existing exports: Error when attempting to query LUN masking information: For input string: ""
java.lang.NumberFormatException: For input string: ""
at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)
at java.lang.Long.parseLong(Long.java:601)
at com.emc.storageos.volumecontroller.impl.smis.SmisCommandHelper.getVolumesFromLunMaskingInstance(SmisCommandHelper.java:4608)



Symdev_list output from the EMCReport from the SE/SMI-S host shows the following:

        Device Name            Dir                  Device                
---------------------------- ------- -------------------------------------
                                                                      Cap 
Sym   Physical               SA :P   Config        Attribute    Sts   (MB)
---------------------------- ------- -------------------------------------
...
0007C Not Visible            ???:??? TDEV          N/Grp'd      RW  4194306

 

Cause

As seen in the debug ViPR Controller controllersvc logs, an empty value for the DeviceNumber is returned by SE/SMI-S.  This causes the ViPR order to fail.  The SE/SMIS symdev_list output from the EMCReports shows the device status as ???:???.  This indicates that the device is not visible to a host. 

Rebuilding the symapi database did not resolve the issue.



Resolution

Workaround:
To resolve the issue the storage administrator removed the device from the storage group and re-added it . This updated the Symmetrix databases and ViPR no longer failed when provisioning storage. 

For steps regarding the specific array in the use case see the documentation from EMC Online Support.  From the EMC Support home page menu bar, select Support by Product, search for the product using "Find a Product". The product page provides one-stop access to technical and support-related information by EMC product for downloads, documentation, tools and additional content.

Because the view is restricted based on customer agreements, you may not have permission to view certain documentation or software downloads. Should you not see documentation or software downloads you believe you should have access to, follow the instructions in  Link Error How to get assistance for EMC Online Support tools.

Additional Information

 


 

Article Properties
Article Number: 000055240
Article Type: Solution
Last Modified: 11 Oct 2024
Version:  3
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