DPA: Agent kann keine Verbindung zum Avamar-Server herstellen, Fehler "Fehler beim Ermitteln der Datenbankversion"

Summary: Der Data Protection Advisor (DPA)-Agent kann keine Verbindung zum Avamar-Server herstellen. Agent-Protokollfehler "Fehler beim Ermitteln der Datenbankversion: Verbindung zur Datenbank mcdb fehlgeschlagen: Verbindung zum Server konnte nicht hergestellt werden: Verbindungs-Timeout" ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Die Datenerfassung für einen Avamar -Server schlägt fehl.

Beim Überprüfen des DPA-Agent-Protokolls oder des Anforderungsverlaufsbildschirms wird der folgende Fehler angezeigt:

DBG1     9695.8        20170403:115705  sodbc.pgsql.connect - cpgsqlConnect(): Failed to determine database version: Connection to database mcdb failed: could not connect to server: Connection timed out
Is the server running on host "test.avamar" (192.xxx.x.xx) and accepting TCP/IP connections on port 5555?

Cause

Dieser Fehler weist darauf hin, dass der DPA-Agent keine Verbindung zum Avamar Server herstellen kann.

Einige Umgebungsfaktoren, die nicht mit DPA zusammenhängen, können dieses Problem verursachen:

  • Netzwerkverbindungsprobleme
  • Namensauflösungsprobleme
  • Probleme mit der Avamar-Verbindungskonfiguration

Resolution

Die folgenden Schritte können verwendet werden, um die Netzwerkverbindung zu testen:

  • Pingen Sie Avamar vom DPA-Agent-Server aus an. Wenn es keine Antwort gibt, handelt es sich um ein Netzwerkproblem.
  • Wenn eine Antwort auf den Ping empfangen wird, können Sie von einem Linux-System oder Windows PowerShell Folgendes ausführen, um die Portverbindung zu testen:
curl -kv <avamar FQDN or IP>:5555
  • Wenn der Port erreichbar ist, zeigt die Zeile "Connected to" an, dass eine Verbindung hergestellt wurde. Siehe Beispiel unten:
curl -kv 10.x.x.x:5555
*   Trying 10.x.x.x:5555...
* Connected to 10.x.x.x (10.x.x.x) port 5555 (#0)
> GET / HTTP/1.1
> Host: 10.x.x.x:5555
> User-Agent: curl/8.0.1
> Accept: */*
>
* Empty reply from server
* Closing connection 0
curl: (52) Empty reply from server
  • Wenn die Zeile "Verbunden mit" nicht angezeigt wird oder Sie die Meldung "Verbindung fehlgeschlagen" oder "Nicht verbunden" erhalten oder nicht mehr reagiert und keine Rückgabe ausgibt, weist dies auf ein Netzwerkverbindungsproblem hin. 
  • Dies erfordert eine Untersuchung durch den Netzwerkadministrator der Umgebung, um das Problem mit der Netzwerkverbindung zu beheben. 
  • Wenn der Curl-Befehl eine Verbindung herstellt, öffnen Sie einen Service-Request (SR) beim Dell Support.


Weitere Details oder Informationen erhalten Sie vom Dell Support .

Affected Products

Data Protection Advisor

Products

Avamar
Article Properties
Article Number: 000059572
Article Type: Solution
Last Modified: 23 Jul 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.