DPA:代理程式無法連線至 Avamar Server,錯誤「無法判定資料庫版本」
Summary: Data Protection Advisor (DPA) 代理程式無法連線至 Avamar Server。代理程式記錄錯誤「無法判定資料庫版本:連線到資料庫 mcdb 失敗:無法連線到伺服器:連線逾時」
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Symptoms
Avamar Server 的資料收集失敗。
檢查 DPA 代理程式記錄或要求歷程記錄畫面,您會看到下列錯誤:
DBG1 9695.8 20170403:115705 sodbc.pgsql.connect - cpgsqlConnect(): Failed to determine database version: Connection to database mcdb failed: could not connect to server: Connection timed out Is the server running on host "test.avamar" (192.xxx.x.xx) and accepting TCP/IP connections on port 5555?
Cause
此錯誤表示 DPA 代理程式無法建立與 Avamar 伺服器的連線。
某些與 DPA 無關的環境因素 (包括) 可能會導致此問題:
- 網路連線問題
- 名稱解析問題
- Avamar 連線組態問題
Resolution
下列步驟可用來測試網路連線能力:
- 從 DPA 代理程式伺服器執行 Ping Avamar。如果沒有回應,則這是網路問題。
- 如果收到對 ping 的回應,則可以從 Linux 系統或 Windows PowerShell 執行下列步驟來測試連接埠連線:
curl -kv <avamar FQDN or IP>:5555
- 在可連線至連接埠的良好回應中,「Connected to」行會顯示已建立連線請參閱以下範例:
curl -kv 10.x.x.x:5555 * Trying 10.x.x.x:5555... * Connected to 10.x.x.x (10.x.x.x) port 5555 (#0) > GET / HTTP/1.1 > Host: 10.x.x.x:5555 > User-Agent: curl/8.0.1 > Accept: */* > * Empty reply from server * Closing connection 0 curl: (52) Empty reply from server
- 如果「Connected to」線路不存在,或您收到「Failed to Connect」、「Not Connected」,或是它停止回應且未提供任何回傳,這表示發生了網路連線問題。
- 這需要環境的網路系統管理員進行調查,以解決網路連線問題。
- 如果 Curl 命令可連線,請向 Dell 支援開立服務要求 (SR)。
請聯絡 Dell 支援 以取得更多詳細資料或資訊。
Affected Products
Data Protection AdvisorProducts
AvamarArticle Properties
Article Number: 000059572
Article Type: Solution
Last Modified: 23 Jul 2025
Version: 4
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