DPA:代理无法连接到 Avamar Server,错误“无法确定数据库版本”

Summary: Data Protection Advisor (DPA) 代理无法连接到 Avamar Server。代理日志错误“无法确定数据库版本:与数据库 mcdb 的连接失败:无法连接到服务器:连接超时”

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Symptoms

Avamar Server 的数据收集失败。

检查 DPA 代理程序日志或请求历史记录屏幕,您会看到以下错误:

DBG1     9695.8        20170403:115705  sodbc.pgsql.connect - cpgsqlConnect(): Failed to determine database version: Connection to database mcdb failed: could not connect to server: Connection timed out
Is the server running on host "test.avamar" (192.xxx.x.xx) and accepting TCP/IP connections on port 5555?

Cause

此错误表示 DPA 代理无法与 Avamar Server 建立连接。

与 DPA 无关的一些环境因素(包括)可能会导致此问题:

  • 网络连接问题
  • 名称解析问题
  • Avamar 连接配置问题

Resolution

以下步骤可用于测试网络连接:

  • 从 DPA 代理程序服务器 Ping Avamar。如果没有响应,则这是网络问题。
  • 如果收到对 ping 的响应,则可以从 Linux 系统或 Windows PowerShell 运行以下命令来测试端口连接:
curl -kv <avamar FQDN or IP>:5555
  • 在端口可访问的良好响应中,“Connected to”行显示已建立连接。请参阅下面的示例:
curl -kv 10.x.x.x:5555
*   Trying 10.x.x.x:5555...
* Connected to 10.x.x.x (10.x.x.x) port 5555 (#0)
> GET / HTTP/1.1
> Host: 10.x.x.x:5555
> User-Agent: curl/8.0.1
> Accept: */*
>
* Empty reply from server
* Closing connection 0
curl: (52) Empty reply from server
  • 如果“Connected to”行不存在,或者您收到“Failed to Connect”、“Not Connected”,或者它停止响应且不返回,则表示存在网络连接问题。 
  • 这需要环境的网络管理员进行调查,以解决网络连接问题。 
  • 如果 curl 命令连接,则向 戴尔支持部门提出服务请求 (SR)。


有关更多详细信息或信息,请联系 戴尔支持

Affected Products

Data Protection Advisor

Products

Avamar
Article Properties
Article Number: 000059572
Article Type: Solution
Last Modified: 23 Jul 2025
Version:  4
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