NetWorker NVP-vProxy: Backups reagieren nicht mehr beim Warten auf beschreibbare Volumes, wenn der Ziel-Backuppool ein schreibgeschütztes Gerät enthält

Summary: Die NVP-Lösung (NetWorker VMware Protection) ist mit der vProxy-Appliance konfiguriert. Der Ziel-Backup-Pool ist mit mehreren Geräten von verschiedenen Mtrees konfiguriert und auf einem der Geräte ist die schreibgeschützte Option ausgewählt. Die Backupaktion kann auf den verbleibenden Geräten nicht ausgeführt werden und die NMC-Warnmeldungen (NetWorker Management Console) weisen darauf hin, dass auf beschreibbare Volumes gewartet wird. Die herkömmlichen NetWorker-Backupaktionen können erfolgreich auf die verfügbaren Geräte schreiben, wenn sich ein schreibgeschütztes Gerät im Pool befindet. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Die NVP-Lösung (NetWorker VMware Protection) ist mit der vProxy-Appliance konfiguriert.
  • Eine oder mehrere virtuelle Maschinen (VMs) in einem Schutzworkflow schreiben keine Backups.
    • Die Backup Aktion kann nicht auf den verbleibenden Geräten ausgeführt werden und es wird eine NMC-Warnmeldung (NetWorker Management Console) angezeigt, die darauf hinweist, dass auf beschreibbare Volumes gewartet wird.
      Warten auf Warnmeldung zum beschreibbaren Volume in der NMC
    • Das Backupaktionsprotokoll meldet möglicherweise die folgenden Fehler:
      YYYY-MM-DD HH:mm:SS 2 5 0 14244 11312 0 NSR_NAME nsrvproxy_save NSR warning Unable to set up the direct save with server 'NSR_NAME'. Be sure network connectivity exists between client 'VCENTER_NAME' and storage node 'STORAGENODE_NAME' in both directions. Error: Unable to connect to the storage node on host STORAGENODE_NAME: nsrvproxy_save failed to authenticate with nsrmmd on host STORAGENODE_NAME: Timed out.
      ...
      YYYY-MM-DD HH:mm:SS 2 5 0 11248 11312 0 NSR_NAME nsrvproxy_save NSR warning Unable to set up the direct save with server 'NSR_NAME'. Be sure network connectivity exists between client 'VCENTER_NAME' and storage node 'STORAGENODE_NAME' in both directions. Error: The VM backup request is not valid.
  • Der Ziel-Backup-Pool ist mit mehreren Geräten von verschiedenen Mtrees konfiguriert und auf einem der Geräte ist die schreibgeschützte Option ausgewählt.
    • Medien-Medien-Pools> – Pool-Eigenschaften>
      Auswahlkriterien für Medienpools
    • Medienfestplatten-Volumes>:
      Festplatten-Volumes
  • Die herkömmlichen NetWorker-Backupaktionen können erfolgreich auf die verfügbaren Geräte schreiben, wenn sich ein schreibgeschütztes Gerät im Pool befindet.

 

Cause

Dies ist eine bekannte Einschränkung in NetWorker, da für das inkrementelle Backup der vProxy-Lösung Virtual Synthetic Full Backups (VSF) auf der Data Domain verwendet werden. Diese Einschränkung wirkt sich auf alle VSF-abhängigen Funktionen aus (z. B. vProxy-Backups, blockbasierte Backups und NetWorker Module for Microsoft-Backups), wenn das Data Domain-Volume im Ziel-Backuppool schreibgeschützt wird.

Die herkömmlichen NetWorker-Clientbackups verwenden VSF nicht, sodass sie einen Zielbackuppool mit einem schreibgeschützten Gerät verwenden können.

 

Resolution

Option 1:

Ändern Sie den Volume-Modus von "read-only" auf "appendable".

HINWEIS: Dies sollte nur erfolgen, wenn Sie sicher sind, dass die Festplatte beschrieben werden soll. Wenn das Gerät "schreibgeschützt" bleiben muss, finden Sie weitere Informationen unter Option 2.
  1. Melden Sie sich mit dem Administratornutzerkonto bei der NetWorker Management Console (NMC) an.

  2. Wenn das Gerät gemountet ist, unmounten Sie es unter Geräte-Geräte>.

    1. Öffnen Sie die Geräteeigenschaften und stellen Sie sicher, dass die automatische Medienverwaltung deaktiviert ist. Wenn diese Option aktiviert ist, wird das Gerät nach dem Unmounten automatisch erneut gemountet:
      Einstellung für die automatische Medienverwaltung
    2. Klicken Sie mit der rechten Maustaste auf das Gerät und wählen Sie Unmount:
      Unmounten eines Geräts
  3. Navigieren Sie zu Media-Disk>Volumes. Klicken Sie mit der rechten Maustaste auf das schreibgeschützte Volume und wählen Sie Change Modes-Appendable> aus. Das Kontrollkästchen "Converting a device to read-only" im NetWorker-Administrationshandbuch gibt an, dass das Gerät nicht in Backupvorgängen verwendet werden kann, das Gerät jedoch weiterhin für Lesevorgänge (Wiederherstellung und Clone) verwendet werden kann. Dies gilt jedoch nur für herkömmliche NetWorker-Backups.
    Ändern des Modus in anhängbar

  4. Kehren Sie zu Geräte –>Geräte zurück. Klicken Sie mit der rechten Maustaste auf das Gerät und wählen Sie Mounten aus.

    WARNUNG: Klicken Sie nicht auf "Etikettieren". Beim Etikettieren des Volumes werden alle Daten gelöscht.

Sobald das Volume angehängt werden kann, ist das Gerät gemountet. Die Warnmeldung "Warten auf beschreibbares Volume" sollte gelöscht werden und die Daten sollten in den Pool geschrieben werden. Wenn die Warnmeldung nicht gelöscht wird, lesen Sie den folgenden Wissensdatenbank-Artikel, da es andere mögliche Ursachen gibt, die ebenfalls zutreffen können: NetWorker: Troubleshooting bei Medienwarteereignissen – Warten auf ein beschreibbares Volume oder keine übereinstimmenden Geräte

Option 2:

Wenn das schreibgeschützte Gerät im Zielbackuppool verbleiben muss, muss das Gerät deaktiviert werden, damit die neuen Backups abgeschlossen werden können. Um das Gerät zu deaktivieren, muss es unmountet werden. Siehe obige Schritte 1-2 zum Unmounten des Geräts. Sobald das Gerät unmountet ist, klicken Sie mit der rechten Maustaste auf das Gerät und wählen Sie Aktivieren/Deaktivieren aus. In der Spalte "enabled" des Geräts wird "no" angezeigt. Nachfolgende VM-Backups schreiben auf die anderen Volumes im Pool.

HINWEIS: Da die neuen Backups kein VSF-Backup erstellen können, wird ein komplettes Backup auf einem neuen Level für die VM durchgeführt.

 

Additional Information

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000069413
Article Type: Solution
Last Modified: 18 Mar 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.