VxRail: Error "503 Servicio no disponible" cuando se accede a VMware vCenter

Summary: Pasos de solución de problemas para resolver el error "503 Service Unavailable, Failed to connect to endpoint" con VMware vCenter.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Es posible que los administradores no puedan acceder a vCenter. Cuando se inicia sesión en la interfaz de usuario, se publica el siguiente mensaje:

503 Service Unavailable Failed to connect to endpoint: [N7Vmacore4Http20NamedPipeServiceSpecE:0x00007f975808ee30] _serverNamespace = / action = Allow _pipeName =/var/run/vmware/vpxd-webserver-pipe)

Cause

Puede haber varias causas para este error. A continuación, se muestran algunos escenarios posibles:

1. El servicio no se inició correctamente y algunos servicios no están en funcionamiento:

# service-control --status
Running:
 lwsmd vmafdd vmcad vmdird
Stopped:
 applmgmt lookupsvc observability observability-vapi pschealth vlcm vmcam vmonapi vmware-analytics vmware-certificateauthority vmware-certificatemanagement vmware-cis-license vmware-content-library vmware-eam vmware-envoy vmware-hvc vmware-imagebuilder vmware-infraprofile vmware-netdumper vmware-perfcharts vmware-pod vmware-postgres-archiver vmware-rbd-watchdog vmware-rhttpproxy vmware-sca vmware-sps vmware-statsmonitor vmware-stsd vmware-topologysvc vmware-trustmanagement vmware-updatemgr vmware-vapi-endpoint vmware-vcha vmware-vdtc vmware-vmon vmware-vpostgres vmware-vpxd vmware-vpxd-svcs vmware-vsan-health vmware-vsm vsphere-ui vstats vtsdb wcp

 

2. Los certificados vencieron. Para revisar el vencimiento, conecte vCenter y ejecute el siguiente comando:

for store in $(/usr/lib/vmware-vmafd/bin/vecs-cli store list | grep -v TRUSTED_ROOT_CRLS); do echo "[*] Store :" $store; /usr/lib/vmware-vmafd/bin/vecs-cli entry list --store $store --text | grep -ie "Alias" -ie "Not After";done;

Resolution

Estas son las diferentes resoluciones para los escenarios 1 y 2 anteriores:

1. Confirme el estado de VMware vCenter Services. Asegúrese de que todos los servicios necesarios estén en funcionamiento y en ejecución.
Si los servicios no se inician correctamente, reinícielos mediante el siguiente artículo de la base de conocimientos:

Detención, inicio o reinicio de los servicios del dispositivoEste hipervínculo lo redirige a un sitio web fuera de Dell Technologies.
 

2. Compruebe si los certificados vencieron:

VxRail: No se puede iniciar sesión en vCenter debido a certificados vencidos
 

3. Revise los registros para ver las posibles causas raíz:

/var/log/vmware/vsphere-client/logs/

/var/log/vmware/vpxd 

 

Para obtener más información sobre la solución de problemas, revise la base de conocimientos oficial de Broadcom:

https://knowledge.broadcom.com/external/article?legacyId=67818 Este hipervínculo lo redirige a un sitio web fuera de Dell Technologies.

Este hipervínculo lo redirige a un sitio web fuera de Dell Technologies.

Additional Information

En VxRail 4.7 (vSphere 6.7), había un problema histórico relacionado con ISO con un nombre largo montado en cualquier cantidad de máquinas virtuales:

Esto hacía que fuera demasiado largo para la base de datos, según el siguiente artículo de la base de conocimientos:

El host no se puede conectar a vCenter debido a un error: cadena demasiado grande para la base de datos (55610)Este hipervínculo lo redirige a un sitio web fuera de Dell Technologies.

 

Affected Products

VxRail, VxRail Appliance Family, VxRail Software
Article Properties
Article Number: 000078068
Article Type: Solution
Last Modified: 01 Dec 2025
Version:  18
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.