วิธีการซ่อมแซมโปรแกรมโหลดบูต EFI บนฮาร์ดไดรฟ์ GPT สําหรับระบบปฏิบัติการ Windows บนคอมพิวเตอร์ Dell ของคุณ
Summary: บทความนี้แสดงข้อมูลเกี่ยวกับวิธีการแก้ไขปัญหากับ EFI Bootloader ไม่บูตอย่างถูกต้องบนฮาร์ดดิสก์ไดรฟ์ GPT มันมีคําแนะนําสําหรับระบบปฏิบัติการ Windows ต่างๆ
Symptoms
Cause
แนะ นำ
คนส่วนใหญ่ที่มีปัญหาการบูตบนระบบปฏิบัติการ Windows เลือกที่จะติดตั้งระบบปฏิบัติการใหม่แทนที่จะพยายามแก้ไขปัญหาการบูตเอง
บทความนี้เกี่ยวข้องกับการซ่อมโปรแกรมโหลดบูตอินเทอร์เฟซเฟิร์มแวร์แบบขยายได้ (EFI) บน GUID [ตัวระบุที่ไม่ซ้ํากันทั่วโลก] ตารางพาร์ติชัน (GPT) ฮาร์ดดิสก์ไดรฟ์
โซลูชันนี้ใช้ได้กับระบบปฏิบัติการที่ติดตั้งบนระบบอินพุต/เอาท์พุตพื้นฐาน (BIOS) ของอินเทอร์เฟซเฟิร์มแวร์แบบขยายได้ (UEFI) แบบรวม
Resolution
วิธีซ่อมแซมโปรแกรมโหลดบูต EFI ของคุณ
โดยทั่วไป Windows 7 และ Windows 8 จะติดตั้งบน BIOS แบบดั้งเดิมที่ใช้บันทึกการเริ่มระบบหลัก (MBR) อย่างไรก็ตาม Windows 11 และ Windows 10 ได้รับการออกแบบมาเพื่อติดตั้งบน UEFI BIOS โดยใช้โปรแกรมโหลดบูต EFI และ GPT
โครงสร้าง GPT เกี่ยวข้องกับปัญหามากมายที่คําสั่ง Bootsect ได้รับการออกแบบมาเพื่อแก้ไขใน MBR อย่างไรก็ตามคําแนะนําต่อไปนี้จะนําคุณไปสู่การซ่อมแซมโปรแกรมโหลดบูต EFI:
หน้าต่าง 11
ถ้าคุณมีสื่อการติดตั้ง:
-
ใส่สื่อ (DVD / USB) ในคอมพิวเตอร์ส่วนบุคคลของคุณและรีสตาร์ท
-
บูตจากสื่อ
-
เลือก ซ่อมแซมคอมพิวเตอร์ของคุณ
-
เลือก "แก้ไขปัญหา"
-
เลือก ตัวเลือกขั้นสูง
-
เลือก พร้อมท์คําสั่ง จากเมนู:
-
พิมพ์และเรียกใช้คําสั่ง:
diskpart -
พิมพ์และเรียกใช้คําสั่ง:
select disk 0 -
พิมพ์และเรียกใช้คําสั่ง:
list vol
-
-
ตรวจสอบว่าพาร์ติชัน EFI (EPS - พาร์ติชันระบบ EFI) ใช้ระบบไฟล์ FAT32 กําหนดอักษรระบุไดรฟ์ให้กับอักษรที่ไม่ได้ใช้งานอยู่แล้ว:
-
พิมพ์และเรียกใช้คําสั่ง:
select vol <number of volume> -
พิมพ์และเรียกใช้คําสั่ง:
assign letter=<drive letter> -
พิมพ์และเรียกใช้คําสั่ง:
exit
-
ถ้าคุณ ไม่มี สื่อการติดตั้ง:
-
ใช้หนึ่งในวิธีในบทความต่อไปนี้เพื่อเริ่มระบบลงในเมนูตัวเลือกการเริ่มต้นขั้นสูงของ Windows:
-
เลือก ซ่อมแซมคอมพิวเตอร์ของคุณ จากเมนูที่ปรากฏขึ้น
-
เลือก พร้อมท์คําสั่ง จากแท็บ ตัวเลือกขั้นสูง ในหน้าจอ แก้ไขปัญหา :
-
พิมพ์และเรียกใช้คําสั่ง:
diskpart -
พิมพ์และเรียกใช้คําสั่ง:
select disk 0 -
พิมพ์และเรียกใช้คําสั่ง:
list vol
-
-
ตรวจสอบว่าพาร์ติชัน EFI (EPS) ใช้ระบบแฟ้ม FAT32 และกําหนดอักษรชื่อไดรฟ์ให้กับพาร์ติชันที่ไม่ได้ใช้งานอยู่:
-
พิมพ์และเรียกใช้คําสั่ง:
select vol <number of volume> -
พิมพ์และเรียกใช้คําสั่ง:
assign letter=<drive letter> -
พิมพ์และเรียกใช้คําสั่ง:
exit
-
-
เมื่อต้องการซ่อมแซมบันทึกการบูต:
-
พิมพ์และเรียกใช้คําสั่ง:
cd /d <drive letter>:\EFI\Microsoft\Boot\ -
พิมพ์และเรียกใช้คําสั่ง:
bootrec /FixBoot
-
หน้าต่าง 10
ถ้าคุณมีสื่อการติดตั้ง:
-
ใส่สื่อ (DVD / USB) ในคอมพิวเตอร์ส่วนบุคคลของคุณและรีสตาร์ท
-
บูตจากสื่อ
-
เลือก ซ่อมแซมคอมพิวเตอร์ของคุณ
-
เลือก "แก้ไขปัญหา"
-
เลือก ตัวเลือกขั้นสูง
-
เลือก พร้อมท์คําสั่ง จากเมนู:
-
พิมพ์และเรียกใช้คําสั่ง:
diskpart -
พิมพ์และเรียกใช้คําสั่ง:
sel disk 0 -
พิมพ์และเรียกใช้คําสั่ง:
list vol
-
-
ตรวจสอบว่าพาร์ติชัน EFI (EPS - พาร์ติชันระบบ EFI) ใช้ระบบไฟล์ FAT32 กําหนดอักษรระบุไดรฟ์ให้กับอักษรที่ไม่ได้ใช้งาน):
-
พิมพ์และเรียกใช้คําสั่ง:
sel vol <number of volume> -
พิมพ์และเรียกใช้คําสั่ง:
assign letter <drive letter>: -
พิมพ์และเรียกใช้คําสั่ง:
exit
-
-
เมื่อต้องการซ่อมแซมบันทึกการบูต:
-
พิมพ์และเรียกใช้คําสั่ง:
cd /d <drive letter>:\EFI\Microsoft\Boot\ -
พิมพ์และเรียกใช้คําสั่ง:
bootrec /FixBoot
-
ถ้าคุณ ไม่มี สื่อการติดตั้ง:
-
ใช้หนึ่งในวิธีในบทความต่อไปนี้เพื่อเริ่มระบบลงในเมนูตัวเลือกการเริ่มต้นขั้นสูงของ Windows:
-
เลือก ซ่อมแซมคอมพิวเตอร์ของคุณ จากเมนูที่ปรากฏขึ้น
-
เลือก พร้อมท์คําสั่ง จากแท็บ ตัวเลือกขั้นสูง ในหน้าจอ แก้ไขปัญหา :
-
พิมพ์และเรียกใช้คําสั่ง:
diskpart -
พิมพ์และเรียกใช้คําสั่ง:
sel disk 0 -
พิมพ์และเรียกใช้คําสั่ง:
list vol
-
-
ตรวจสอบว่าพาร์ติชัน EFI (EPS) ใช้ระบบแฟ้ม FAT32 และกําหนดอักษรชื่อไดรฟ์ให้กับพาร์ติชันที่ไม่ได้ใช้งานอยู่:
-
พิมพ์และเรียกใช้คําสั่ง:
sel vol <number of volume> -
พิมพ์และเรียกใช้คําสั่ง:
assign letter=<drive letter>: -
พิมพ์และเรียกใช้คําสั่ง:
exit
-
-
เมื่อต้องการซ่อมแซมบันทึกการบูต:
-
พิมพ์และเรียกใช้คําสั่ง:
cd /d <drive letter>:\EFI\Microsoft\Boot\ -
พิมพ์และเรียกใช้คําสั่ง:
bootrec /FixBoot
-
หน้าต่าง 8 และ 8.1
ถ้าคุณมีสื่อการติดตั้ง:
-
ใส่สื่อ (DVD / USB) ในคอมพิวเตอร์ส่วนบุคคลของคุณและรีสตาร์ท
-
บูตจากสื่อ
-
เลือก ซ่อมแซมคอมพิวเตอร์ของคุณ
-
เลือก "แก้ไขปัญหา"
-
เลือก พร้อมท์คําสั่ง จากเมนู:
-
พิมพ์และเรียกใช้คําสั่ง:
diskpart -
พิมพ์และเรียกใช้คําสั่ง:
sel disk 0 -
พิมพ์และเรียกใช้คําสั่ง:
list vol
-
-
ตรวจสอบว่าพาร์ติชัน EFI (EPS - พาร์ติชันระบบ EFI) ใช้ระบบไฟล์ FAT32 กําหนดอักษรระบุไดรฟ์ให้กับอักษรระบุ (กําหนดตัวอักษรที่ไม่ได้ใช้งานอยู่แล้ว):
-
พิมพ์และเรียกใช้คําสั่ง:
sel vol <number of volume> -
พิมพ์และเรียกใช้คําสั่ง:
assign letter=<drive letter>: -
พิมพ์และเรียกใช้คําสั่ง:
exit
-
-
เมื่อต้องการซ่อมแซมบันทึกการบูต:
-
พิมพ์และเรียกใช้คําสั่ง:
cd /d <drive letter>:\EFI\Microsoft\Boot\ -
พิมพ์และเรียกใช้คําสั่ง:
bootrec /FixBoot
-
ถ้าคุณ ไม่มี สื่อการติดตั้ง:
-
รีสตาร์ทเครื่องคอมพิวเตอร์ส่วนบุคคลของคุณ
-
แตะอย่างรวดเร็วบนปุ่ม <F8> เมื่อคอมพิวเตอร์ส่วนบุคคลเปิดอยู่ แต่ก่อนที่หน้าจอเริ่มต้นของ Windows จะปรากฏขึ้น
โปรดทราบว่าการดําเนินการนี้อาจต้องใช้ความพยายามหลายครั้ง เวลาสําหรับตัวเลือกนี้สั้นลงจากใน Windows 7
-
เลือก ซ่อมแซมคอมพิวเตอร์ของคุณ จากเมนูที่ปรากฏขึ้น
-
เลือก พรอมต์คําสั่ง จากหน้าจอ แก้ไขปัญหา :
-
พิมพ์และเรียกใช้คําสั่ง:
diskpart -
พิมพ์และเรียกใช้คําสั่ง:
sel disk 0 -
พิมพ์และเรียกใช้คําสั่ง:
list vol
-
-
ตรวจสอบว่า พาร์ติชัน EFI (EPS) กําลังใช้ระบบแฟ้ม FAT32 กําหนดอักษรระบุไดรฟ์ให้กับอักษรระบุ (กําหนดตัวอักษรที่ไม่ได้ใช้งานอยู่แล้ว):
-
พิมพ์และเรียกใช้คําสั่ง:
sel vol <number of volume> -
พิมพ์และเรียกใช้คําสั่ง:
assign letter=<drive letter>: -
พิมพ์และเรียกใช้คําสั่ง:
exit
-
-
เมื่อต้องการซ่อมแซมบันทึกการบูต:
-
พิมพ์และเรียกใช้คําสั่ง:
cd /d <drive letter>:\EFI\Microsoft\Boot\ -
พิมพ์และเรียกใช้คําสั่ง:
bootrec /FixBoot
-
วินโดวส์ 7
ถ้าคุณมีสื่อการติดตั้ง:
-
ใส่สื่อ (DVD / USB) ในคอมพิวเตอร์ส่วนบุคคลของคุณและรีสตาร์ท
-
บูตจากสื่อ
-
เลือก ซ่อมแซมคอมพิวเตอร์ของคุณ
-
เลือกระบบปฏิบัติการ และคลิก ถัดไป
-
เลือก พร้อมท์คําสั่ง จากเมนู:
-
พิมพ์และเรียกใช้คําสั่ง:
diskpart -
พิมพ์และเรียกใช้คําสั่ง:
sel disk 0 -
พิมพ์และเรียกใช้คําสั่ง:
list vol
-
-
ตรวจสอบว่าพาร์ติชัน EFI (EPS - พาร์ติชันระบบ EFI) ใช้ระบบไฟล์ FAT32 กําหนดอักษรระบุไดรฟ์ให้กับอักษรที่ไม่ได้ใช้งานอยู่แล้ว:
-
พิมพ์และเรียกใช้คําสั่ง:
sel vol <number of volume> -
พิมพ์และเรียกใช้คําสั่ง:
assign letter=<drive letter>: -
พิมพ์และเรียกใช้คําสั่ง:
exit
-
-
เมื่อต้องการซ่อมแซมบันทึกการบูต:
-
พิมพ์และเรียกใช้คําสั่ง:
cd /d <drive letter>:\EFI\Microsoft\Boot\ -
พิมพ์และเรียกใช้คําสั่ง:
bootrec /FixBoot
-
ถ้าคุณ ไม่มี สื่อการติดตั้ง:
-
รีสตาร์ทเครื่องคอมพิวเตอร์ส่วนบุคคลของคุณ
-
แตะอย่างรวดเร็วบนปุ่ม <F8> เมื่อคอมพิวเตอร์ส่วนบุคคลเปิดอยู่ แต่ก่อนที่หน้าจอเริ่มต้นของ Windows จะปรากฏขึ้น
-
เลือก ซ่อมแซมคอมพิวเตอร์ของคุณ จากเมนูที่ปรากฏขึ้น
-
เลือก พร้อมท์คําสั่ง จาก ตัวเลือกการกู้คืน
-
พิมพ์และเรียกใช้คําสั่ง:
diskpart -
พิมพ์และเรียกใช้คําสั่ง:
sel disk 0 -
พิมพ์และเรียกใช้คําสั่ง:
list vol
-
-
ตรวจสอบว่า พาร์ติชัน EFI (EPS) กําลังใช้ระบบแฟ้ม FAT32 และกําหนดอักษรชื่อไดรฟ์ให้กับพาร์ติชันที่ไม่ได้ใช้งานอยู่
-
พิมพ์และเรียกใช้คําสั่ง:
sel vol <number of volume> -
พิมพ์และเรียกใช้คําสั่ง:
assign letter=<drive letter>: -
พิมพ์และเรียกใช้คําสั่ง:
exit
-
-
เมื่อต้องการซ่อมแซมบันทึกการบูต:
-
พิมพ์และเรียกใช้คําสั่ง:
cd /d <drive letter>:\EFI\Microsoft\Boot\ -
พิมพ์และเรียกใช้คําสั่ง:
bootrec /FixBoot
-
Windows 11 และ Windows 10 (เวอร์ชัน 1709 และใหม่กว่า):
-
สร้างร้านค้า BCD ใหม่
-
ก่อนอื่นให้เรียกใช้คําสั่งด้านล่างเพื่อสํารองข้อมูล BCD เก่า:
ren BCD BCD.bak -
ตอนนี้สร้างใหม่โดยใช้คําสั่งนี้:
bcdboot c:\Windows /s <boot letter>: /f ALL(คุณสามารถเพิ่มสวิตช์ก่อน/sสําหรับตําแหน่งที่ตั้งของคอมพิวเตอร์:/l <language code>. โดยค่าเริ่มต้นจะใช้/l en-usภาษาอังกฤษสหรัฐอเมริกา) -
bootrec /rebuildbcd
-
Windows 10 (ก่อนเวอร์ชัน 1709), Windows 8 และ Windows 7:
-
สร้างร้านค้า BCD ใหม่
-
ก่อนอื่นให้เรียกใช้คําสั่งด้านล่างเพื่อสํารองข้อมูล BCD เก่า:
ren BCD BCD.old -
ตอนนี้สร้างใหม่โดยใช้คําสั่งนี้:
bcdboot c:\Windows /l en-us /s <boot letter>: All
-
วิธีซ่อมแซมบันทึกการบูตหลักของคุณ (MBR)
ขั้นตอนเหล่านี้ใช้กับไดรฟ์รุ่นเก่าที่ใช้เป็นไดรฟ์สําหรับเริ่มระบบบนระบบปฏิบัติการ Windows ล่าสุด
-
ใช้ปุ่ม F12 ที่หน้าจอ Dell Splash เพื่อเข้าสู่เมนูการบู๊ต ช่วยให้คุณบูตจากสื่อการติดตั้ง Windows หรือดิสก์ที่สามารถบู๊ตได้หรือแฟลชไดรฟ์
-
คลิกลิงก์ซ่อมแซมคอมพิวเตอร์ของคุณที่ด้านล่างของหน้าจอติดตั้งทันที
-
คลิก แก้ไขปัญหา
-
เลือก พรอมต์คําสั่ง
-
ป้อนคําสั่งสามคําสั่งต่อไปนี้ตามลําดับโดยกดปุ่ม Enter :
bootrec /fixmbrbootrec /fixbootbootrec /rebuildbcd -
รีสตาร์ทคอมพิวเตอร์โดยเอาสื่อการติดตั้งออกเพื่อตรวจสอบว่าการซ่อมแซมทํางานหรือไม่
หากคุณต้องการความช่วยเหลือเพิ่มเติม โปรดติดต่อฝ่ายสนับสนุนด้านเทคนิค
| ติดต่อเรา |
Additional Information
ไม่อยู่ภายใต้การรับประกัน? ไม่มีปัญหา เรียกดูเว็บไซต์ Dell.com/support และป้อนป้ายบริการของ Dell และดูข้อเสนอของเรา