NVP vProxy : Échec des sauvegardes de VM avec le message « aucun appareil correspondant à l’enregistrement du nom du client « vCenter Name » : vérifier les nœuds de stockage, les appareils ou les pools »

Summary: La sauvegarde échoue sur les machines virtuelles protégées par l’appliance NVP vProxy. Le journal d’actions de sauvegarde indique « aucun appareil correspondant à l’enregistrement du nom vCenter du client : vérifiez les nœuds de stockage, les périphériques ou les pools » ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • La sauvegarde de la machine virtuelle échoue peu de temps après le démarrage avec l’erreur suivante consignée dans le journal des actions de la console de gestion NetWorker :
DD/MM/YYYY HH:MM:SS Unable to process VM 'VM_NAME': no matching devices for save of client `VCENTER_NAME' check storage nodes, devices or pools
DD/MM/YYYY HH:MM:SS VM_NAME: Backup failed
Remarque : Cette erreur peut s’afficher pour d’autres types de sauvegarde (système de fichiers, base de données, etc.). Les étapes de cet article de la base de connaissances peuvent être utilisées pour résoudre ce problème.

Cause

Il ne s’agit pas d’un problème vProxy. La panne se produit lors de la sélection de l’appareil. Le workflow n’est pas en mesure de rapprocher un appareil utilisable. Soit il existe un problème de communication entre le NetWorker Server, le nœud de stockage et le périphérique existants, soit il existe un conflit de configuration potentiel.

Resolution

1. Ouvrez une session sur la NetWorker Management Console (NMC).
2. Accédez à Protection-Policies>, puis sélectionnez Workflow dans le menu de gauche.
3. Notez le pool et le nœud de stockage configurés dans l’action de sauvegarde du workflow :

Pool et nœud de stockage définis dans l’action de sauvegarde

4. Accédez à Media-Media>Pools et ouvrez les propriétés du pool utilisé par le workflow.
5. Dans l’onglet Selection Criteria, notez tous les périphériques cochés. Si certains appareils sont cochés, cela signifie que le pool est limité à l’utilisation de ces appareils uniquement. 

Critères de sélection des pools

Remarque : Le périphérique doit être de type Data Domain. Pour une protection VMware à l’aide de plusieurs périphériques dans un seul pool, chaque périphérique doit résider dans le même hôte Data Domain.

6. Accédez à Devices-Devices> et vérifiez que les périphériques cochés dans les critères de sélection sont montés. Un périphérique monté affiche un libellé de volume. 

L’appareil est monté

Remarque : Si la colonne Volume Name est vide, le périphérique est démonté. Cliquez avec le bouton droit de la souris sur le périphérique et sélectionnez Monter. Surveillez la fenêtre Log et Alerts pour détecter d’éventuels problèmes de montage du périphérique.

7. Ouvrez les propriétés du périphérique et assurez-vous que la case « lecture seule » est désactivée :

La case Lecture seule de l’appareil est désactivée

8. Accédez à Media-DiskVolumes, assurez-vous> que le volume est modifiable.

Le volume de disque est modifiable

9. Accédez à Devices-Storage>Nodes et vérifiez que le nœud de stockage indiqué à l’étape 3 est à l’état « Ready » :

Le nœud de stockage NetWorker est prêt et activé

REMARQUE : nsrserverhost est le nœud de stockage local du NetWorker Server. Tous les périphériques affichés avec un préfixe rd= signifient qu’ils sont configurés via un nœud de stockage NetWorker « distant ». 

10. Accédez à Protection-Clients> et ouvrez les propriétés client de la ressource client de vCenter Server.
11. Dans l’onglet Globaux (2 sur 2), assurez-vous que les entrées de nœud de stockage existent pour les nœuds de stockage utilisés lors des sauvegardes de machines virtuelles de ce vCenter. Plusieurs nœuds de stockage peuvent être répertoriés, à raison d’une entrée par ligne.

image.png

Remarque : Le mode View-Diagnostic> doit être activé pour afficher les spécifications des nœuds de stockage dans les propriétés du client.

Additional Information

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000200894
Article Type: Solution
Last Modified: 19 Mar 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.