ECS: Certificate upload Error: "Kan de persoonlijke sleutel niet laden"

Summary: De klant heeft een persoonlijke sleutel opgegeven die niet kan worden geüpload met het bericht 'Kan de persoonlijke sleutel niet laden'. Er zijn klanten die CSR genereren buiten het ECS om en een ondertekende certificaatbundel samen met de persoonlijke sleutel leveren. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Een snelle manier om het sleutelbestand te controleren, is door de certificaatmodules van het ondertekende certificaat en de verstrekte persoonlijke sleutel te vergelijken.
1. okt. De modulus van het servercertificaat en de persoonlijke sleutel moet hetzelfde zijn.
Opdracht om de certificaatmodulus te verifiëren.
openssl x509 -noout -modulus -in < server certificate > | openssl md5
Opdracht om de persoonlijke sleutelmodulus te verifiëren.
openssl rsa -noout -modulus -in <private-key> | openssl md5
2. Controleer de kop- en voettekst van de persoonlijke sleutel.
Voorbeeld:
-----BEGIN RSA PRIVATE KEY-----

       Private Key Hash

-----END RSA PRIVATE KEY-----
Er zijn echter privésleutelindelingen die er identiek uitzien als de PEM-indeling wanneer we deze openen met behulp van de Linux-cat-opdracht.

Cause

De indeling van de persoonlijke sleutel kan afwijken van wat in ECS wordt verwacht.

Resolution

Als de certificaatmodules van het servercertificaat en de persoonlijke sleutel overeenkomen en de indeling van de persoonlijke sleutel vergelijkbaar is met de PEM-indeling. Het is het proberen waard om de sleutel tot PEM te verbergen met behulp van de onderstaande opdracht.
Gebruik de onderstaande opdracht om de opgegeven persoonlijke sleutel te converteren naar de PEM-indeling.
openssl rsa -in <private key> -out <private-key.pem>
Article Properties
Article Number: 000216155
Article Type: Solution
Last Modified: 09 Feb 2024
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.